-   Linux - Newbie (
-   -   How do I setup Dell Wireless 1395 WLAN mini card for Linux RHEL4.8 for Workstation ? (

RPeruzzi 06-20-2009 03:33 PM

How do I setup Dell Wireless 1395 WLAN mini card for Linux RHEL4.8 for Workstation ?
I have a Dell Vostro 1510 Laptop with a built-in Dell Wireless 1395 WLAN Mini Card. I installed the RHEL 4.8 for Workstation version of Linux. I installed Linux completely on an external drive to keep Linux and XP completely isolated.

Linux is basically working but with some sore spots -- including the wireless LAN. I purchased RedHat basic service, but after a week of playing one-message-per-day email ping-pong with me they said "Ain't my job, man", because RedHat doesn't supply that driver.

Searching the forums I see some hints and several somewhat detailed workarounds but I haven't succeeded in putting them together and getting them to work. (I don't understand some of the suggestions that were given.)

Can someone point me to a sequence of newbie-level instructions to find, download and install the proper WLAN driver?


Bob P.

farslayer 06-22-2009 08:20 AM

I believe that wireless card uses the Broadcom STA driver..

You can verify by using lspci at the command prompt, it should show a Broadcom bcm4311 I believe, for that wireless card.

Here is dells notification of Broadcom Supplying the driver.


Linux driver available for Dell Wireless cards

Christopher Tozzi's blog from Thursday reminded me of the announcement that I never made: Linux driver support is now available to Dell-branded wireless cards. We started working closely with Broadcom early this year on providing this support, as our customers have been asking for a Linux driver for our cards for a while now. As a result of this effort, Broadcom released an updated Linux wireless driver that supports cards based on the Broadcom 4311, 4312, 4321, and 4322 chipsets, which include the Dell 1490, 1395, 1397, 1505, and 1510 Wireless cards. This driver is included in the Ubuntu 8.10 release, and should be added to Ubuntu 8.04. It is currently only partially open-source, similar to ATI or NVIDIA video drivers, so keep this in mind when deciding if you want to use it. For those who want to try it out immediately, the driver can be downloaded from here.
The install directions should be in a README or INSTALL file along with the driver

RPeruzzi 06-23-2009 11:52 AM

Thanks for your response. Details are enough for me to follow. Have a great week!

RPeruzzi 06-23-2009 02:50 PM

What to substitute for <2.6.xx.xx>?
Thanks again for the link to the driver and README file. I've downloaded and un-tarred the package. Again, exposing my newbie status, I don't understand the README instruction:

"You use the standard Linux 2.6 kernel build system as follows to make a Linux loadable
kernel module (LKM):"


4. Cleanup (optional): make -C /lib/modules/<2.6.xx.xx>/build M=`pwd` clean
5. Build the LKM, i.e. wl.ko: make -C /lib/modules/<2.6.xx.xx>/build M=`pwd`

I suppose I should know right off the top of my head what I should substitute for <2.6.xx.xx> but I don't.

So I look via:

$ ls /lib/modules
2.6.9-89.EL 2.6.9-89.ELhugemem 2.6.9-89.ELsmp kabi-4.0-0 kabi-4.0-0smp

and I see 2.6.9-89 is a likely suspect, but it doesn't quite fit the template. But I try it anyway in:

$ make -C /lib/modules/2.6.9-89/build M=`pwd` clean
make: *** /lib/modules/2.6.9-89/build: No such file or directory. Stop.

Obviously I'm on the wrong track, and taking wild guesses.

What should I substitute for <2.6.xx.xx>?
Where should I have looked for the answer on my own?


Bob P.

farslayer 06-23-2009 03:09 PM

uname -r should give you the proper kernel version to use..

Looks like you may not have the kernel headers installed..
yun install kernel-devel

the first thing I see when it builds the module is it switching into the kernel headers directory.


it-lenny:/home/lusername/temp/STA$ uname -r

it-lenny:/home/lusername/temp/STA$ make -C /lib/modules/2.6.18-6-686/build M=`pwd`
make: Entering directory `/usr/src/linux-headers-2.6.18-6-686'
  LD      /home/lusername/temp/STA/built-in.o
  CC [M]  /home/lusername/temp/STA/src/wl/sys/wl_linux.o
  CC [M]  /home/lusername/temp/STA/src/wl/sys/wl_iw.o
  CC [M]  /home/lusername/temp/STA/src/shared/linux_osl.o
  LD [M]  /home/lusername/temp/STA/wl.o
  Building modules, stage 2.
  CC      /home/lusername/temp/STA/wl.mod.o
  LD [M]  /home/lusername/temp/STA/wl.ko
make: Leaving directory `/usr/src/linux-headers-2.6.18-6-686'

wl.ko that's the file we were building so this looks like a success..

unfortunately the error provided to you, didn't really show you that it wasn't finding the kernel headers
(at least I believe that's what your problem is)

Let us know if you run into any further difficulties.

RPeruzzi 06-23-2009 04:56 PM

Further progress to next roadblock
Thanks again, farslayer.

Your suggested command:
uname -r

So I will repeat the steps I took before your response appeared and see if it will get me past the roadblock I hit.

Before seeing your most recent response I did some Google searching for "<2.6.xx.xx>" and from it, tried an educated guess and used the commands:

4. Cleanup (optional):
make -C /lib/modules/2.6.9-89.EL/build M=`pwd` clean
5. Build the LKM, i.e. wl.ko:
make -C /lib/modules/2.6.9-89.EL/build M=`pwd`

There were no errors or warnings and all the expected files were created.

Continued with remaining steps:

1. Validate you don't have loaded (or built into the kernel) the Linux community provided
driver for Broadcom hardware. This exists in two forms: either "bcm43xx" or a split form
of "b43" plus "b43legacy". If these modules were loaded you would either
a) rmmod bcm43xx or
b) rmmod b43; rmmod b43legacy
Results: GOOD -- found and removed bcm43xx*

1a. Validate you don't have a older wl.ko driver loaded from previous install.
If the module exist, remove it and replace with new driver:
a) rmmod wl.ko
Results: GOOD -- used "find /. -name wl.ko" and the only instance of it was the one I just generated.

2. Replacing existing driver with wl.ko just build in step 5 above.
(most likely path to find wl.ko is: /lib/modules/2.6.9-89.EL/kernel/driver/net/wireless
or /lib/modules/<kernel_version>/
Results: Not Applicable. But I did verify the actual path for me is
i.e. drivers, not driver

3. depmod
Results: Unknown.
Logged in as root and used /sbin/depmod
There was a pause before command finished but no output text

4. modprobe wl
Results: Bad.
Tried this both as root and normal login.
/sbin/modprobe wl
Text output:
FATAL: Module wl not found.
This guess produced the identical error message.
/sbin/modprobe wl.ko
I also tried copying wl.ko into the wireless directory:
cp wl.ko /lib/modules/2.6.9-89.EL/kernel/drivers/net/wireless/wl.ko
Then executed
/sbin/modprobe wl
and got the same FATAL message. Final attempt was
/sbin/modprobe /lib/modules/2.6.9-89.EL/kernel/drivers/net/wireless/wl.ko
and of course, got that same message.

As I said, I will repeat the sequence using the output from uname -R,
and report the outcome.

Thanks for helping.

Bob P.

RPeruzzi 06-23-2009 05:32 PM

Identical results using 2.6.9-89.ELsmp for <>
Many thanks to farslayer, by the way,for previous help. I'm editing my most recent posting because I found the solution to that final problem. By Googling for "Error for wireless request Set Encode (8B2A)" I figured out that I hadn't copied my wireless router information and key over to my WLAN configuration. This should get me up and running. Disregard the message below, left in only for reference.

Best regards,

Bob P.

=============== OLD ==================
Breakthrough, but still not up and running.

I replaced <2.6.xx.xx> with the output of command uname -r which is

With that, after a couple of false starts, I figured out how to follow all the rest of the steps. When I rebooted, the "new" driver hardware was found and I configured it using all defaults.

From the RedHat environment:
Applications > System Tools > Network Device Control

When I activate the WLAN I get this message in a pop-up:

Error for wireless request "Set Encode" (8B2A) :
SET failed on device eth1 ; Invalid argument.

Determining IP information for eth1...

But but it finishes activating, the pop-up disappears and it appears to be active in the Network Device Control window.

However, I can't connect to the internet through it.

I wonder if other than defaults should be used for configuring the WLAN, and if so, where do I find the right parameters for it.

Bob P.

All times are GMT -5. The time now is 03:06 PM.