LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How do I mount a 2nd CD drive??? (https://www.linuxquestions.org/questions/linux-newbie-8/how-do-i-mount-a-2nd-cd-drive-359074/)

phreakshew 09-01-2005 05:31 AM

How do I mount a 2nd CD drive???
 
:Pengy: Hello! I am running Debian, and the computer came with 1 CDROM. I purchased a CDRW today and installed it, setting the jumpers to Master and the old CDROM to Slave.

Now what???

I have been researching this all night and only have partial information.

etc/fstab reads:
/dev/hda1 /boot ext3 defaults 0 2 #size=100
/dev/hda2 none swap sw 0 0 #size=250
/dev/hda3 / ext3 defaults,errors=remount-ro 0 1 #size=remaining
/dev/fd0 /floppy auto defaults,user,noauto 0 0
/dev/cdrom /cdrom iso9660 defaults,rw,user,noauto 0 0
proc /proc proc defaults 0 0

Am I correct to add this line?:
/dev/cdrom1 /cdrom1 iso9660 defaults,ro,user,noauto 0 0

I read something about having to compile a kernal... Since I already have a CDROM do I need to do this?

I understand I need to mount the device, but am still unsure of what to do.

Please HELP!!! Thank you very much.
:Pengy:

mrosati 09-01-2005 06:00 AM

hi.
what you have to do is to ensure that /dev/cdrom1 (the new cdrw) really exists in the /dev directory. surely /dev/cdrom (the cdrom you altrady have) is a symbolic link to a device. you should discover where this link points (ls -l /dev/cdrom). it should point to /dev/hdb or hdc, it dipends where you plugged the drive. please do this and post it here!
bye

phreakshew 09-01-2005 07:01 AM

$ ls -l /dev/cdrom
lrwxrwxrwx 1 root root 11 Jul 22 13:05 /dev/cdrom -> /dev/cdrom0
is what I get...

If I use Konqueror to get to file:/dev I find 2 italicized entries:
cdrom is a link to dev/cdrom0, and
cdrom0 is a link to dev/hdc.

I haven't added the line for cdrom1 in etc/fstab yet because I wasn't sure if I'm supposed to do it now (or at all) or wait til later....

ready 4 next nugget of information- & thanx 4 the help!!!

mrosati 09-01-2005 07:28 AM

ok, if /dev/cdrom points to /dev/hdc, i am quite sure that the new cd drive points to /dev/hdb or /dev/hdd. try to check them, try to add either

/dev/hdd <mount_point> iso9660 ro,user,noauto 0 0

or

/dev/hdb <mount_point> iso9660 ro,user,noauto 0 0

then

#mount -a

and then try to mount the cdrom drive.

phreakshew 09-01-2005 08:36 AM

ok- just to be sure I did thid right so far--

I added:

/dev/hdd /cdrom1 iso9660 ro,user,noauto 0 0

to the fstab list, then exited and at a root prompt typed:

mount -a

Is that right? - If so, then great! And now how exactly do I try to mount the device?

m_yates 09-01-2005 08:43 AM

To mount the second device:
Code:

mount
/dev/hdd /cdrom1

you may also have to make the mount directory if it doesn't exist:
Code:

mkdir /cdrom1

phreakshew 09-01-2005 08:51 AM

ok! 1st I typed: mkdir /cdrom1

2nd I typed: mount /dev/hdd /cdrom1

Computer said: mount: you must specify the filesystem type

phreakshew 09-01-2005 08:59 AM

I just tried: mount -t iso9660 /dev/hdb /cdrom

and the computer responded:
Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .

phreakshew 09-01-2005 09:10 AM

I think I did it...?

I went to desktop and clicked create new / device / cdrom device
and clicked on device tab and selected /dev/hdd (/cdrom1) and clicked ok

then I put a cdrom disk in the drive and clicked on the new icon and whaddya know-? It loaded!

Yahoooooooooo!-

Now, is that all I have to do?

What about audio discs? There are 2 icons on the desktop relating to the other (CDRW) - one labeled cdrom and the othe labeled audio cd... Do I need to do something to let audio cds play from both cd drives or should I only let 1 drive play audio?

Thanx again for your help!

mrosati 09-01-2005 01:55 PM

i hope i have well understood your question...

1)you want to play 2 audio cd at the same time one in the cdr and the other in the cdrw? i don't know if you can do that, never tried.

2)you are asking if it's the same to play an audio cd either from the cdr or the cdrw? well yes, it's the same thing. you just have to specify the source cd, for example in the configure panel of KsCD.

cheers

phreakshew 09-01-2005 04:27 PM

yes, my question was, is it the same to play an audio cd either from the cdr or the cdrw?

I tried to specify the source cd by going to the configure panel of KsCD and changing the source from dev/cdrom to dev/hdd- and again with dev/cdrom1... Both times I got a message saying:

CD-ROM read or access error (or no audio disc in drive).
Please make sure you have access permissions to:
/dev/cdrom1 (or) /dev/hdd.

I guess I need to grant access permissions to that drive-? I thought I already did that..... Anyways- I really appreciate your help!

mrosati 09-01-2005 05:05 PM

hmmm ok try this, substitute:

Code:

/dev/hdd /cdrom1 iso9660 ro,user,noauto 0 0
with

Code:

/dev/hdd /cdrom1 iso9660 ro,users,noauto 0 0
please notice the difference from user and userS and then tell me.

bye

kencaz 09-01-2005 05:34 PM

Quote:

Originally posted by phreakshew
yes, my question was, is it the same to play an audio cd either from the cdr or the cdrw?

I tried to specify the source cd by going to the configure panel of KsCD and changing the source from dev/cdrom to dev/hdd- and again with dev/cdrom1... Both times I got a message saying:

CD-ROM read or access error (or no audio disc in drive).
Please make sure you have access permissions to:
/dev/cdrom1 (or) /dev/hdd.

I guess I need to grant access permissions to that drive-? I thought I already did that..... Anyways- I really appreciate your help!

Hmm, KsCD should automatically determine the drive your using for an Audio CD... Mine will play wheather I use my /dev/hdc or /dev/hdd but the default is /dev/hdd

I however, use Mplayer which is a diff story... the cdda option in mplayer has a default and mine is /dev/hdc and I play audio CD's using:

mplayer cdda://2

This will play track #2 of my audio CD in my CDRW drive /dev/hdc

This:

mplayer cddb://2 -cdrom-device /dev/hdd

will play the same track but in my CDROM drive /dev/hdd but it must be specified as such...

KC

phreakshew 09-01-2005 05:47 PM

I tried both dev/hdd /cdrom1 iso9660 ro,user,noauto 0 0
and /dev/hdd /cdrom1 iso9660 ro,users,noauto 0 0

and got: CD-ROM read or access error (or no audio disc in drive).
Please make sure you have access permissions to:
/dev/cdrom1 (or) /dev/hdd.

both times...blah.

bosewicht 09-01-2005 07:31 PM

are you able to play audio cd's as root on the cdrw?


All times are GMT -5. The time now is 08:42 PM.