LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-05-2004, 06:53 PM   #1
DrD
Member
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 99

Rep: Reputation: 15
How do I switch to gnome in Suse 9.0?


I have searched and googled around a lot and haven't figured out how to make my default wm gnome instead of KDE. How do I do this? I just installed Suse 9.0.

Last edited by DrD; 02-05-2004 at 10:24 PM.
 
Old 02-05-2004, 06:59 PM   #2
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
one way might be to make gnome the default in your ~/.xsessions file. how do you start kde now? do you do startx, or do you use a display manager?
 
Old 02-05-2004, 07:05 PM   #3
DrD
Member
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 99

Original Poster
Rep: Reputation: 15
At this moment in time, KDE just starts automatically. Where is this ~/.xsessions file, and when I edit it, what exactly do I change?
 
Old 02-05-2004, 07:15 PM   #4
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
~ is you home folder
~/.filename is a hidden file in your home folder
 
Old 02-05-2004, 07:20 PM   #5
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
what about a ~/.xinitrc file, do you have one of those? (the ~/ means your /home/<user> directory, btw, and the dot in front of the file means it's "hidden").

>had that one on screen too long.

anyway, i thought it might be ~/.xinitrc, but i just checked my debian box, and ~/.xsession is the file that used to automatically start my gui there, while ~/.xinitrc is on my slackware box, and doesn't start X automatically but needs startx. so if you have ~/.xsession, just comment out any line starting KDE, and add a line to start gnome, probably something like:

# exec KDE
exec gnome-session

if you don't have that file, KDE might be starting some other way, e.g., through a session manager, but i don't use either one of those or KDE, so someone else will have to chime in with info on how to change that. gl

Last edited by synaptical; 02-05-2004 at 07:28 PM.
 
Old 02-05-2004, 07:28 PM   #6
DrD
Member
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 99

Original Poster
Rep: Reputation: 15
Thanks. Now, when I edit this file, what do I change?
(I'm at work, I'm just asking so that when I get home, I know what to do)

EDIT: ok, when I get home I can try that.

Last edited by DrD; 02-05-2004 at 07:34 PM.
 
Old 02-05-2004, 10:16 PM   #7
DrD
Member
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 99

Original Poster
Rep: Reputation: 15
I'm home now. I tried to open .xsessions and .xinitrc within an editor, and neither file could be found.
Anyone else know how to switch from KDE to gnome (in suse?)
 
Old 02-05-2004, 10:29 PM   #8
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
just make a .xinitrc file, and put "exec gnome-session" in it. then logout of kde, and go to /etc/X11/xinit and run the file with the name of gnome in it: ./xinitrc-gnome
 
Old 02-05-2004, 10:36 PM   #9
DrD
Member
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 99

Original Poster
Rep: Reputation: 15
Will that make gnome start up automatically as my wm?
 
Old 02-05-2004, 10:48 PM   #10
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
putting it in .xinitrc (or making .xinitrc) should do that, afaik. try it though and post back if it doesn't work.

p.s. check in a terminal first to make sure you don't have the file. in your home directory, type:

ls -a

and see if .xinitrc shows up. depending on what editor and options you used, hidden files might not show up there.

Last edited by synaptical; 02-05-2004 at 10:50 PM.
 
Old 02-07-2004, 01:30 AM   #11
DrD
Member
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 99

Original Poster
Rep: Reputation: 15
Thanks. What you suggested worked - but it turned out suse didn't install gnome after all (I thought I saw gnome packages during the installation). I reinstalled suse and made sure to include gnome this time around, and also to not bypass the login screen. Now I can choose sessions right at the prompt. Anyhow, thanks. At least I know something I didn't before.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to make it a default application? jethind Linux - Newbie 8 11-17-2005 07:36 AM
my kde session keeps changing to gnome, how do i make it my default? mojarron Slackware 6 03-19-2005 10:24 PM
How to Make Firefox Default vsj Linux - Software 11 03-19-2004 06:13 PM
Make default Gnome mairul Linux - Newbie 1 03-02-2004 04:19 AM
9.2 make KDE default?? c_olin3404 Mandriva 7 01-08-2004 07:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration