-   Linux - Newbie (
-   -   How do I install Red Hat 9 Linux onto my PC (

Lordlava 12-31-2008 01:40 AM

How do I install Red Hat 9 Linux onto my PC
I want to install Red Hat 9 Linux onto my system.

I currently have two PCs that run Windows.

The older one is an Athalon 2600 and runs Windows XP. It has a 2nd disk drive (60Gb) that I am clearing to install Linux.

The newer one is a Quad Core running Vista. It has a 2nd disk drive that I have partitioned to have 200Gb free for Linux.

I need to find, download and install Red Hat 9 to be able to run and modify an application.

I have found some sites that have Red Hat 9 (sometimes called Fedora I believe) but I do not know which version of it to download (ppc, x86, i386 etc).

For want of a better choice I downloaded the two iso files for the x86 version
Fedora-9-x86_64-Live.iso and
Fedora-9-x86_64-Live-KDE.iso and
redhat-config-date-1.5.15-1.noarch.rpm and

It said something about converting these iso files to disk images before trying to install and did not mention how to do that or what to do with the other two files (rpm and mht).

Once I have the correct disks I want to install Red Hat 9 onto the two PCs.

Presumably I will have to format the selected drives and hopefully it will do so automatically.

Then I can start doing some damage to the system itself.

So is there an easy way to find out what steps I have to take to download the correct files, set them up as install disks (assuming I have to do this) and install the system?

I would appreciate any help or advice I can get.

billymayday 12-31-2008 01:51 AM

RH9 is an out of date distro that led to Fedora Core 1. We are now up to Fedora 10 (no longer referred to as core as of F7).

First thing would be to work out exactly what you need.

If you actually require RH9, you will find it on the downloads on this site. I doubt you want RH9. Go for i386 would be my suggestion.

If not, you can stick with what you have. The difference between the live-iso and live kde-iso is just the window manager - the former is gnome, the latter is kde. If you've got no idea what I mean, you can choose either, it's a preference thing, and perhaps look at both - you might love one and think the other sucks.

Once you have an iso, you need to burn it. I use nero from windows, and it has an option to burn a disk image to a disk. Whatever dick utility you use, you need to find an option to burn an image.

Once burnt, stick it back in the drive. If there's the fedora....iso there, you got it wrong and burnt the iso as a file. If there are a number of files there, you got it right.

Boot with the cd in the drive, and follow the instructions. End of story.

Good luck

Lordlava 12-31-2008 03:47 AM

Thanks for the very fast response.

I have been told that I need RH9 as that is the platform that the system runs on, being fairly dated by now.

I have started downloading the iso files for the 386 version and will follow your advice.

The first small steps on a journey.

Thanks for your help.

billymayday 12-31-2008 04:01 AM

Just be aware that you may have problems with newer hardware, since most of the drivers are in the kernel


IBall 12-31-2008 06:46 AM

Since Redhat 9 is very ancient, I doubt you will get it installed on any reasonably new hardware. It doesn't support common things such as SATA (meaning it likely won't recognise your hard drive).

My suggestion would be to install VMWare Server on the better machine. Then install Redhat 9 in a Virtual Machine, which is more likely to work.

If you want to play around with Linux (ie: for your own knowledge), then install a more recent distro.


Lordlava 01-01-2009 11:12 AM

I successfully downloaded the 3 shrike-i386 discs for the Red Hat 9 Linux and installed the on the old Athalon and it has worked. I very much appreciate your help and I am impressed at the speed of the replies.

I have not yet tried it on the Quad Core which incidentally has a two SATA drives so I guess that may cause a problem. I will research the VM Ware issue once I have mastered the basics on the older PC.

I am in the process of downloading the application to test it.

Not sure how to note a thanks against someone but I would do it if I knew how.

On a side note many of the links no longer work on
The Main CDs links failed as did the ones from France.
2 of the 3 Germany links worked but the Germany ISO 1 was corrupted so I picked up the HK disk 1.


XavierP 01-01-2009 01:00 PM

Could you alert the maintainers of which ones don't work please. The link to report them is

billymayday 01-01-2009 04:07 PM

The thumbs up icon is the thank you button.

Lordlava 01-02-2009 09:24 AM

Next stage - Installation and compilation
By the way, I did send a message to the link on the forum to say I could not get them working, before I posted here. I should have mentioned that.

Next steps

I have successfully downloaded the application in the form of packagename.tar.gz.

I can double click on it and the folder structure is
and a series of .c and .h files and a few others
Extract partially fails
When I extract using the Extract button from the Filer Roller windows everything gets extracted except the .dat .obj .save and .tmp folders. The folders and files are extracted under /home in the structure listed above.

It tried to extract it also on the command line using
gzip -d -c packagename.tar.gz | tar xf-
gzip -d -c packagename.tar.gz
and various combinations of this but the results was the same. The 4 folders are still missing.
I will need them to set up and run the system.

I can successfully compile an individual .c file into a .o file using
gcc file.o -o file
but I can not compile multiple simultaneously. I get a message saying "too many files"
As there are over 100 files to compile it would be nice if I can do them all together or at least in groups.

I am assuming the .o file is a compiled and executable object.

Assuming I am successful in compiling the .c files and moving them into the .obj folder and finding the missing folders, how do I run the system. I was expecting to see a main.o or packagename.o file for me to execute. Any tips would be appreciated.

So I have 3 questions
1) How to I extract the recalcitrant folders that are there but don't want to come out.
2) How do I compile the 100 odd .c programs and am I correct in assuming that .o files are the final executable state.
3) How do I identify which of the 100 executable files is the main one that starts the system?

IBall 01-02-2009 10:18 PM


Originally Posted by Lordlava (Post 3394502)
So I have 3 questions
1) How to I extract the recalcitrant folders that are there but don't want to come out.
2) How do I compile the 100 odd .c programs and am I correct in assuming that .o files are the final executable state.
3) How do I identify which of the 100 executable files is the main one that starts the system?

1) Not sure. I normally use "tar -xzvf archiveName.tar.gz".

2) Normally, you can compile using (from within the directory that was created when you unzipped the archive):

make install

make install should be run as root. The .o files are object files. They are an intermediate step between code and being fully compiled and linked.

3) It will probably be the name of the system. Check the documentation for whatever program to find out what it is called.


Lordlava 01-03-2009 03:58 AM

Thanks Ian.

1) Your manual method successfully extracted the missing folders and files. I do not understand why the window extract button did not work but I can now get past that step.

2) The ./configure command fails as does the Make command.

./configure gives no such file or directory
make gives nothing can be done for "all"
all: newserver password xxx happens to be the beginning of the first line in the Makefile
However you have set me on the right path and I am now exploring the GNU Make Manual to find out why the supplied Makefile causes me an error on line 1. I will also try to explore why the ./configure command fails (maybe they are related) but this will keep me busy on the webs for a few hours.

3) In the Makefile I discovered what I think is the name of the final executable code called "newserver". There is a 1.5Mb file in the folder with that name. Needless to say with my luck, I tried to type that in at the command prompt and it did not work either "command not found" but I shall power on regardless in my quest for knowledge in this new world.

By the way, there is no documentation. :)

I appreciate your help.

IBall 01-03-2009 06:52 AM

If you want to run a command that is in the current directory, you need to begin it with a ./.

The ./configure command is saying "run the program called configure that lives in the current directory". Obviously there is no configure program in this directory. FYI - the configure program normally builds the make file by checking all the locations of libraries, etc on this system.

If there is a program called "newserver" that looks like it would be the final executable, try running it as ./newserver from within the directory. You may need to make it executable:

chmod 744 newserver

Lordlava 01-03-2009 10:15 AM

Many thanks
./newserver did nothing but at least it did not give an error message so I guessed it worked but need something more.

So I ran it again with the password as a parameter and it is up and running with thousands of messages happily appearing on my console.

Apparently I also need a client with my IP address to get into it from another PC and test it but that will be a different story.

I tested my C code changes and they compiled cleanly and the application stills runs (although I can not test yet if they worked).

I am now a happy little Linux user and I thank you very much for your help.

I hope that if I need more assistance in the future I will be a bit further up the learning curve.

Much appreciated.

All times are GMT -5. The time now is 06:16 AM.