LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-03-2008, 01:41 AM   #16
ehawk
Senior Member
 
Registered: Jul 2003
Posts: 1,257

Rep: Reputation: 48

The previous posts tried to explain that because you installed RHEL 5, but probably are not paying a subscription, you cannot use the RHEL repositories for installing software. Since Centos 5 aims, and is pretty successful, at being 100% binary compatible with RHEL 5, you can change the software repository used by the yum package manager to refer to Centos 5 sites instead of the official RHEL 5 sites with minimal, if any, disruption. The following site shows how to do this. It is merely a matter of changing the contents of the file stored in /etc/yum.repos.d/ using a text editor:

http://www.centos.org/modules/newbb/...?topic_id=7905

You will then be able to issue the yum commands to install all the normal software packages as suggested in the posts above.

Hope this helps. Keep posting with questions and problems you experience.

The CentOS people take advantage of the fact that Red Hat releases their software under the General Public License to just blatantly copy all the source code for you free use. They just have to remove the other aspects of the Red Hat's intellectual property that are not covered by the GPL (trademarks). They host the blatantly copied source code on their own servers.

This is why you need to change the contents of the file in the /etc/yum.repos.d/ directory. You need to tell yum to stop looking at the offical RHEL servers for software and instead look at Centos' servers.

Last edited by ehawk; 08-03-2008 at 01:48 AM.
 
Old 08-03-2008, 01:45 AM   #17
sagitalk
Member
 
Registered: Aug 2008
Posts: 38

Original Poster
Rep: Reputation: 15
i have downloaded a rpm package for gcc named gcc-4.3.1-6.ppc.rpm
i typed rpm -i gcc-4.3.1-6.ppc.rpm on the command prompt and got the following error....

error: Failed dependencies:
binutils >= 2.17.50.0.17-3 is needed by gcc-4.3.1-6.ppc
cpp = 4.3.1-6 is needed by gcc-4.3.1-6.ppc
glibc-devel >= 2.2.90-12 is needed by gcc-4.3.1-6.ppc
libgcc >= 4.3.1-6 is needed by gcc-4.3.1-6.ppc
libgomp = 4.3.1-6 is needed by gcc-4.3.1-6.ppc
libgomp.so.1 is needed by gcc-4.3.1-6.ppc

how do i install these subordinate things required
 
Old 08-03-2008, 01:50 AM   #18
rahilmaknojia
Member
 
Registered: Dec 2007
Distribution: RHEL6, CentOS6.3
Posts: 188

Rep: Reputation: 32
Quote:
Originally Posted by sagitalk View Post
i have downloaded a rpm package for gcc named gcc-4.3.1-6.ppc.rpm
i typed rpm -i gcc-4.3.1-6.ppc.rpm on the command prompt and got the following error....

error: Failed dependencies:
binutils >= 2.17.50.0.17-3 is needed by gcc-4.3.1-6.ppc
cpp = 4.3.1-6 is needed by gcc-4.3.1-6.ppc
glibc-devel >= 2.2.90-12 is needed by gcc-4.3.1-6.ppc
libgcc >= 4.3.1-6 is needed by gcc-4.3.1-6.ppc
libgomp = 4.3.1-6 is needed by gcc-4.3.1-6.ppc
libgomp.so.1 is needed by gcc-4.3.1-6.ppc

how do i install these subordinate things required
Ist you will need to have dependencies file to install gcc++ u can find it from ur linux CDs or DVDs or type file name in google which u needed and u will find it or go to rpmfinder.net
 
Old 08-03-2008, 01:52 AM   #19
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,363

Rep: Reputation: 172Reputation: 172
Ok, rpms come in 4 basic types for each distro and version.

.src.rpms= source rpms
.ppc.rpms for ppc computers (macs until recently)
.i386(or i686) rpms for 32bit computers or 32bit OS running on 64 bit computer.
.x86_64 (or some variant thereof) for 64 bit computers.

You probably need the i386 rpm depending on what you have installed.
 
Old 08-03-2008, 01:55 AM   #20
sagitalk
Member
 
Registered: Aug 2008
Posts: 38

Original Poster
Rep: Reputation: 15
i have the RedHat Enterprise Linx 5 so which package do i reqire for that the .i386??
 
Old 08-03-2008, 01:59 AM   #21
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,363

Rep: Reputation: 172Reputation: 172
Yes, but there is a .ppc rhel5, .i386 rhel5, and a .i686 rhel5.

Post the results of "uname -a". That should tell us.
 
Old 08-03-2008, 02:01 AM   #22
sagitalk
Member
 
Registered: Aug 2008
Posts: 38

Original Poster
Rep: Reputation: 15
this is the result of the uname -a command

Linux localhost.localdomain 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:21 EST 2007 i686 i686 i386 GNU/Linux
 
Old 08-03-2008, 02:10 AM   #23
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,363

Rep: Reputation: 172Reputation: 172
Ok, that says that you are using the 32bit version. So you need to use rpms with i386 (or i586 or i686) in the name.

Quote:
gcc-4.1.2-42.el5.i386.rpm
 
Old 08-03-2008, 02:12 AM   #24
sagitalk
Member
 
Registered: Aug 2008
Posts: 38

Original Poster
Rep: Reputation: 15
i downloaded the package gcc-3.2.2-5.i386.rpm

now when i run the command rpm -i gcc-3.2.2-5.i386.rpm

i got the following error

warning: gcc-3.2.2-5.i386.rpm: Header V3 DSA signature: NOKEY, key ID db42a60e
error: Failed dependencies:
cpp = 3.2.2-5 is needed by gcc-3.2.2-5.i386
glibc-devel >= 2.2.90-12 is needed by gcc-3.2.2-5.i386
 
Old 08-03-2008, 02:19 AM   #25
sagitalk
Member
 
Registered: Aug 2008
Posts: 38

Original Poster
Rep: Reputation: 15
now i have the following packages on my desktop

gcc-3.2.2-5.i386.rpm

the above package required something more so i downloaded the following:

glibc-devel-2.2.93-5.i386.rpm
cpp-3.2.2-5.i386.rpm

now how do i proceed from here
 
Old 08-03-2008, 02:28 AM   #26
sagitalk
Member
 
Registered: Aug 2008
Posts: 38

Original Poster
Rep: Reputation: 15
this is the error when i tried installing gcc-4.1.2-42.el5.i386.rpm


Missing Dependency: libgcc >= 4.1.2-42.el5 is needed by package gcc
Missing Dependency: cpp = 4.1.2-42.el5 is needed by package gcc
Missing Dependency: glibc-devel >= 2.2.90-12 is needed by package gcc
Missing Dependency: libgomp = 4.1.2-42.el5 is needed by package gcc
Missing Dependency: libgomp.so.1 is needed by package gcc
 
Old 08-03-2008, 02:43 AM   #27
sagitalk
Member
 
Registered: Aug 2008
Posts: 38

Original Poster
Rep: Reputation: 15
where can i download this file

glibc-devel-2.2.90-12

only this file is causing a lot of dependency problem
 
Old 08-03-2008, 02:50 AM   #28
rahilmaknojia
Member
 
Registered: Dec 2007
Distribution: RHEL6, CentOS6.3
Posts: 188

Rep: Reputation: 32
Quote:
Originally Posted by sagitalk View Post
where can i download this file

glibc-devel-2.2.90-12

only this file is causing a lot of dependency problem
go to this website u can download devel file from here

http://rpm.pbone.net/index.php3/stat...ch/glibc-devel
 
Old 08-03-2008, 03:06 AM   #29
ehawk
Senior Member
 
Registered: Jul 2003
Posts: 1,257

Rep: Reputation: 48
Is pursuing dependencies worth the effort as opposed to getting yum working? Even if this application is installed via manual rpm'ing, wouldn't yum pay off considering all the future packages to be installed? Not meaning to deride the progress made...
 
Old 08-03-2008, 03:13 AM   #30
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,363

Rep: Reputation: 172Reputation: 172
Ehawk is right. This is why they invented yum. I am going to guess that Centos has the more current version of glibc (which is why your system is asking for the older version of the -devel). All these dependencies are interconnected. If you change just one piece you may have to change ten more just to make sure that the mesh of the system is maintained (thus yum).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I just downloaded a game in a tar.bz2 file. How do I install and run it? Mac_09 Linux - Newbie 2 05-19-2008 01:40 AM
How to install pidgin as a .tar.bz2 file epich Linux - Software 10 03-24-2008 09:26 AM
Why can't I install a *.tar.gz or a *.tar.bz2 file? SkinnerC Slackware 11 12-13-2007 11:03 AM
Problem installing gcc-4.0.2.tar.bz2 MadAboutLinux Linux - Software 1 04-02-2006 12:40 PM
How you install file with TAR.BZ2 extension?.. thanks suse2166 Linux - Software 14 01-03-2005 05:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration