-   Linux - Newbie (
-   -   How do I get xorg drivers to work right on nVidia NV18 GeForce4MX Ubuntu 10.10 (

cigtoxdoc 10-27-2010 09:05 PM

How do I get xorg drivers to work right on nVidia NV18 GeForce4MX Ubuntu 10.10
With Ubuntu 10.10 I cannot get a proprietary driver to work with the nVidia NV18 GeFroce4MX video on my PC. I worked fine on 10.04 LTS. Numerous posts on Ubunutu forums, but none seem to work for my PC.

Only thing that seems to work in part is to use xorg 1.9 driver. However, something is not right as mouse cursor has to be positioned about one line above where you would normally click to get things to work.

What am I doing wrong?


mlangdn 10-29-2010 11:57 AM

Have you downloaded the very latest nvidia driver - 260.19.12?

cigtoxdoc 10-30-2010 11:50 PM

How do I get xorg drivers to work right on nVidia NV18 GeForce4MX Ubuntu 10.10
Thank you for your reply. According to the information I found, the drivers you suggested are for the 64-bit version of Ubuntu. I am using 32-bit. Correct driver is reportedly 96.43.18. If one downloads loads this driver, the driver will load and activate, but will not let Ubuntu go into graphics mode.


TobiSGD 10-31-2010 12:03 AM

The driver versions have nothing to do with 32 or 64 bit. It is just so that NVidia dropped support for your card after the 90-series.
However, what errors do you get? Is X starting at all? Maybe it would help, if you post your xorg.conf and your Xorg.0.log.

cigtoxdoc 11-12-2010 07:39 PM

Xorg.cof Xorg.0.log
2 Attachment(s)
Sorry for delay. Copies of files you suggested are attached.

What are next steps?


TobiSGD 11-13-2010 09:31 AM

There seem to be no errors in your log. I would try to rename your xorg.conf and let the system start without it.

thorkelljarl 11-13-2010 10:18 AM

Did you look in the README...

There is a package, "nvidia-xconfig", installed with the driver that allows you to configure and trouble shoot the Nvidia driver. Ubuntu 10.10 does not generate an xorg.conf file upon installation, but the Nvidia driver will, and you can also use "nvidia-config" to generate the conf file again. See the README, section 6.

linus72 11-13-2010 10:29 AM

This is the procedure I used to install the 96.43.19 version in Ubuntu 10.10/Mint 10

the exact procedure being:

1) First, download the driver and put it somewhere in your /home/username directory. After downloading the driver; edit /etc/modprobe.d/blacklist-framebuffer.conf as root using a terminal to open a editor, (sudo gedit /etc/modprobe.d/blacklist-framebuffer.conf). For me I blacklisted the nouveau driver.

2) Now update the initrd so it doesn't load the nouveau driver at boot, again as root "sudo update-initramfs -c -v -k all", now reboot

3) This is the important part: at the Grub2 boot menu after reboot, hit "e" to edit the grub kernel line and wherever it says "quiet splash --" replace that with "text". Hit control-x to boot. This way it will boot to a console login and GDM/X won't start, which is necessary when installing a graphics driver. Also, remove any reference to "vga="

4) Once it boots up, login to the console prompt as your user-name, add GCC and make by doing "sudo apt-get install gcc make automake libtool". Then execute the nVidia installer, "sudo sh" or "sudo ./". It should run and successfully install.

5) Once again update the initrd; "sudo update-initramfs -c -v -k all". After that I rebooted as usual and the nVidia driver works great! Make sure you don't use any "vga=" parameter if possible in your Grub2 config.

deus_machinarum 11-15-2010 06:09 AM

I have tried the procedure described by linus72(although using the x86_64-260.19.21 driver which should be applicable to my system and card). Everything went fine until starting the install script:
there I got an error message claiming: "The distribution pre-install script failed, do you want to continue anyway?" I selected yes and the driver installed( I did not choose to install the OpenGL 32 bit extensions as I would be happy just to get a higher resolution on my freshly installed Mint 10, nothing else required). After the initramfs... I rebooted and was greeted by a black screen as soon as X tries to start up(which is the exact same thing that happens when I use jockey to install the recommended driver)

Hardware: Sony Vaio using an Intel i7 and a geforce gt 425M
I should also mention that Mint does not recognize my Monitor at all, so in standard mode(no nvidia driver installed) it only offers a max. resolution of 800x600.
lspci gives: VGA compatible controller: nVidia Corporation Device 0df0 (rev a1) which I think means it does not know which card is there?

Can anyone help me as to what I am doing wrong?

Thank you in advance

rylan76 11-15-2010 08:33 AM

As another poster said, your card might be too old to be supported by Nvidia anymore.

Have you tried switching down runlevels and then running the driver's install script though?

I usually upgrade my Xorg driver like this. I'm using FC11 and my card is a GeForce 7950GT PCI-E - so your mileage may vary on the steps below:


1. As root, edit /etc/inittab and make the default runlevel 3. (If a 5, and you boot, the system will instantly try to go to graphics mode.)
2. Reboot
3. System should give you a text terminal login, with no graphics.
4. Uncompress, set as executable (chmod a+x driverfile.tar.gz) and run the driver file.
5. It should churn awhile and ask a few questions. It might say "no compatible kernel interface found. Compile a new one?" - choose yes.
6. NOTE for the above step you might need to have a compiled and installed kernel source tree...!
7. On my systtem, after doing this "Compile a new one?" step, the Nvidia installer reports that the new kernel interface was compiled successfully.
8. Install the new module when prompted, and also respond positively if the driver install wants to overwrite your xorg.conf (Don't worry, it should automatically make a copy of the old one.)
9. When it is done, exit the driver installer.
10. Again edit /etc/inittab and set the default runlevel back to 5.
11. Reboot.

When I do this, at least for my FC11 system with the 7950GT, XWindows comes back up with the new Nvidia driver running...

linus72 11-15-2010 09:06 AM

No, you have a legacy card
you need to use the 96 series drivers I think
anything below gforce5 has to be 96

did you try the 96.43.19 driver?

deus_machinarum 11-15-2010 09:22 AM

Are you sure it is a legacy card?(Note the 400M series being mentioned for laptops) I selected the driver that the nvidia site gives me when entering my card and linux 64-bit, also the card only came out this year.

I will try the other driver though.

Also I noted that in the X-Server start up log everything seems to go fine, there is no error.

However in the error log the following appears:

Fatal Server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock and start again.

On other occasions the log file just stays empty but the error remains the same.

I tried deleting the file mentioned but on reboot I get the same blank screen.
Might this be related to my installation not recognizing my card and my monitor? Or might it be related to the nouveau drivers not being fully removed?

Contents of Xorg.0.log:

[    20.252]
X.Org X Server 1.9.0
Release Date: 2010-08-20
[    20.252] X Protocol Version 11, Revision 0
[    20.252] Build Operating System: Linux 2.6.24-27-server x86_64 Ubuntu
[    20.252] Current Operating System: Linux DavidZarfl-VAIO 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64
[    20.252] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=4332aff4-5b2c-48b3-9f54-cd6c50d10598 ro quiet splash
[    20.252] Build Date: 16 September 2010  06:18:41PM
[    20.252] xorg-server 2:1.9.0-0ubuntu7 (For technical support please see
[    20.252] Current version of pixman: 0.18.4
[    20.252]        Before reporting problems, check
        to make sure that you have the latest version.
[    20.252] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    20.252] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Nov 15 15:14:09 2010
[    20.307] (==) Using config file: "/etc/X11/xorg.conf"
[    20.307] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    20.379] (==) ServerLayout "Layout0"
[    20.379] (**) |-->Screen "Screen0" (0)
[    20.379] (**) |  |-->Monitor "Monitor0"
[    20.389] (**) |  |-->Device "Device0"
[    20.389] (**) |-->Input Device "Keyboard0"
[    20.389] (**) |-->Input Device "Mouse0"
[    20.389] (==) Automatically adding devices
[    20.389] (==) Automatically enabling devices
[    20.461] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    20.461]        Entry deleted from font path.
[    20.531] (==) FontPath set to:
[    20.531] (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    20.531] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    20.531] (WW) Disabling Keyboard0
[    20.531] (WW) Disabling Mouse0
[    20.531] (II) Loader magic: 0x7d0200
[    20.531] (II) Module ABI versions:
[    20.531]        X.Org ANSI C Emulation: 0.4
[    20.531]        X.Org Video Driver: 8.0
[    20.531]        X.Org XInput driver : 11.0
[    20.531]        X.Org Server Extension : 4.0
[    20.533] (--) PCI:*(0:1:0:0) 10de:0df0:104d:907a rev 161, Mem @ 0xe2000000/16777216, 0xd0000000/268435456, 0xe0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/524288
[    20.533] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    20.533] (II) LoadModule: "extmod"
[    20.559] (II) Loading /usr/lib/xorg/modules/extensions/
[    20.593] (II) Module extmod: vendor="X.Org Foundation"
[    20.593]        compiled for 1.9.0, module version = 1.0.0
[    20.593]        Module class: X.Org Server Extension
[    20.593]        ABI class: X.Org Server Extension, version 4.0
[    20.593] (II) Loading extension MIT-SCREEN-SAVER
[    20.593] (II) Loading extension XFree86-VidModeExtension
[    20.593] (II) Loading extension XFree86-DGA
[    20.593] (II) Loading extension DPMS
[    20.593] (II) Loading extension XVideo
[    20.593] (II) Loading extension XVideo-MotionCompensation
[    20.593] (II) Loading extension X-Resource
[    20.593] (II) LoadModule: "dbe"
[    20.593] (II) Loading /usr/lib/xorg/modules/extensions/
[    20.594] (II) Module dbe: vendor="X.Org Foundation"
[    20.594]        compiled for 1.9.0, module version = 1.0.0
[    20.594]        Module class: X.Org Server Extension
[    20.594]        ABI class: X.Org Server Extension, version 4.0
[    20.594] (II) Loading extension DOUBLE-BUFFER
[    20.594] (II) LoadModule: "glx"
[    20.594] (II) Loading /usr/lib/xorg/modules/extensions/
[    21.638] (II) Module glx: vendor="NVIDIA Corporation"
[    21.640]        compiled for 4.0.2, module version = 1.0.0
[    21.640]        Module class: X.Org Server Extension
[    21.640] (II) NVIDIA GLX Module  260.19.21  Thu Nov  4 21:42:11 PDT 2010
[    21.640] (II) Loading extension GLX
[    21.640] (II) LoadModule: "record"
[    21.640] (II) Loading /usr/lib/xorg/modules/extensions/
[    21.657] (II) Module record: vendor="X.Org Foundation"
[    21.657]        compiled for 1.9.0, module version = 1.13.0
[    21.657]        Module class: X.Org Server Extension
[    21.657]        ABI class: X.Org Server Extension, version 4.0
[    21.657] (II) Loading extension RECORD
[    21.657] (II) LoadModule: "dri"
[    21.657] (II) Loading /usr/lib/xorg/modules/extensions/
[    21.680] (II) Module dri: vendor="X.Org Foundation"
[    21.680]        compiled for 1.9.0, module version = 1.0.0
[    21.681]        ABI class: X.Org Server Extension, version 4.0
[    21.681] (II) Loading extension XFree86-DRI
[    21.681] (II) LoadModule: "dri2"
[    21.681] (II) Loading /usr/lib/xorg/modules/extensions/
[    21.681] (II) Module dri2: vendor="X.Org Foundation"
[    21.681]        compiled for 1.9.0, module version = 1.2.0
[    21.681]        ABI class: X.Org Server Extension, version 4.0
[    21.681] (II) Loading extension DRI2
[    21.681] (II) LoadModule: "nvidia"
[    21.682] (II) Loading /usr/lib/xorg/modules/drivers/
[    21.762] (II) Module nvidia: vendor="NVIDIA Corporation"
[    21.765]        compiled for 4.0.2, module version = 1.0.0
[    21.765]        Module class: X.Org Video Driver
[    21.799] (II) NVIDIA dlloader X Driver  260.19.21  Thu Nov  4 21:18:43 PDT 2010
[    21.799] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    21.799] (++) using VT number 7

[    21.819] (II) Loading sub module "fb"
[    21.819] (II) LoadModule: "fb"
[    21.820] (II) Loading /usr/lib/xorg/modules/
[    21.864] (II) Module fb: vendor="X.Org Foundation"
[    21.865]        compiled for 1.9.0, module version = 1.0.0
[    21.865]        ABI class: X.Org ANSI C Emulation, version 0.4
[    21.865] (II) Loading sub module "wfb"
[    21.865] (II) LoadModule: "wfb"
[    21.865] (II) Loading /usr/lib/xorg/modules/
[    21.874] (II) Module wfb: vendor="X.Org Foundation"
[    21.875]        compiled for 1.9.0, module version = 1.0.0
[    21.875]        ABI class: X.Org ANSI C Emulation, version 0.4
[    21.875] (II) Loading sub module "ramdac"
[    21.875] (II) LoadModule: "ramdac"
[    21.875] (II) Module "ramdac" already built-in
[    21.879] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    21.879] (==) NVIDIA(0): RGB weight 888
[    21.879] (==) NVIDIA(0): Default visual is TrueColor
[    21.879] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    21.880] (**) NVIDIA(0): Enabling RENDER acceleration
[    21.880] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
[    21.880] (II) NVIDIA(0):    enabled.

All times are GMT -5. The time now is 03:47 AM.