LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   how do i get my internet working? (https://www.linuxquestions.org/questions/linux-newbie-8/how-do-i-get-my-internet-working-92001/)

ferretmanus 09-12-2003 11:07 AM

how do i get my internet working?
 
okay, on my journey with linux i have run into yet another problem. ive got linux on my machine and have it running well. on my goals to make this a proxy server i have run into an obstacle in just the first step. ive got redhat installed, mandrake was having issues with the setup, but i have redhat installed now and im trying to get the internet working. i have good old road runner(every time i make a change they piss me off), but during bootup it is saying that eth0 is not recognizing an ip, and i know that there is a connection coming to the linuxbox, but how do i get it to recognize it? help!

Mathieu 09-12-2003 03:39 PM

What type of internet connection do you have ? (Cable modem or DSL)

Can you post the contents of /etc/sysconfig/network-scripts/ifcfg-eth0 (eth0 configuration file).

The ifconfig command will display info concerning eth0.
Check the status of eth0 by typing:
Code:

service network status

ferretmanus 09-12-2003 04:47 PM

DEVICE=etho
BOOTPROTO=dhcp
ONBOOT=yes

ferretmanus 09-12-2003 04:47 PM

oh, and its cable

ferretmanus 09-12-2003 06:00 PM

heres the config, its an old compaq i got for free and upgraded a bit, it has 2 10 baset100 cards in it so that i can network my room, but i just first want it to be online.....HELP THE UBER NEWBEEEE

Mathieu 09-12-2003 06:55 PM

In /etc/sysconfig/network-scripts/ifcfg-eth0, the device is eth0 (zero) not the letter "o". (Unless you made a type when copying).
Code:

DEVICE=eth0
You have two network cards, so make sure that eth0 is the one with the internet connection.
To get information concerning your network cards (ethX), type:
Code:

dmesg | grep eth[0-9]
Since you have RedHat, did you try using RedHat's Network Configuration GUI tool.
In the menu, System Settings -> Network.
Or type: redhat-config-network

ferretmanus 09-12-2003 07:00 PM

yeah, i know it was a 0 not an o, just a typo. ill try that very soon. i have to go hook up my grandmothers printer. if i get that up and running how do i then get the two computers i have that are running xp pro and home to work on it as a proxy?

ferretmanus 09-13-2003 12:40 PM

okay, i ran the nework configuration, the card Was disabled
so i enabled it. the internet still doesent work but the sys-config file for eth0 has changed
it now says

DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
USERCTL=no
PEERDNS=no
TYPE=ethernet

i know the card works becuase i used it in my other computer before. in my first bt of learning to network, i used it. it worked just fine. it is registering in linux, but the other one is not. its a dud, or just the fact its an older one and is using one of the odler type of slots, the one before pci. i can get another pci network card, but first, this one has to be on the internet. lol. joyous. so, got any ideas with the new information provided?

Mathieu 09-13-2003 03:09 PM

Your ifcfg-eth0 is configured correctly.

Take a look at /etc/modules.conf and make sure the module is assigned to the correct device.

Check the status of eth0 by typing:
Code:

service network status
The output should say that eth0 is configured and currently active. If not, try restarting the network:
Code:

service network restart
Hopefully, you should now have an IP for eth0. Type:
Code:

ifconfig
If ifconfig does not show an IP for eth0, post the output of all the commands (dmesg |..., service...) and files in this thread.

ferretmanus 09-15-2003 02:31 PM

where do i put the code? ive tried it in console and it goes on this whole bash error doesent recognize ramble. where do i do that? should i just go to the regular console by doing the ctrl alt f1 switch? im also just taking the older network card out and re-installing redhat with just the server settings ect.. im gonna use gnome or just x. hey, i actually sound like i know what im doing. yaya. alright, thanks a bunch, leave me where i should type that in so i can get better

ricdave 09-15-2003 05:28 PM

r u logged in as root?

ferretmanus 09-15-2003 05:54 PM

i log in my user profile but then i just set the root pswd when i need to. it will prompt me when i need it

ricdave 09-15-2003 06:11 PM

logon root:

[david@david david]$ su
Password:
[root@david david]# service network status
Configured devices:
lo eth0
Currently active devices:
lo eth0
[root@david david]#


All times are GMT -5. The time now is 01:20 PM.