LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-20-2001, 11:00 AM   #1
oudent
Member
 
Registered: Jul 2001
Distribution: Ubuntu
Posts: 195

Rep: Reputation: 30
How do I get my Epson SC 880 USB to print?


I'm running Red Hat 7.2

It has my printer in the list of printers it offers, but I still can't print.

When I try printing a test page nothing happens! Again, I have an Epson Stylus Color 880 connected via USB, through a USB hub, but I know for a fact that linux knows its there because it is listed in the USB info somewhere, as well as my web cam (by name, also if you know how to get that working...)

So the printer seems like its setup, and it is supposed to work according to all the stuff I've read, and its supposed to work with the 'stp' thing that RH has set for it, but it just does not print...hopefully someone can help me with this or any of my other questions I have posted.

Thanks
 
Old 11-16-2005, 02:04 PM   #2
eternity2002
LQ Newbie
 
Registered: Jun 2004
Distribution: Debian Sarge 3.1
Posts: 3

Rep: Reputation: 0
Talking

Hi!

I have exactely the same problem with my Epson SC 880 which you have discribed. I would like to ask you if you could tell my how you solved your problem.
I am using Debian Sarge 3.1 with kernel 2.6.8-2-k7. I have tried to install my printer with cups, it worked. I am using cups 1.1.23-10 with gimp-print 4.2.7-10. The printer also shows up in Gnome & KDE-controlcenters, but it simply doesn't print. As you, I can send test pages or click "print" in any application without getting any errors, but the printer simply doesn't print...

Can you help me?

thx in advance,
eternity2002
 
Old 11-16-2005, 03:26 PM   #3
oudent
Member
 
Registered: Jul 2001
Distribution: Ubuntu
Posts: 195

Original Poster
Rep: Reputation: 30
eternity2002,

As you may have noticed, that is a really old post. I'll look into the problem, but I haven't had problems printing in years...well, not like that. Just make sure you have the newest version of CUPS possible.

How is the printer connected to the computer? USB, Network, Parallel?

I'll try to get back to you with possible solutions as soon as I can.

Nick
 
Old 11-16-2005, 04:23 PM   #4
eternity2002
LQ Newbie
 
Registered: Jun 2004
Distribution: Debian Sarge 3.1
Posts: 3

Rep: Reputation: 0
Thak you for your answer.
Well, I have the newest version of cups, I keep my Debian Sarge "up-to-date-daily".
My printer is connected via USB and if I turn the printer up, an USB-printing-modul is beeing loaded.
I just don't know what I should do to get the printer working.
Thanks for your effords!

cu eternity2002
 
Old 02-01-2006, 11:09 AM   #5
Skazi
Member
 
Registered: Aug 2004
Location: Minneapolis, MN, USA
Distribution: Slackware 13.1
Posts: 82

Rep: Reputation: 15
ttt,

I seem to be having the same problem in Slackware 10.2, which comes with cups-1.1.23 and gimp-print-4.2.7. I also am trying to use an Epson Stylus Color 880.

I started cupsd manually, because it is not enabled at startup in Slackware default install:

Code:
/etc/rc.d/rc.cups start
Referencing http://www.cups.org/doc-1.1/sam.html, I found my printer device:

Code:
lpinfo -v
A line returned by this was "direct usb://EPSON/Stylus%20COLOR%20880", which I add as a printer:

Code:
lpadmin -p Epson -E  -v usb://EPSON/Stylus%20COLOR%20880 -m stcolor.ppd
Finally, I tried printing with this command from http://www.linuxprinting.org/cups-doc.html:

Code:
lp -d Epson -o PageSize=Letter /etc/motd
So, it looks like the print job is submitted. Looking at http://localhost:631/admin all print jobs I've attempted are listed as completed, but nothing comes out of the printer. Also, I find no errors listed in /var/log/cups/error_log

So, everything looks ok, but nothing comes out of the printer.

Last edited by Skazi; 02-01-2006 at 11:12 AM.
 
Old 02-02-2006, 01:04 AM   #6
Skazi
Member
 
Registered: Aug 2004
Location: Minneapolis, MN, USA
Distribution: Slackware 13.1
Posts: 82

Rep: Reputation: 15
Made some progess. Using http://localhost:631/admin I modified the printer I previously added, setting Device to "USB Printer #1", and selecting the CUPS+gimp-print driver for the Epson Stylus Color 880.

The changed the Device URI to "usb:/dev/usb/lp0", and printing a test page now works.

Now I'm working on setting it up under Samba ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Epson C66 doesn't work with Epson drivers (print/pips-sc65_66s port) josealexandre Linux - Hardware 1 06-26-2005 12:51 PM
Print in Epson C42UX Gerardoj Linux - General 0 02-01-2004 12:24 PM
Epson Stylus Color 880 prints blanks premsaggar Linux - Hardware 0 12-17-2003 07:06 PM
Epson 880 Printing Colored Splotches, even with b/w fieldmethods Linux - Hardware 3 10-01-2003 02:19 AM
I install my Epson 880(usb) printer in RH 7.2 but nothing happens oudent Linux - Software 4 12-19-2001 02:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration