LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How do I get my Epson SC 880 USB to print? (https://www.linuxquestions.org/questions/linux-newbie-8/how-do-i-get-my-epson-sc-880-usb-to-print-8972/)

oudent 11-20-2001 10:00 AM

How do I get my Epson SC 880 USB to print?
 
I'm running Red Hat 7.2

It has my printer in the list of printers it offers, but I still can't print.

When I try printing a test page nothing happens! Again, I have an Epson Stylus Color 880 connected via USB, through a USB hub, but I know for a fact that linux knows its there because it is listed in the USB info somewhere, as well as my web cam (by name, also if you know how to get that working...)

So the printer seems like its setup, and it is supposed to work according to all the stuff I've read, and its supposed to work with the 'stp' thing that RH has set for it, but it just does not print...hopefully someone can help me with this or any of my other questions I have posted.

Thanks

eternity2002 11-16-2005 01:04 PM

Hi!

I have exactely the same problem with my Epson SC 880 which you have discribed. I would like to ask you if you could tell my how you solved your problem.
I am using Debian Sarge 3.1 with kernel 2.6.8-2-k7. I have tried to install my printer with cups, it worked. I am using cups 1.1.23-10 with gimp-print 4.2.7-10. The printer also shows up in Gnome & KDE-controlcenters, but it simply doesn't print. As you, I can send test pages or click "print" in any application without getting any errors, but the printer simply doesn't print... :confused: :cry:

Can you help me?

thx in advance,
eternity2002

oudent 11-16-2005 02:26 PM

eternity2002,

As you may have noticed, that is a really old post. I'll look into the problem, but I haven't had problems printing in years...well, not like that. Just make sure you have the newest version of CUPS possible.

How is the printer connected to the computer? USB, Network, Parallel?

I'll try to get back to you with possible solutions as soon as I can.

Nick

eternity2002 11-16-2005 03:23 PM

Thak you for your answer.
Well, I have the newest version of cups, I keep my Debian Sarge "up-to-date-daily".
My printer is connected via USB and if I turn the printer up, an USB-printing-modul is beeing loaded.
I just don't know what I should do to get the printer working.
Thanks for your effords! :)

cu eternity2002

Skazi 02-01-2006 10:09 AM

ttt,

I seem to be having the same problem in Slackware 10.2, which comes with cups-1.1.23 and gimp-print-4.2.7. I also am trying to use an Epson Stylus Color 880.

I started cupsd manually, because it is not enabled at startup in Slackware default install:

Code:

/etc/rc.d/rc.cups start
Referencing http://www.cups.org/doc-1.1/sam.html, I found my printer device:

Code:

lpinfo -v
A line returned by this was "direct usb://EPSON/Stylus%20COLOR%20880", which I add as a printer:

Code:

lpadmin -p Epson -E  -v usb://EPSON/Stylus%20COLOR%20880 -m stcolor.ppd
Finally, I tried printing with this command from http://www.linuxprinting.org/cups-doc.html:

Code:

lp -d Epson -o PageSize=Letter /etc/motd
So, it looks like the print job is submitted. Looking at http://localhost:631/admin all print jobs I've attempted are listed as completed, but nothing comes out of the printer. Also, I find no errors listed in /var/log/cups/error_log

So, everything looks ok, but nothing comes out of the printer.

Skazi 02-02-2006 12:04 AM

Made some progess. Using http://localhost:631/admin I modified the printer I previously added, setting Device to "USB Printer #1", and selecting the CUPS+gimp-print driver for the Epson Stylus Color 880.

The changed the Device URI to "usb:/dev/usb/lp0", and printing a test page now works.

Now I'm working on setting it up under Samba ...


All times are GMT -5. The time now is 12:33 PM.