LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How do I get "Kernel Header" files so I can install nVidia drivers (https://www.linuxquestions.org/questions/linux-newbie-8/how-do-i-get-kernel-header-files-so-i-can-install-nvidia-drivers-134790/)

Stevetgn 01-14-2004 01:16 PM

How do I get "Kernel Header" files so I can install nVidia drivers
 
I'm running Mandrake 9.2 and I'm struggling installing the nVidia drivers for my Geforce 5900FX. I run the downloaded driver without X running by using the "sh NVIDIA-Linux-x86. etc etc... and it tells me I need the "Kernel Header files" where do I get them from, how do I install them and what are they for???

Many thanks in advance

Steve

:newbie:

lone_nut 01-14-2004 01:40 PM

You didn't mention, what kernel version, you are running. I know you have a kernel installed, and you will need sources for THAT version, not for some other version.
To find out, what version your kernel is, run
su -c 'grep kernel\ version /var/log/kernel/info |cut -d: -f4|tail -n 1'
It will ask you for your root password, then find any line in /etc/log/kernel/info that has the world kernel version in it. Then print the part from the 4th to the 5th of last of theese lines.
Then go to www.kernel.org and download the sources for that version.
unpak them using:
cd /usr/src
tar xjf kernel-souce-files
Now the Nvida drivers, should find the sources, and compile with out problems.
BTW.
Kernel sources are those used to bild the kernel. It boots at startup, and handles all hardware actions - such as reading/writing to a disk such. That is way I was sure, You already had a kernel. People says they install Linux, put technicly the kernel is linux.
It is needed to do such a simple ting as executing a program. With the kernel, you have nothing

Stevetgn 01-14-2004 01:45 PM

Thats great thanks lone_nut. I'll try that later on tonight

Thanx again

Steve

Shachaf 01-14-2004 03:14 PM

If you're using Mandrake, there should be an RPM file with the kernel source on one of the CDs. I think typing urpmi kernel-source would work (maybe it's urpmi install kernel-source).

mahibedi 01-14-2004 05:57 PM

Hi..
I had the same problem.."Unable to find kernel header"

I tried what is suggested here..

http://www.linuxquestions.org/quest...+9.0+and+Nvidia

Have just finished loading the new drivers and it works perfectly..
You can see what I had posted here...

http://www.linuxquestions.org/questi...hreadid=134455


Hope this helps...


All times are GMT -5. The time now is 05:23 PM.