LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   how do I change the filesystem from read-only to read-write? (https://www.linuxquestions.org/questions/linux-newbie-8/how-do-i-change-the-filesystem-from-read-only-to-read-write-185821/)

les_chow 05-25-2004 06:26 PM

how do I change the filesystem from read-only to read-write?
 
How can I change my root filesystem from read only to read-write? I edited my fstab and accidentally added a tilde to the end of the filename. Now linux won't boot to the GUI and simply puts me into maintainence mode. The problem arises because the OS cannot find fstab to mount the / filesystem (or much else for that matter). I have tried changing the filename, copying the misnamed file to a new file called fstab without success; the system simply responds that the filesystem is read-only. Okay, I've logged in as root and tried chmod 0777 / and chmod +w / and even mount with the rw option all without success. I'm running RHLinus WS 3, kernel version 2.4.21 -9. I've used up my limited knowledge and would really appreciate any tips on resolving this issue.

Thanks

L. Chow

qwijibow 05-25-2004 06:54 PM

did you try removing the tilde from fstab ?

Vlad-A 05-26-2004 09:25 AM

How about
mount -o remount,rw /

les_chow 05-26-2004 11:51 AM

thanks for your replies. Unfortunately, neither of those suggestions worked. Becuase the fielsystem is read-only, I can't rename or copy any files. The mount -o remount,rw / command simply failed and gave me the mount help screen. Any other ideas out there.

Thanks,

Les

Vlad-A 05-26-2004 12:12 PM

OK, imagine your root partition is hda2

then try:

mount -o remount,rw /dev/hda2 /

I tested this and in my case it works.

BTW: What's teh ouput of
mount

Although I have a SuSE 9.1 distribution, mount shall not be different

les_chow 05-26-2004 03:14 PM

Vlad, thanks. That worked. The hardest part was trying to remember which partition / was installed on. I'm back up and running. Thanks again.

les


All times are GMT -5. The time now is 03:37 PM.