Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 12-18-2011, 12:28 PM   #1
Registered: Dec 2011
Posts: 171

Rep: Reputation: Disabled
How do I change the default text size in Salix OS Ratpoison windows?

Hi to all,
I am running Salix OS Ratpoison edition on one of my PC's and I'm trying to enlarge the on-screen text in all of the tiling windows. When I installed it, one of the screens that came up was the following:

Configure Lilo to use frame Buffer Console?
Looking at /proc/devices, it seems your kernel has support for the Linux frame buffer console. If we enable this in /etc/lilo.conf, it will allow more rows and columns of text on the screen and give you a cool penguin logo at boot time. However, the frame buffer text console is slower than a standard text console. In addition, not every video card or monitor supports all of the video modes. Would you like to use the frame buffer console, or the standard Linux console?

select from the following:


I chose the 640x480 option (because I want the largest text possible when using Salix OS). On boot-up I get a very brief screen showing Tux the penguin logo in the upper left-hand portion of the screen. But more important to me, is that when this screen is showing, the text is much, *MUCH* larger (which is what I want it to be and stay permanently when using this OS), but soon after that screen comes up it goes away and then the on-screen text goes back to being tiny once again and stays tiny permanently when it boots into the Ratpoison desktop (which also has tiny text in all of its tiling windows screens- whether running console T.U.I applications or G.U.I. applications, its still tiny text in all of them)
My question is this: is there a way to get the text to stay that same large size when it is booting and briefly shows the Tux the penguin logo and into the Ratpoison desktop or switch it on somehow or edit a boot up file or something and if so, how do I do it?

Thank you
Old 12-18-2011, 01:13 PM   #2
Stephen Morgan
Registered: Feb 2011
Location: England
Distribution: Slackware
Posts: 163

Rep: Reputation: 17
The framebuffer only effects console programmes run in the TTYs, it has no effect on anything running through the X server.

You might have to change the text size in each application individually, setting the font size in the Xterm by changing the .ratpoisonrc entry for the command to launch it, and so on.

Or, you could change the X server resolution, which would also reduce the clarity of pictures and so forth, not just fonts.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Got a black screen after installing Salix OS Ratpoison (Slackware) punchy71 Linux - Newbie 3 12-12-2011 01:42 PM
LXer: Salix OS 13.37 Features Ratpoison Window Manager LXer Syndicated Linux News 0 10-05-2011 08:51 PM
User can't change default text size. gamfa Grafpup 3 06-28-2007 11:21 AM
enlightenment: how to change text size? kak Linux - Software 1 08-10-2004 08:23 AM
Change QT text size drigz Linux - Software 0 08-05-2004 04:28 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:52 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration