LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-16-2006, 10:44 PM   #1
adana
LQ Newbie
 
Registered: Jan 2006
Posts: 6

Rep: Reputation: 0
How do I change firefox totem default??


I am using ubuntu/GNOME.

My firefox always opens totem when clicking on the c-span website, "recent programs".

How do I change this??

I have edited /usr/share/applications/defaults.list and mimeinfo.cache to remove totem from every entry. No effect.

I am out of ideas. Any help please?
 
Old 01-16-2006, 11:23 PM   #2
scott_R
Member
 
Registered: Jul 2003
Location: Brighton, Michigan, USA
Distribution: Lots of distros in the past, now Linux Mint
Posts: 748

Rep: Reputation: 31
in firefox, edit->preferences->downloads->view and edit actions and changing firefox's own internal mime types doesn't help?
 
Old 01-17-2006, 10:53 AM   #3
adana
LQ Newbie
 
Registered: Jan 2006
Posts: 6

Original Poster
Rep: Reputation: 0
I will check that again. The last time I checked that, very few file types where listed and firefox gave me no way to add new ones.

I wonder how file types end up there --- maybe when plugins are added?

When I look at aboutlugins in firefox, totem is already not associated with any file types.

Also the media connectivity extension for firefox doesn't fix this. That extension has realplay set for all file types.

I am not running firefox through GNOME, by the way. I installed it stand-alone outside of synaptic.

Last edited by adana; 01-17-2006 at 10:56 AM.
 
Old 01-18-2006, 10:44 AM   #4
adana
LQ Newbie
 
Registered: Jan 2006
Posts: 6

Original Poster
Rep: Reputation: 0
in firefox, edit->preferences->downloads->view and edit actions and changing firefox's own internal mime types doesn't help?

--------No, this doesn't help. Totem is not listed at all.
 
Old 01-14-2007, 04:41 PM   #5
pxumsgdxpcvjm
Member
 
Registered: Aug 2005
Posts: 235

Rep: Reputation: 30
I had the same problem, and I don't see a way to add file types in firefox.

I did manage to change it. It appears that the browser is calling the OS to run the appropriate app for the file type.

In my case I wanted to change the default app that opened a *.pdf file.

So I downloaded a *.pdf.

Went to the OS file browser, right clicked on it, went to properties and changed the default app to run for *.pdfs.

That worked for me. I hope it helps you.

-snacker
 
Old 01-30-2007, 10:31 PM   #6
RandCraw
LQ Newbie
 
Registered: Jan 2007
Posts: 4

Rep: Reputation: 0
Edit your window manager's defaults

Firefox is using your window manager's defaults. If your WM is gnome, run gconf-editor, proceed to desktop->gnome->url-handlers. Change the entries for mms, mmsh, net, pnm, rtp, rtsp, and uvox.

If you use KDE, you're on your own.

Randy
 
Old 01-30-2007, 11:25 PM   #7
RandCraw
LQ Newbie
 
Registered: Jan 2007
Posts: 4

Rep: Reputation: 0
Talking Here's what I *really* meant to say.

Quote:
Originally Posted by RandCraw
Firefox is using your window manager's defaults. If your WM is gnome, run gconf-editor, proceed to desktop->gnome->url-handlers. Change the entries for mms, mmsh, net, pnm, rtp, rtsp, and uvox.

If you use KDE, you're on your own.

Randy
Hmm. And that seemed like such a *good* idea...

Here's what does work. As root, cd to /usr/lib/mozilla-firefox/plugins. Then re/move all the libtotem* files. Restart Firefox. If you've wisely installed the Mediaplayer Connectivity plugin, it will prompt you for the media apps that you want to handle Firefox's video & audio. If not, it *should* switch to use another existing media plugin found in that directory (like libvlcplugin.so)

Randy
 
Old 02-07-2007, 10:59 PM   #8
RandCraw
LQ Newbie
 
Registered: Jan 2007
Posts: 4

Rep: Reputation: 0
Third time is the charm...

To change Ubuntu from using totem to xine (for example), do it from within gnome. Navigate via the main menu bar:

System -> Preferences -> Removable Drives and Media -> Multimedia

Then change the appropriate entry from totem to xine.

Randy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox, I changed my default profile for login, how do I change it back ? TroelsSmit Linux - Newbie 5 03-19-2010 08:35 AM
sound from totem, but not in firefox cooldudejz Ubuntu 1 10-31-2005 07:17 PM
how to change default player in firefox abd_bela MEPIS 3 09-29-2005 07:44 AM
How do I, set MPlayer as default and remove Totem? SonoranFun Linux - Software 6 01-24-2005 04:05 PM
totem seek values and konqueror default profile mickyg Linux - Software 1 10-28-2004 07:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration