LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-18-2021, 04:14 PM   #1
KrazyKat52
LQ Newbie
 
Registered: Mar 2021
Posts: 21

Rep: Reputation: Disabled
How can we fix this? No irq handler for vector


We have the following error message come up when the new Mageia 8 (after fresh, new install on new machine) is booting up (doesn't make it to desktop or even login screen):

_common_interrupt: 1.55 No irq handler for vector

(The message repeats with a line that goes up to 10.55)

How do we solve this?

If we have to add something to the "kernel," what do we do and how do we get to the kernel?

Thank you very much!!!!!!


Please note that we did a search for this on this site with nothing coming up.



Asus ROG Strix B550-F MB
Asus TUF RTX 3060 OC Edition 12GB GPU
AMD 7 3800x CPU
32 GB 3200 DDR4 Memory
EVGA G5 850 Watt PSU
2 Seagate HDD 2TB each
DVD burner
 
Old 03-18-2021, 04:32 PM   #2
shruggy
Senior Member
 
Registered: Mar 2020
Posts: 3,578

Rep: Reputation: Disabled
The search turned up this thread on Reddit, see particularly this comment:
Quote:
Originally Posted by Forsaken-Leopard9281
This is caused by the iommu being set to Auto or Enabled in EFI/BIOS. Disabling it gets rid of the error messages. From what I can gather online, this has been a long ongoing issue that AMD is aware of. It's used for GPU pass-through to VMs and such.
 
Old 03-18-2021, 04:59 PM   #3
KrazyKat52
LQ Newbie
 
Registered: Mar 2021
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by shruggy View Post
The search turned up this thread on Reddit, see particularly this comment:

We went through the links, and it seems there wasn't a real solution. A lot of things were tried. If there somehow was a solution, it was mixed up in technical jargon, and the text and info was so confusing. We clicked in the multiple links. We already updated the BIOS, and we can't find the iommu in the BIOS.

Is there an actual solution? Please help. Thank you.

Last edited by KrazyKat52; 03-18-2021 at 05:08 PM. Reason: Added more info
 
Old 03-18-2021, 06:02 PM   #4
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~amd64
Posts: 7,513

Rep: Reputation: Disabled
Disable IOMMU in kernel.
 
Old 03-18-2021, 07:35 PM   #5
KrazyKat52
LQ Newbie
 
Registered: Mar 2021
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Emerson View Post
Disable IOMMU in kernel.
Thank you for responding. How do we get to the kernel to disable it and what do we type?

Thank you!
 
Old 03-18-2021, 09:24 PM   #6
computersavvy
Senior Member
 
Registered: Aug 2016
Posts: 2,917

Rep: Reputation: 1213Reputation: 1213Reputation: 1213Reputation: 1213Reputation: 1213Reputation: 1213Reputation: 1213Reputation: 1213Reputation: 1213
When I built my new machine
Ryzen 5 3600
Asrock B550M Pro
32 GB ram

I had the same error as it booted on Fedora 33. The error was benign for me and I essentially ignored it since all I found online showed that users had no related problems that interfered with the machine operation.

There have been numerous kernel updates since then and at some point I quit seeing those errors so apparently whatever changes were made in the kernel over time corrected the error. For me the CPU and its microcode was ahead of the kernel development.

All I can suggest is just ignore it unless you can definitively say it caused a specific problem. Your new machine with bleeding edge hardware is likely to lag a little behind in the drivers and kernel catching up to the hardware.
 
Old 03-19-2021, 07:37 AM   #7
KrazyKat52
LQ Newbie
 
Registered: Mar 2021
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by computersavvy View Post
When I built my new machine
Ryzen 5 3600
Asrock B550M Pro
32 GB ram

I had the same error as it booted on Fedora 33. The error was benign for me and I essentially ignored it since all I found online showed that users had no related problems that interfered with the machine operation.

There have been numerous kernel updates since then and at some point I quit seeing those errors so apparently whatever changes were made in the kernel over time corrected the error. For me the CPU and its microcode was ahead of the kernel development.

All I can suggest is just ignore it unless you can definitively say it caused a specific problem. Your new machine with bleeding edge hardware is likely to lag a little behind in the drivers and kernel catching up to the hardware.

Thank you letting me know your experience with it.

I wish I really could ignore it... The system freezes at the black screen with this message. The OS doesn't go forward to even the the login page.

Please help! Otherwise, I won't be able to use Mageia at all until new one comes out. Thank you everyone!

Last edited by KrazyKat52; 03-19-2021 at 07:38 AM.
 
Old 03-19-2021, 08:58 AM   #8
shruggy
Senior Member
 
Registered: Mar 2020
Posts: 3,578

Rep: Reputation: Disabled
Quote:
Originally Posted by KrazyKat52 View Post
How do we get to the kernel to disable it and what do we type?
There are several kernel boot options that are IOMMU-related. A good explanation of them can be found at Gentoo Wiki. Ultimately, one of them should be added to the variable GRUB_CMDLINE_LINUX in the file /etc/default/grub. After that, don't forget to run grub-mkconfig.

Before that, you can test different options by adding them to a kernel line in the GRUB boot menu and booting that kernel.

I don't know which option will work best in your case. Perhaps iommu=off is needed. Or maybe iommu=soft or even iommu=noforce would be enough. Or maybe you should go for some AMD-specific option like amd_iommu_intr=legacy. If you don't find any information specific to your hardware configuration then it's mostly trial and error process.

Last edited by shruggy; 03-19-2021 at 08:59 AM.
 
Old 03-19-2021, 08:58 AM   #9
KrazyKat52
LQ Newbie
 
Registered: Mar 2021
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Emerson View Post
Disable IOMMU in kernel.

We how do we edit the kernel? We got into recovery and are at root. Followed instructions to view localhost.localdomain kernel. It lets us view it, but can't edit it. Please advise. Thanks.
 
Old 03-19-2021, 02:47 PM   #10
KrazyKat52
LQ Newbie
 
Registered: Mar 2021
Posts: 21

Original Poster
Rep: Reputation: Disabled
Okay. According to one link given :

IS THIS CORRECT? (We have not done anything, yet.)

If we choose recovery, it will run and go to root after giving password.

Then type, cd /usr/src/linux, press Enter
Then type make menuconfig, press Enter

Then type
Device Drivers ---> [*] IOMMU Hardware Support --->
Generic IOMMU Pagetable Support ---- [*] AMD IOMMU support [*] Export AMD IOMMU statistics to debugfs
<M> AMD IOMMU Version 2 driver [*] Support for Intel IOMMU using DMA Remapping Devices [*] Support for Shared Virtual Memory with Intel IOMMU [*] Enable Intel DMA Remapping Devices by default [*] Support for Interrupt Remapping


Then type, mount /boot. Press Enter.
Then type #make && make modules_install && make install Press Enter.

I'm not sure if this is the correct order or if I'm missing steps. I also don't know what comes up after this, but it seems to mean that something comes up where I can turn the IOMMU to off.



???

Not sure where/how to do what shruggy typed:
GRUB_CMDLINE_LINUX in the file /etc/default/grub. After that, don't forget to run grub-mkconfig.



Thanks for your help

Last edited by KrazyKat52; 03-19-2021 at 02:52 PM. Reason: Add info
 
Old 03-19-2021, 03:01 PM   #11
shruggy
Senior Member
 
Registered: Mar 2020
Posts: 3,578

Rep: Reputation: Disabled
No. Those steps are for rebuilding the kernel from source. You don't need it. See Grub configuration at Mageia Wiki. Particularly this:
Quote:
GRUB_CMDLINE_LINUX_DEFAULT= allows to add options to the kernel.
And as I see now, Mageia has update-grub, so you should run it rather than grub-mkconfig.

An easier option for you probably would be adding kernel parameters in Grub Customizer, but you'd need to have a working GUI for this. Do Mageia live media include Grub Customizer, per chance?

You can edit a boot entry in GRUB boot menu by pressing e on it. See GRUB documentation.

BTW, have you tried safe boot (Advanced options for Mageia)?

Last edited by shruggy; 03-19-2021 at 03:23 PM.
 
Old 03-22-2021, 04:18 AM   #12
KrazyKat52
LQ Newbie
 
Registered: Mar 2021
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by shruggy View Post

And as I see now, Mageia has update-grub, so you should run it rather than grub-mkconfig.

An easier option for you probably would be adding kernel parameters in Grub Customizer, but you'd need to have a working GUI for this. Do Mageia live media include Grub Customizer, per chance?

You can edit a boot entry in GRUB boot menu by pressing e on it. See GRUB documentation.

BTW, have you tried safe boot (Advanced options for Mageia)?

When it was rebooted, we looked at the other boot options including under Advanced Options, but didn't find one that had Safe in its name.

We tried the Live disk, but it wouldn't load properly. We'll get back to you on the rest you noted, but wanted to give you an update.
 
Old 03-22-2021, 11:22 AM   #13
KrazyKat52
LQ Newbie
 
Registered: Mar 2021
Posts: 21

Original Poster
Rep: Reputation: Disabled
How do we get to and change the file /etc/default/grub?

We figured out (we think) GRUB_CMDLINE_LINUX_DEFAULT=
but what comes before or after that, we don't know. The grub customizer was confusing.

We also tried to update the grub via typing e on the grub screen, but we could not get it to save.

Thank you for your help...and thank you for your patience.

Last edited by KrazyKat52; 03-23-2021 at 04:10 AM.
 
Old 10-29-2022, 01:52 AM   #14
andrea77
LQ Newbie
 
Registered: Oct 2022
Posts: 1

Rep: Reputation: 0
I solved changing "XHCI Mode" in BIOS: from "Windows 10" to "Windows 7"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux mint boot error: "1.55 No irq handler for vector" sluggish system. Amit15 Linux Mint 6 08-20-2018 11:42 AM
How to eliminate error messages "do_IRQ: n.nnn No irq handler for vector (irq -1)" gwpucci Linux - Newbie 4 11-01-2017 09:31 PM
[SOLVED] RHEL 6.4 Error - kernel:do_IRQ: 1.205 No irq handler for vector (irq -1) capperdog Linux - Newbie 4 02-28-2014 09:56 AM
Wondering what "do_IRQ: .176 No Irq handler for vector (irq -1)" means 4restg Linux - Newbie 1 10-27-2009 03:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration