LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How can I use Java runtime? (https://www.linuxquestions.org/questions/linux-newbie-8/how-can-i-use-java-runtime-420222/)

annemarietjuhhh 02-28-2006 01:32 AM

How can I use Java runtime?
 
I have firefox 1.0.7 on my Ubuntu-computer. On another computer I do have firefox 1.0.7 too, but that's a windows computer. When I try to install Java Runtime Environment on my Ubuntu-computer, My browser doesn't use it. On my Windows-computer (with the same browser) it does work. Does anyone know how to solve this problem??

spooon 02-28-2006 01:53 AM

How did you install Java? See here for the different ways of installing Java on Ubuntu.

timmeke 02-28-2006 07:11 AM

Did you add the JRE plugin to Firefox, as explained on http://java.com/en/download/linux_manual.jsp, under
"instructions"?

Installation of the plugin doesn't only apply to Mozilla, it also applies for Firefox.

Furthermore, you should make sure that, once you have installed the plugin, you have Java support enabled.
To do this, open Firefox, and go to the menu Edit. There, you select Preferences. In one of the tabs,
you should find a checkbox "Enable Java" or something like that. Make sure it's selected.

annemarietjuhhh 02-28-2006 08:08 AM

[QUOTE=timmeke]Did you add the JRE plugin to Firefox, as explained on <<url>> under "instructions"?

Yes I did, and after I switched the Java on, but it still doesn't work.

timmeke 02-28-2006 08:23 AM

Have you tried spooon's suggestions too?

On my boxes (RH8 and FC3), it works just fine. All I did was install Java and then put the plugin in the right place and enable Java in the browser preferences and it's done.

Can you please post:
-the firefox version?
-the contents (ls -l) of /usr/lib/firefox-<version>/plugins
where <version> should be replaced by the version of Firefox you're running.

annemarietjuhhh 02-28-2006 10:09 AM

Quote:

Originally Posted by timmeke
Have you tried spooon's suggestions too?

Yeah I tried, but got only problems...

I have Firefox 1.0.7

I don't know how to get to the content of /usr/lib/firefox-<version>/plugins, because I can't find the directory anywhere. (I haven't installed it by myself, I installed Ubuntu, and Firefox was automatically included)

pljvaldez 02-28-2006 12:43 PM

Did you follow the Unofficial Ubuntu Guide?

Or try to install Automatix

Here's more details about automatix:
http://ubuntuforums.org/showthread.php?t=66563

annemarietjuhhh 02-28-2006 02:02 PM

Everytime when I try to install something with apt, my computer find an error (again... :cry: ) I should have to type apt-get update, but that doesn't work too.

ethics 02-28-2006 02:41 PM

it's nice to supply the error, helps people diagnose the problem, are you running apt get with
Code:

sudo apt-get update
Need sudo for root permissions since ubuntu doesnt use root by default


All times are GMT -5. The time now is 12:35 AM.