LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-14-2008, 07:45 AM   #1
sarmoodi
Member
 
Registered: Jan 2008
Posts: 37

Rep: Reputation: 15
How can i see and get access the ntfs partition from Mandriva??


hi..

the hard have 3 partitions now..:

c: ntfs for winXP
d: for linux_Mandriva
e: ntfs for documents

from mandriva i can see the c and d but not e: wich contain all the documents....so how this prob. can b solved??

thanx..
 
Old 01-14-2008, 08:06 AM   #2
deepumnit
Member
 
Registered: Dec 2006
Location: NOIDA, India
Distribution: Debian, SUSE, Fedora
Posts: 334
Blog Entries: 1

Rep: Reputation: 31
Dude, since 'C' is also NTFS, how can you see that? Did you mount that on your own? If you can mount that, why not 'E' too?

Well, if you want to see what all are mounted, type:
Code:
sudo mount
You can mount the 'E' drive or any other Windows partition by changing the '/etc/fstab' file entry on Linux.
 
Old 01-14-2008, 08:07 AM   #3
deepumnit
Member
 
Registered: Dec 2006
Location: NOIDA, India
Distribution: Debian, SUSE, Fedora
Posts: 334
Blog Entries: 1

Rep: Reputation: 31
Does Mandriva auto mount the Windows partitions like Fedora 8?

I'll be back in 20 minutes
 
Old 01-14-2008, 08:47 AM   #4
hansalfredche
Member
 
Registered: Jun 2005
Posts: 445

Rep: Reputation: 31
Probably the "E:" partition is not mounted. Have a look in Harddrake, probably you can fix it there.
 
Old 01-14-2008, 09:29 AM   #5
sarmoodi
Member
 
Registered: Jan 2008
Posts: 37

Original Poster
Rep: Reputation: 15
sorry guys but i can't get u...coz am really newbie for linux...imagine someone using win all the time and now for only 2 days using linux....i feel linke LOST in linux hhhh
 
Old 01-14-2008, 09:31 AM   #6
deepumnit
Member
 
Registered: Dec 2006
Location: NOIDA, India
Distribution: Debian, SUSE, Fedora
Posts: 334
Blog Entries: 1

Rep: Reputation: 31
Dude, we are here to help. Just paste your /etc/fstab file here.
 
Old 01-14-2008, 09:52 AM   #7
hansalfredche
Member
 
Registered: Jun 2005
Posts: 445

Rep: Reputation: 31


Most feel lost at first. Diskdrake (I wrongly typed Harddrake, sorry) is in the Control Center btw. You can also start a command line and type:
Quote:
su
[password]
diskdrake
You should get a window looking like this:
http://linux.techteam.gr/docs/mandra...drake-use1.png

I think "E:" is another hard drive, no? If yes it is in a tab, it should either be called hdx or sdx with "x" usually a letter from the beginning of the alphabet. If you look at the screenshot above you see that two drives are present: hda and hdb
 
Old 01-14-2008, 10:05 AM   #8
sarmoodi
Member
 
Registered: Jan 2008
Posts: 37

Original Poster
Rep: Reputation: 15
this is /ets/fstab :



/dev/hda5 / ext3 noatime 1 1
none /proc proc defaults 0 0
/dev/hda7 swap swap defaults 0 0
/dev/hda1 /media/hd ntfs umask=0022,nls=utf8,sync,ro 0 0
/dev/hda6 /media/hd2 ntfs umask=0022,nls=utf8,sync,ro 0 0


and thank u deepumnit and hansalfrendche for help
 
Old 01-14-2008, 10:13 AM   #9
sarmoodi
Member
 
Registered: Jan 2008
Posts: 37

Original Poster
Rep: Reputation: 15
and now i've run the diskdrake !!!! when i installed the linux i've choosen about 400 MB to b as swap partition but now what i c is this 400 MB is read as windows partition from linux and the 35GB which should b E: partition is read as swap !!!
 
Old 01-14-2008, 10:18 AM   #10
monsm
Member
 
Registered: Feb 2005
Location: London, UK
Distribution: Gentoo
Posts: 568

Rep: Reputation: 37
Looks like you have both your NTFS drives mounted already:
"/dev/hda5 /" = d: for linux_Mandriva
"/dev/hda1 /media/hd" = probably c: ntfs for winXP
"/dev/hda6 /media/hd2" = proabably e: ntfs for documents

Open a bash prompt (command line) and run "ls /media/hd" and "ls /media/hd2". If everyingthing is ok you should get the content of each driver.

Last edited by monsm; 01-14-2008 at 10:21 AM. Reason: typo
 
Old 01-14-2008, 10:20 AM   #11
monsm
Member
 
Registered: Feb 2005
Location: London, UK
Distribution: Gentoo
Posts: 568

Rep: Reputation: 37
Your post came just before I pressed the submit button there. So what do you get with those 2 ls commands?
 
Old 01-14-2008, 10:23 AM   #12
deepumnit
Member
 
Registered: Dec 2006
Location: NOIDA, India
Distribution: Debian, SUSE, Fedora
Posts: 334
Blog Entries: 1

Rep: Reputation: 31
Also paste the output for the following command as root:
Code:
fdisk -l
So that we will be able to edit your /etc/fstab file! You can paste that there and reboot to see all your drives!
 
Old 01-14-2008, 11:13 AM   #13
sarmoodi
Member
 
Registered: Jan 2008
Posts: 37

Original Poster
Rep: Reputation: 15
this is what appeared:


[sarmad@localhost ~]$ ls /media/hd
AUTOEXEC.BAT* IO.SYS* Program Files/
boot.ini* MSDOS.SYS* RECYCLER/
CONFIG.SYS* NTDETECT.COM* System Volume Information/
dell/ ntldr* WINDOWS/
Documents and Settings/ pagefile.sys* YServer.txt*
[sarmad@localhost ~]$ ls /media/hd2
[sarmad@localhost ~]$



i think there is a problem with the swap coz as i told u when i open the hard disk manager of linux i've found the swap is occupying the partition which is supposed to b for documents which is the E: partition as i c it from the win !!
 
Old 01-14-2008, 12:02 PM   #14
deepumnit
Member
 
Registered: Dec 2006
Location: NOIDA, India
Distribution: Debian, SUSE, Fedora
Posts: 334
Blog Entries: 1

Rep: Reputation: 31
Dear Sarmoodi:

Put your 'fdisk -l' output. You should type 'su' in a terminal before using that command.
 
Old 01-14-2008, 02:15 PM   #15
hansalfredche
Member
 
Registered: Jun 2005
Posts: 445

Rep: Reputation: 31
Strange. You are saying the 35GB are used as swap? So first of all save anything what you have on your 35GB partition (if nothing is on it the better). Then start diskdrake and enable advanced mode. You should first try to assign a swap partition on the 400MB big one. For this first unmount the 400MB partition. Then the options should change and you should find something saying "type" (I don't have it in english here) where you have a list of filesystems. Choose "linux-swap" and confirm (make sure everything important has been saved on another hard drive before!). Then use the same procedure for the second partition, just select "NTFS" as filesystem this time. Re-mount both partitions, exit the diskdrake and restart your machine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandriva Installer Changes NTFS Partition NarrowPathPilgrim Linux - Newbie 1 11-05-2007 07:07 PM
NTFS partition access kodiak18 Mandriva 8 08-16-2007 04:46 PM
NTFS partition access Red Barchetta Linux - Newbie 6 03-23-2007 05:22 AM
Can't access NTFS partitions from mandriva 2007 majk Linux - Newbie 1 12-04-2006 09:14 AM
NTFS partition access rr_rr_29 Linux - Hardware 1 10-17-2005 05:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration