LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-07-2010, 05:32 AM   #1
genogebot
Member
 
Registered: Jun 2010
Location: Brisbane, Australia
Distribution: Xubuntu 16.04.1 / Linux Mint 18 XFCE / Linux Mint 18 Mate / Ubuntu Server 16.04.1 / Lubuntu 16.04.1
Posts: 146

Rep: Reputation: 19
Question How can I prevent Network Manager from automatically enabling wireless?


I'm running Linux Mint 9 with Gnome.

I don't want my wireless network card to be automatically enabled in Network Manager when I start my computer. I keep setting it to disabled in Network Manager but when I reboot Network Manager has re-enabled it again.

Is there some way of starting with wireless disabled until I tell Network Manager to enable it?
 
Old 07-07-2010, 05:47 AM   #2
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,167

Rep: Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524
I'm running version 0.8. If you edit the wireless connection, there is a check box called Connect automatically. Uncheck that box for your wireless connection.

You should be able to have several network connections, and have none start automatically. Then choose the one you want depending on your location.
 
Old 07-07-2010, 06:05 AM   #3
genogebot
Member
 
Registered: Jun 2010
Location: Brisbane, Australia
Distribution: Xubuntu 16.04.1 / Linux Mint 18 XFCE / Linux Mint 18 Mate / Ubuntu Server 16.04.1 / Lubuntu 16.04.1
Posts: 146

Original Poster
Rep: Reputation: 19
camorri, thanks for your quick reply, but that's not what I was referring to. I'm not talking about preventing automatic connection to a network, I'm trying to stop the wireless card from being enabled at all.

In the Network Manager applet, there's an entry 'Enable Wireless' with a check mark next to it. I click on it to disable wireless, but each time I restart my computer it's enabled again. I want to prevent that from happening.
 
Old 07-07-2010, 06:25 AM   #4
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,595

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
From the GNOME menu: System->Preferences->Startup Applications then disable NetworkManager
 
Old 07-07-2010, 06:33 AM   #5
genogebot
Member
 
Registered: Jun 2010
Location: Brisbane, Australia
Distribution: Xubuntu 16.04.1 / Linux Mint 18 XFCE / Linux Mint 18 Mate / Ubuntu Server 16.04.1 / Lubuntu 16.04.1
Posts: 146

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by RockDoctor View Post
From the GNOME menu: System->Preferences->Startup Applications then disable NetworkManager
Thanks. Will that still allow my wired network to connect automatically?
 
Old 07-07-2010, 07:41 AM   #6
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,867
Blog Entries: 27

Rep: Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162Reputation: 2162
Hi,

Quote:
Originally Posted by genogebot View Post
Thanks. Will that still allow my wired network to connect automatically?
If you disable the Network Manager then I suggest the use of 'wicd';

Quote:
excerpt from 'wicd';

Wicd is an open source wired and wireless network manager for Linux which aims to provide a simple interface to connect to networks with a wide variety of settings.
Some of Wicd's features include:

  1. A full-featured interactive console interface and graphical interface
  2. No required graphical dependencies (ie, no X, Gnome, KDE)
  3. GTK interface has no GNOME dependencies, so it can be used in XFCE, Fluxbox, Openbox, Enlightenment, etc.
  4. Ability to connect to wired (Ethernet only, no PPPoE/DSL support yet) and wireless networks
  5. Profiles for each wireless network and wired network
  6. Many encryption schemes, some of which include WEP/WPA/WPA2 (and you can add your own)
  7. Remains compatible with wireless-tools
  8. Tray icon showing network activity and signal strength
wicd is a lot better therfore easier to use.


The above links and others can be found at 'Slackware-Links'. More than just SlackwareŽ links!
 
Old 07-07-2010, 08:04 AM   #7
genogebot
Member
 
Registered: Jun 2010
Location: Brisbane, Australia
Distribution: Xubuntu 16.04.1 / Linux Mint 18 XFCE / Linux Mint 18 Mate / Ubuntu Server 16.04.1 / Lubuntu 16.04.1
Posts: 146

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by onebuck View Post
If you disable the Network Manager then I suggest the use of 'wicd';
Thanks, I'll give wicd a try.

I've hunted around the Network Manager site and there doesn't seem to be a way to make it behave the way I want. Maybe I'll have more luck with wicd.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless network connects and works fine, but doesnt show up on the network manager newbie236 Linux - Newbie 1 07-07-2010 12:47 AM
automatically connecting to wireless network kunalshah Linux - Laptop and Netbook 2 10-26-2008 07:46 PM
Wireless network won't automatically connect Ehlyah Linux - Wireless Networking 1 04-22-2008 08:01 AM
Enabling a Wireless network Manually C-Sniper Slackware 4 12-17-2006 12:10 AM
Automatically switch to different wireless network? m_a_b Linux - Wireless Networking 0 10-07-2004 09:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration