LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-06-2019, 07:34 PM   #1
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Posts: 817

Rep: Reputation: 58
Red face How can I make it so I can easily select 75hz as my monitor refresh rate in KDE?


FTR, I know I can fire some commands into the prompt to make this happen, but I am trying to get away from doing these one off alterations of the OS and looking for more complete solutions. I want to make it so I can physically click the refresh rate drop down in the KDE-Displays window and select 75hz.

Also, I'd like to know if games that I am playing through Wine/Lutris/Proton will detect that I now have a 75hz capable screen like it would on Windows.

I am using Kubuntu 18.04, R7-1700 / rx480 and I believe I am using the open source gpu drivers.

Thanks in advance!
 
Old 10-07-2019, 03:58 AM   #2
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 3,647
Blog Entries: 1

Rep: Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215
In System Settings -> Displays should be a select list near the bottom center for refresh rate. If your display supports 75, it should be selectable there. Are you saying 75 isn't there, or that it won't let you select it? With my Vizio 1920x1080 TV @1920x1080, 75 isn't available, only 60 or less.

Please provide output from running 'inxi -GxxS' in Konsole? Does it report use of amdgpu? If it doesn't, that needs to be solved before concern with what to click in Plasma.
 
1 members found this post helpful.
Old 10-07-2019, 12:46 PM   #3
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Posts: 817

Original Poster
Rep: Reputation: 58
Quote:
Originally Posted by mrmazda View Post
In System Settings -> Displays should be a select list near the bottom center for refresh rate. If your display supports 75, it should be selectable there. Are you saying 75 isn't there, or that it won't let you select it? With my Vizio 1920x1080 TV @1920x1080, 75 isn't available, only 60 or less.

Please provide output from running 'inxi -GxxS' in Konsole? Does it report use of amdgpu? If it doesn't, that needs to be solved before concern with what to click in Plasma.
It's definitely a 75hz screen, on Windows it worked as a 75hz screen although I did have to set it as a custom resolution in the AMD driver program. I do not have the AMD driver program on linux, should I Just get that?

Code:
wh33t@wh33tbox:~$ inxi -GxxS
System:    Host: wh33tbox Kernel: 5.0.0-31-generic x86_64 bits: 64 gcc: 7.4.0
           Desktop: KDE Plasma 5.12.9 (Qt 5.9.5) dm: sddm,sddm Distro: Ubuntu 18.04.3 LTS
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X]
           bus-ID: 06:00.0 chip-ID: 1002:67df
           Display Server: x11 (X.Org 1.20.4 ) drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa)
           Resolution: 2560x1080@60.00hz
           OpenGL: renderer: AMD Radeon RX 480 Graphics (POLARIS10, DRM 3.27.0, 5.0.0-31-generic, LLVM 8.0.0)
           version: 4.5 Mesa 19.1.2 - padoka PPA Direct Render: Yes
 
Old 10-07-2019, 01:29 PM   #4
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 3,647
Blog Entries: 1

Rep: Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215
The proprietary amdcpu driver for your system is probably not available. For the newest distros it was deprecated in favor of the FOSS DDX provided by xserver-xorg-video-amdgpu.

That version of inxi isn't making it clear which DDX is in use, but it looks like more likely the ati than the amdgpu. Check as I indicated in /var/log/Xorg.0.log as I indicated, if it exists, or if not, ~/.local/share/xorg/Xorg.0.log to see which is in use. If the amdgpu is not in use, purging xserver-xorg-video-ati and xserver-xorg-video-radeon should switch to using it.
 
1 members found this post helpful.
Old 10-17-2019, 09:02 PM   #5
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Posts: 817

Original Poster
Rep: Reputation: 58
Most of the log file is stuff like this.

Code:
[ 67612.930] (II) AMDGPU(0): Modeline "1280x720"x0.0   74.25  1280 1720 1760 1980  720 725 730 750 +hsync +vsync (37.5 kHz e)
[ 67612.930] (II) AMDGPU(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[ 67612.930] (II) AMDGPU(0): Modeline "640x480"x0.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz e)
[ 67612.930] (II) AMDGPU(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz e)
It looks like I'm using AMDGPU?

The words ATI do appear in the log as well though. The xorg.log file is so huge it won't even fit in the konsole buffer when I 'cat' it out. But here are some more excerpts.

Code:
[    14.437]    ABI class: X.Org Server Extension, version 10.0
[    14.437] (II) Applying OutputClass "AMDgpu" to /dev/dri/card0
[    14.437]    loading driver: amdgpu  
[    14.437] (==) Matched amdgpu as autoconfigured driver 0
[    14.437] (==) Matched ati as autoconfigured driver 1
[    14.437] (==) Matched modesetting as autoconfigured driver 2
[    14.437] (==) Matched fbdev as autoconfigured driver 3
[    14.437] (==) Matched vesa as autoconfigured driver 4
[    14.437] (==) Assigned the driver to the xf86ConfigLayout
[    14.437] (II) LoadModule: "amdgpu"  
[    14.438] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so
[    14.441] (II) Module amdgpu: vendor="X.Org Foundation"
[    14.441]    compiled for 1.20.4, module version = 19.0.1
[    14.441]    Module class: X.Org Video Driver
[    14.441]    ABI class: X.Org Video Driver, version 24.0
[    14.441] (II) LoadModule: "ati"
[    14.441] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[    14.442] (II) Module ati: vendor="X.Org Foundation"
[    14.442]    compiled for 1.20.4, module version = 19.0.1
[    14.442]    Module class: X.Org Video Driver
[    14.442]    ABI class: X.Org Video Driver, version 24.0
[    14.471] (II) LoadModule: "modesetting"
[    14.471] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    14.472] (II) Module modesetting: vendor="X.Org Foundation"
[    14.472]    compiled for 1.20.4, module version = 1.20.4
[    14.472]    Module class: X.Org Video Driver
[    14.472]    ABI class: X.Org Video Driver, version 24.0
[    14.472] (II) LoadModule: "fbdev"
[    14.473] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    14.473] (II) Module fbdev: vendor="X.Org Foundation"
[    14.473]    compiled for 1.20.1, module version = 0.5.0
[    14.473]    Module class: X.Org Video Driver
[    14.473]    ABI class: X.Org Video Driver, version 24.0
[    14.473] (II) LoadModule: "vesa"
[    14.473] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    14.474] (II) Module vesa: vendor="X.Org Foundation"
[    14.474]    compiled for 1.20.1, module version = 2.4.0
[    14.474]    Module class: X.Org Video Driver
[    14.474]    ABI class: X.Org Video Driver, version 24.0
[    14.474] (II) AMDGPU: Driver for AMD Radeon:
Here is a part that mentions ATI

Code:
[    14.437]    ABI class: X.Org Server Extension, version 10.0
[    14.437] (II) Applying OutputClass "AMDgpu" to /dev/dri/card0
[    14.437]    loading driver: amdgpu  
[    14.437] (==) Matched amdgpu as autoconfigured driver 0
[    14.437] (==) Matched ati as autoconfigured driver 1
[    14.437] (==) Matched modesetting as autoconfigured driver 2
[    14.437] (==) Matched fbdev as autoconfigured driver 3
[    14.437] (==) Matched vesa as autoconfigured driver 4
[    14.437] (==) Assigned the driver to the xf86ConfigLayout
[    14.437] (II) LoadModule: "amdgpu"  
[    14.438] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so
[    14.441] (II) Module amdgpu: vendor="X.Org Foundation"
[    14.441]    compiled for 1.20.4, module version = 19.0.1
[    14.441]    Module class: X.Org Video Driver
[    14.441]    ABI class: X.Org Video Driver, version 24.0
[    14.441] (II) LoadModule: "ati"
[    14.441] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[    14.442] (II) Module ati: vendor="X.Org Foundation"
[    14.442]    compiled for 1.20.4, module version = 19.0.1
[    14.442]    Module class: X.Org Video Driver
[    14.442]    ABI class: X.Org Video Driver, version 24.0
[    14.471] (II) LoadModule: "modesetting"
[    14.471] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    14.472] (II) Module modesetting: vendor="X.Org Foundation"
[    14.472]    compiled for 1.20.4, module version = 1.20.4
[    14.472]    Module class: X.Org Video Driver
[    14.472]    ABI class: X.Org Video Driver, version 24.0
[    14.472] (II) LoadModule: "fbdev"
[    14.473] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    14.473] (II) Module fbdev: vendor="X.Org Foundation"
[    14.473]    compiled for 1.20.1, module version = 0.5.0
[    14.473]    Module class: X.Org Video Driver
[    14.473]    ABI class: X.Org Video Driver, version 24.0
[    14.473] (II) LoadModule: "vesa"
[    14.473] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    14.474] (II) Module vesa: vendor="X.Org Foundation"
[    14.474]    compiled for 1.20.1, module version = 2.4.0
[    14.474]    Module class: X.Org Video Driver
[    14.474]    ABI class: X.Org Video Driver, version 24.0
[    14.474] (II) AMDGPU: Driver for AMD Radeon:
Sorry took so long to reply! I have been busy with other things. Appreciate the help a lot!
 
Old 10-17-2019, 09:53 PM   #6
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 3,647
Blog Entries: 1

Rep: Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215
Quote:
Originally Posted by wh33t View Post
Code:
...AMDGPU(0)...
AMDGPU(0)...
AMDGPU(0)...
AMDGPU(0)...
It looks like I'm using AMDGPU?
Correct!

Quote:
The xorg.log file is so huge it won't even fit in the konsole buffer when I 'cat' it out.
Logs should be uploaded and the URL to the upload location pasted here. The pastebinit command facilitates doing this.
 
1 members found this post helpful.
Old 10-17-2019, 11:22 PM   #7
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Posts: 817

Original Poster
Rep: Reputation: 58
Quote:
Originally Posted by mrmazda View Post
Correct!

Logs should be uploaded and the URL to the upload location pasted here. The pastebinit command facilitates doing this.
Would you like me to upload the entire log to pastebin? I'm not sure where to go from here.
 
Old 10-17-2019, 11:32 PM   #8
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 3,647
Blog Entries: 1

Rep: Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215
If you upload the log we might be able to spot a reason why your problem exists.
 
1 members found this post helpful.
Old 10-17-2019, 11:35 PM   #9
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Posts: 817

Original Poster
Rep: Reputation: 58
Quote:
Originally Posted by mrmazda View Post
If you upload the log we might be able to spot a reason why your problem exists.
Like I mentioned earlier, it's a 75hz screen but even in Windows land it wasn't detected as a 75hz screen. I had to use the AMD Driver suite to add a custom resolution that was 75hz, and then use it that way. I'm trying to make it so that I can select 75hz as a option from the KDE Display tool. The only options I get in the Display tool are AUTO and 60hz. I'd like to make it so 75hz is selectable.
 
Old 10-18-2019, 01:03 AM   #10
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 3,647
Blog Entries: 1

Rep: Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215
Code:
Section "Monitor"
    Identifier	"Default Monitor"
    HorizSync	30-120	# this needs to be the spec for your display
    VertRefresh	56-86	# this needs to be the spec for your display
    Option	"TargetRefreshRate"	"75"
    Option	"DDC"	"off"
    Option	"DefaultModes"	"on"
    Option	"PreferredMode"	"2560x1080@75"
EndSection
It's possible creating /etc/X11/xorg.conf.d/50-monitor.conf containing the above or some variation of the above would solve the problem. It may be that corresponding files 50-device.conf and/or 50-screen-conf would also need to be required, in which case you might find it easier to put it all in /etc/X11/xorg.conf:
Code:
Section "Device"
    Identifier "Default Device"
EndSection

Section "Monitor"
    Identifier	"Default Monitor"
    HorizSync	30-120	# this needs to be the spec for your display
    VertRefresh	56-86	# this needs to be the spec for your display
    Option	"TargetRefreshRate"	"75"
    Option	"DDC"	"off"
    Option	"PreferredMode"	"2560x1080@75"
EndSection

Section "Screen"
  Identifier "Default Screen"
  Device "Default Device"
  Monitor "Default Monitor"
EndSection
If you cannot locate the published HorizSync and VertRefresh for your display to included in Section Monitor, you should be able to get them from:
Code:
hwinfo --monitor
Next to try if it doesn't work would be to include a modeline in Section Monitor, something I've never found necessary, but is commonly recommended among help forums.

Again, there might be a clue to the failure in Xorg.0.log.
 
1 members found this post helpful.
Old 10-20-2019, 07:06 PM   #11
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Posts: 817

Original Poster
Rep: Reputation: 58
I don't have any xorg files in that directory, should there be some in there?

Code:
wh33t@wh33tbox:/etc/X11$ ls -al
total 96
drwxr-xr-x  11 root root  4096 Aug  5 12:03 .
drwxr-xr-x 135 root root 12288 Oct 20 15:42 ..
drwxr-xr-x   2 root root  4096 Sep 28 14:05 app-defaults
drwxr-xr-x   2 root root  4096 Aug  5 12:02 cursors
-rw-r--r--   1 root root    14 Aug  5 12:03 default-display-manager
drwxr-xr-x   4 root root  4096 Aug  5 12:02 fonts
-rw-r--r--   1 root root 17394 Jan 19  2017 rgb.txt
drwxr-xr-x   2 root root  4096 Sep 28 13:54 xinit
drwxr-xr-x   2 root root  4096 Feb  2  2018 xkb
-rwxr-xr-x   1 root root   709 Jan 19  2017 Xreset
drwxr-xr-x   2 root root  4096 Aug  5 12:02 Xreset.d
drwxr-xr-x   2 root root  4096 Aug  5 12:02 Xresources
-rwxr-xr-x   1 root root  3730 May  3  2017 Xsession
drwxr-xr-x   2 root root  4096 Sep 29 17:05 Xsession.d
-rw-r--r--   1 root root   265 Jan 19  2017 Xsession.options
drwxr-xr-x   2 root root  4096 Aug  5 12:03 xsm
-rw-r--r--   1 root root    13 Dec  5  2016 XvMCConfig
-rw-r--r--   1 root root   630 Aug  5 12:03 Xwrapper.config
 
Old 10-20-2019, 07:26 PM   #12
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 3,647
Blog Entries: 1

Rep: Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215
Any files in /etc/X11/xorg.conf.d/ are optional, as are file /etc/X11/xorg.conf and directory /etc/X11/xorg.conf.d/.
 
1 members found this post helpful.
Old 10-21-2019, 06:58 AM   #13
allend
LQ 5k Club
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 5,834

Rep: Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322
Quote:
Like I mentioned earlier, it's a 75hz screen but even in Windows land it wasn't detected as a 75hz screen. I had to use the AMD Driver suite to add a custom resolution that was 75hz, and then use it that way. I'm trying to make it so that I can select 75hz as a option from the KDE Display tool. The only options I get in the Display tool are AUTO and 60hz. I'd like to make it so 75hz is selectable.
Unlike Windows, X respects hardware provided information. My thought is that your monitor is supplying incomplete EDID information. Without a log, this is impossible to verify. If you were to do a web search for "X CustomEDID", you would find many guides on how to use the "CustomEDID" option for X. I used to use this for an old laptop that did not properly advertise the native resolution.
 
Old 10-21-2019, 07:28 AM   #14
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 3,647
Blog Entries: 1

Rep: Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215Reputation: 1215
Did you try any of my comment 10 suggestions (which are much simpler than custom EDID)?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I would like to change screen refresh rate to 75Hz itz2000 Linux - Newbie 17 06-10-2019 08:19 AM
NVIDIA install driver problems; Cannot select a higher Refresh rate jadex Linux - Newbie 9 01-27-2007 10:41 PM
NVIDIA install driver problems; Cannot select a higher Refresh rate. jadex Linux - Software 3 01-24-2007 11:56 PM
none of the changes i make to my monitor refresh rate in the control centre stick Michael_aust Mandriva 3 01-24-2006 05:46 PM
Vertical refresh rate, horizontal sync rate. NomDeGuerre Linux - Newbie 7 10-07-2005 03:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration