LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-08-2004, 01:18 PM   #1
dodo1983
Member
 
Registered: May 2004
Location: BS
Distribution: Mandrake
Posts: 59

Rep: Reputation: 15
How can I know...?


I would like to know how I am able to know whih file I have to handle (install, uncompress..., etc...) if I downloaded something.

For example: I installed mplayer and as I looked for its location I've got:

[usr@usr sur]$ su
Password:
[root@usr usr]# find / -name mplayer
/etc/mplayer
/usr/share/mplayer
/usr/bin/mplayer
/usr/lib/mplayer

So, four locations in which mplayer is. Where do I have to go in the console? Which file do I have to uncompress?

Thank you for helping.
 
Old 06-08-2004, 01:23 PM   #2
t3___
Member
 
Registered: Sep 2003
Posts: 240

Rep: Reputation: 30
describe how you "installed" it?

did you decompress a .tar.gz file such as mplayer.1.2.0.tar.gz, then run ./configure, then run make, then run make install?

or did you install from an rpm

have you tried just running the command mplayer from the "run" option in the GUI, or just at a terminal prompt?
 
Old 06-08-2004, 01:28 PM   #3
dodo1983
Member
 
Registered: May 2004
Location: BS
Distribution: Mandrake
Posts: 59

Original Poster
Rep: Reputation: 15
Actually mplayer was already available in MandrakeLinux 10.0. So I just downloaded it by going to 'install software'...
After installing I didn't do any actions.
 
Old 06-08-2004, 01:30 PM   #4
lyceum
Member
 
Registered: Aug 2003
Location: N.C.
Distribution: rh9, fc1, slack 9.1, 10
Posts: 229

Rep: Reputation: 30
it appears that it is already installed, so you shouldn't have to decompress anything. try opening a terminal and typing
Code:
mplayer
 
Old 06-08-2004, 01:33 PM   #5
t3___
Member
 
Registered: Sep 2003
Posts: 240

Rep: Reputation: 30
agreed. you should just be able to type mplayer at the command line.

I'm not familiar with the mandrake gui or what thier default is, but it should be pretty easy to create an icon that runs the command mplayer (don't worry about entering a path).
 
Old 06-08-2004, 01:34 PM   #6
dodo1983
Member
 
Registered: May 2004
Location: BS
Distribution: Mandrake
Posts: 59

Original Poster
Rep: Reputation: 15
I've got a lot of informations in the console because I wrote 'mplayer'... can you help me going ahead?
 
Old 06-08-2004, 01:43 PM   #7
dodo1983
Member
 
Registered: May 2004
Location: BS
Distribution: Mandrake
Posts: 59

Original Poster
Rep: Reputation: 15
if I want to create a shortcut- from which direction in which mplayer is do I have to do this shortcut?
(sorry, maybe my questions are a little bit clumsy..)
 
Old 06-08-2004, 01:52 PM   #8
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
So you got a lot of information in console. But did the mplayer start? Probably.

Simple way to find where the mplayer is:

which mplayer
or
which gmplayer (in FC2 mplayer is started with gmplayer)

This will produce the directory mplayer is in. Just create a shortcut on your desktop with right click. And copy the path to the file you got from the which command.

Good luck!
 
Old 06-08-2004, 01:53 PM   #9
lyceum
Member
 
Registered: Aug 2003
Location: N.C.
Distribution: rh9, fc1, slack 9.1, 10
Posts: 229

Rep: Reputation: 30
the shortcut should use /usr/bin/mplayer as it's target if the above information from your first post is still valid. (though depending on your PATH variable, that full pathname may not be needed)

Last edited by lyceum; 06-08-2004 at 01:55 PM.
 
Old 06-08-2004, 01:57 PM   #10
dodo1983
Member
 
Registered: May 2004
Location: BS
Distribution: Mandrake
Posts: 59

Original Poster
Rep: Reputation: 15
Thanks to all. Thats what I wanted to know
 
Old 06-08-2004, 03:11 PM   #11
dodo1983
Member
 
Registered: May 2004
Location: BS
Distribution: Mandrake
Posts: 59

Original Poster
Rep: Reputation: 15
Something is not good: I cannot play anything with mplayer.

[dodo@Dominik dodo]$ mplayer
MPlayer 1.0pre3-3.3.2 (C) 2000-2003 MPlayer Team

CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville 1043 MHz (Family: 6, Stepping: 6)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/dodo/.mplayer/config
Reading /home/dodo/.mplayer/codecs.conf: Can't open '/home/dodo/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 61 audio & 169 video codecs
Usage: mplayer [options] [url|path/]filename

Basic options: (complete list in the man page)
-vo <drv[:dev]> select video output driver & device ('-vo help' for a list)
-ao <drv[:dev]> select audio output driver & device ('-ao help' for a list)
vcd://<trackno> play VCD (Video CD) track from device instead of plain file
dvd://<titleno> play DVD title from device instead of plain file
-alang/-slang select DVD audio/subtitle language (by 2-char country code)
-ss <timepos> seek to given (seconds or hh:mm:ss) position
-nosound do not play sound
-fs fullscreen playback (or -vm, -zoom, details in the man page)
-x <x> -y <y> set display resolution (for use with -vm or -zoom)
-sub <file> specify subtitle file to use (also see -subfps, -subdelay)
-playlist <file> specify playlist file
-vid x -aid y select video (x) and audio (y) stream to play
-fps x -srate y change video (x fps) and audio (y Hz) rate
-pp <quality> enable postprocessing filter (details in the man page)
-framedrop enable frame dropping (for slow machines)

Basic keys: (complete list in the man page, also check input.conf)
<- or -> seek backward/forward 10 seconds
up or down seek backward/forward 1 minute
pgup or pgdown seek backward/forward 10 minutes
< or > step backward/forward in playlist
p or SPACE pause movie (press any key to continue)
q or ESC stop playing and quit program
+ or - adjust audio delay by +/- 0.1 second
o cycle OSD mode: none / seekbar / seekbar + timer
* or / increase or decrease PCM volume
z or x adjust subtitle delay by +/- 0.1 second
r or t adjust subtitle position up/down, also see -vf expand

* * * SEE THE MAN PAGE FOR DETAILS, FURTHER (ADVANCED) OPTIONS AND KEYS * * *

[dodo@Dominik dodo]$ --disable-runtime-cpudetection
bash: --disable-runtime-cpudetection: command not found
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.



What can I do to make mplayer work?
Thanks for helping again
 
Old 06-08-2004, 03:15 PM   #12
t3___
Member
 
Registered: Sep 2003
Posts: 240

Rep: Reputation: 30
to follow thier recommendation to recompile, you need to remove the existing package, get the latest version of the program in a non-rpm format (.tar.gz file), then follow the

./configure

make

make install

procedure, adding the --disable-runtime-cpudetection option (not sure what step you do that at? can anyone help?)

Last edited by t3___; 06-08-2004 at 03:17 PM.
 
Old 06-08-2004, 03:20 PM   #13
brentos
Member
 
Registered: Nov 2003
Distribution: Fedora Core3, RHEL3,4
Posts: 92

Rep: Reputation: 15
The --disable-runtime-cpudetection option will be on the configure so
./configure --disable-runtime-cpudetection
 
Old 06-08-2004, 03:31 PM   #14
dodo1983
Member
 
Registered: May 2004
Location: BS
Distribution: Mandrake
Posts: 59

Original Poster
Rep: Reputation: 15
I reinstalled the package from my system. I think I damaged it by my own

Now I got this:

mplayer
MPlayer 1.0pre3-3.3.2 (C) 2000-2003 MPlayer Team

CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville 1042 MHz (Family: 6, Stepping: 6)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/dodo/.mplayer/config
Reading /home/dodo/.mplayer/codecs.conf: Can't open '/home/dodo/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 61 audio & 169 video codecs
Usage: mplayer [options] [url|path/]filename

Basic options: (complete list in the man page)
-vo <drv[:dev]> select video output driver & device ('-vo help' for a list)
-ao <drv[:dev]> select audio output driver & device ('-ao help' for a list)
vcd://<trackno> play VCD (Video CD) track from device instead of plain file
dvd://<titleno> play DVD title from device instead of plain file
-alang/-slang select DVD audio/subtitle language (by 2-char country code)
-ss <timepos> seek to given (seconds or hh:mm:ss) position
-nosound do not play sound
-fs fullscreen playback (or -vm, -zoom, details in the man page)
-x <x> -y <y> set display resolution (for use with -vm or -zoom)
-sub <file> specify subtitle file to use (also see -subfps, -subdelay)
-playlist <file> specify playlist file
-vid x -aid y select video (x) and audio (y) stream to play
-fps x -srate y change video (x fps) and audio (y Hz) rate
-pp <quality> enable postprocessing filter (details in the man page)
-framedrop enable frame dropping (for slow machines)

Basic keys: (complete list in the man page, also check input.conf)
<- or -> seek backward/forward 10 seconds
up or down seek backward/forward 1 minute
pgup or pgdown seek backward/forward 10 minutes
< or > step backward/forward in playlist
p or SPACE pause movie (press any key to continue)
q or ESC stop playing and quit program
+ or - adjust audio delay by +/- 0.1 second
o cycle OSD mode: none / seekbar / seekbar + timer
* or / increase or decrease PCM volume
z or x adjust subtitle delay by +/- 0.1 second
r or t adjust subtitle position up/down, also see -vf expand

* * * SEE THE MAN PAGE FOR DETAILS, FURTHER (ADVANCED) OPTIONS AND KEYS * * *

But if I want to start the *rmbv - movie, it starts Totem Player. What shall I do? Thanks
 
Old 06-08-2004, 03:34 PM   #15
dodo1983
Member
 
Registered: May 2004
Location: BS
Distribution: Mandrake
Posts: 59

Original Poster
Rep: Reputation: 15
Sorry, out there... I didn't see that I realy have to download a new package... sorry. You don't have to send posts for that..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration