LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-14-2012, 09:57 AM   #16
yurigaitho
LQ Newbie
 
Registered: Oct 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
apt url help


on the ubuntu update page http://www.ubuntuupdates.org/package...biaxclient-dev i try installing the package by using the APT INSTALL link but all i get in the address bar is the url "apt:libiaxclient-dev" any ideas how i can use APT INSTALL link to install the package..i have checked to see if apt url is installed in my system by using command "sudo apt-get install apturl" i get

yurigaitho@yurigaitho-HP-Compaq-dc7100-SFF-PC923A ~ $ sudo apt-get install apturl
[sudo] password for yurigaitho:
Reading package lists... Done
Building dependency tree
Reading state information... Done
apturl is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 293 not upgraded.
yurigaitho@yurigaitho-HP-Compaq-dc7100-SFF-PC923A ~ $



any ideas how to correctly use "apt install" to get that package

Last edited by yurigaitho; 10-14-2012 at 10:15 AM.
 
Old 10-14-2012, 01:33 PM   #17
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975
there is no correct way to get it. All that will do is run "apt install libiaxwhatever-dev" for you. which doesn't work as it's not built for your distro. there is no package. end of story. so compile it yourself, or use the distro the install instructions clearly say you should.
 
Old 11-01-2012, 10:03 AM   #18
yurigaitho
LQ Newbie
 
Registered: Oct 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
I managed to successfully extract "warvox" program using command terminal however i'm stuck at step when i run the command "sudo apt-get install build-essential libiaxclient-dev sox lame ruby ruby-dev rake rubygems libopenssl-ruby libreadline-ruby libsqlite3-ruby gnuplot"
i get error message

"E: Unable to locate package libiaxclient-dev"

after i get a libiaxclient.dev from here and insatll it on my mint 12

http://pkgs.org/ubuntu-10.04/ubuntu-....deb/download/

now i'm getting this error

yurigaitho@yurigaitho-HP-Compaq-dc7100-SFF-PC923A /usr/local/src $ sudo apt-get install build-essential libiaxclient-dev sox lame ruby ruby-dev rake rubygems libopenssl-ruby libreadline-ruby libsqlite3-ruby gnuplot
[sudo] password for yurigaitho:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libruby' instead of 'libopenssl-ruby'
Note, selecting 'libruby' instead of 'libreadline-ruby'
build-essential is already the newest version.
libiaxclient-dev is already the newest version.
The following extra packages will be installed:
gnuplot-nox gnuplot-x11 groff libnetpbm10 libreadline5 libruby1.8
libsox-fmt-alsa libsox-fmt-base libsox1b libsqlite3-ruby1.8 libwxbase2.8-0
libwxgtk2.8-0 netpbm psutils ruby1.8 ruby1.8-dev
Suggested packages:
gnuplot-doc libsox-fmt-all libgnomeprintui2.2-0 ri ruby1.8-examples ri1.8
The following NEW packages will be installed:
gnuplot gnuplot-nox gnuplot-x11 groff lame libnetpbm10 libreadline5 libruby
libruby1.8 libsox-fmt-alsa libsox-fmt-base libsox1b libsqlite3-ruby
libsqlite3-ruby1.8 libwxbase2.8-0 libwxgtk2.8-0 netpbm psutils rake ruby
ruby-dev ruby1.8 ruby1.8-dev rubygems sox
0 upgraded, 25 newly installed, 0 to remove and 291 not upgraded.
Need to get 14.1 MB of archives.
After this operation, 47.5 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com/ubuntu/ oneiric/universe gnuplot-nox i386 4.4.3-0ubuntu2 [948 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ oneiric/universe libwxbase2.8-0 i386 2.8.11.0-0ubuntu10 [594 kB]
Get:3 http://archive.ubuntu.com/ubuntu/ oneiric/universe libwxgtk2.8-0 i386 2.8.11.0-0ubuntu10 [3,249 kB]
Get:4 http://archive.ubuntu.com/ubuntu/ oneiric/universe gnuplot-x11 i386 4.4.3-0ubuntu2 [647 kB]
Get:5 http://archive.ubuntu.com/ubuntu/ oneiric/universe gnuplot all 4.4.3-0ubuntu2 [1,068 B]
Get:6 http://archive.ubuntu.com/ubuntu/ oneiric/main groff i386 1.21-6 [3,556 kB]
Err http://archive.ubuntu.com/ubuntu/ oneiric/universe lame i386 3.98.4-0ubuntu1
502 Bad Gateway [IP: 91.189.92.202 80]
Get:7 http://archive.ubuntu.com/ubuntu/ oneiric/main libnetpbm10 i386 2:10.0-12.2 [67.4 kB]
Get:8 http://archive.ubuntu.com/ubuntu/ oneiric/main libreadline5 i386 5.2-9ubuntu1 [123 kB]
Get:9 http://archive.ubuntu.com/ubuntu/ oneiric-updates/main libruby1.8 i386 1.8.7.352-2ubuntu0.2 [1,787 kB]
Get:10 http://archive.ubuntu.com/ubuntu/ oneiric/main libruby all 4.8 [4,766 B]
Get:11 http://archive.ubuntu.com/ubuntu/ oneiric/universe libsox1b i386 14.3.2-1ubuntu1 [260 kB]
Get:12 http://archive.ubuntu.com/ubuntu/ oneiric/universe libsox-fmt-alsa i386 14.3.2-1ubuntu1 [7,560 B]
Get:13 http://archive.ubuntu.com/ubuntu/ oneiric/universe libsox-fmt-base i386 14.3.2-1ubuntu1 [29.2 kB]
Get:14 http://archive.ubuntu.com/ubuntu/ oneiric/universe libsqlite3-ruby1.8 i386 1.3.3-1 [35.8 kB]
Get:15 http://archive.ubuntu.com/ubuntu/ oneiric/universe libsqlite3-ruby all 1.3.3-1 [3,432 B]
Get:16 http://archive.ubuntu.com/ubuntu/ oneiric/main netpbm i386 2:10.0-12.2 [1,213 kB]
Get:17 http://archive.ubuntu.com/ubuntu/ oneiric/main psutils i386 1.17-29 [93.1 kB]
Get:18 http://archive.ubuntu.com/ubuntu/ oneiric-updates/main ruby1.8 i386 1.8.7.352-2ubuntu0.2 [35.9 kB]
Get:19 http://archive.ubuntu.com/ubuntu/ oneiric/main ruby all 4.8 [5,054 B]
Get:20 http://archive.ubuntu.com/ubuntu/ oneiric/universe rake all 0.8.7-2ubuntu1 [136 kB]
Get:21 http://archive.ubuntu.com/ubuntu/ oneiric-updates/main ruby1.8-dev i386 1.8.7.352-2ubuntu0.2 [626 kB]
Get:22 http://archive.ubuntu.com/ubuntu/ oneiric/main ruby-dev all 4.8 [4,572 B]
Get:23 http://archive.ubuntu.com/ubuntu/ oneiric/universe rubygems all 1.7.2-1 [425 kB]
Get:24 http://archive.ubuntu.com/ubuntu/ oneiric/universe sox i386 14.3.2-1ubuntu1 [94.6 kB]
Fetched 13.9 MB in 1min 51s (125 kB/s)
Failed to fetch http://archive.ubuntu.com/ubuntu/poo...untu1_i386.deb 502 Bad Gateway [IP: 91.189.92.202 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


kindly help me on how i can finalize installing warvox successfully as per their installation instructions http://warvox.org/install.html

thanks in advance

Last edited by yurigaitho; 11-01-2012 at 10:30 AM.
 
Old 11-01-2012, 10:34 AM   #19
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,698

Rep: Reputation: 3291Reputation: 3291Reputation: 3291Reputation: 3291Reputation: 3291Reputation: 3291Reputation: 3291Reputation: 3291Reputation: 3291Reputation: 3291Reputation: 3291
Quote:
how can I find the package "libiaxclient-dev"so that I can compile it
Your link, post # 18, and then one page back ...
http://packages.ubuntu.com/lucid/libiaxclient1
> http://archive.ubuntu.com/ubuntu/poo....2.orig.tar.gz
>> iaxclient_2.0.2.orig.tar.gz
.... And the patch :
http://archive.ubuntu.com/ubuntu/poo...build1.diff.gz
>> iaxclient_2.0.2-3build1.diff.gz

.
 
1 members found this post helpful.
Old 11-02-2012, 10:05 AM   #20
yurigaitho
LQ Newbie
 
Registered: Oct 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
I think i'm almost done installing warvox on my system after i got this confirmation message..

" *
* WarVOX Installation Verifier *
* *
**********************************************************************
[*] The KissFFT module appears to be available[*] The SOX binary appears to be available with RAW file support[*] The GNUPlot binary appears to be available[*] The LAME binary appears to be available[*] The IAXRECORD binary appears to be available
[*] Congratulations! You are now ready to run WarVOX[*] Start WarVOX with bin/warvox.rb

however i'm still not able to access warvox because the start command "bin/warvox"
gives the below results




"
yurigaitho@yurigaitho-HP-Compaq-dc7100-SFF-PC923A /usr/local/src/warvox-1.0.1 $ bin/warvox.rb
[*] Starting WarVOX on http://127.0.0.1:7777/

=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails 2.2.2 application starting on http://127.0.0.1:7777
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
/usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load_without_new_constant_marking': no such file to load -- mongrel_rails (MissingSourceFile)
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/railties/lib/commands/servers/mongrel.rb:64
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:153:in `require'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:153:in `require'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/railties/lib/commands/server.rb:49
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from ./script/server:3
from bin/warvox.rb:72:in `load'
from bin/warvox.rb:72
yurigaitho@yurigaitho-HP-Compaq-dc7100-SFF-PC923A /usr/local/src/warvox-1.0.1 $


google instruction are that i Change the username and password in /warvox-1.0.1/etc/warvox.conf and if all goes well i can launch it with

/bin/warvox.rb --address yourIPaddress --port 7777

but i really dont have any idea how to do this..

thanks in advance
 
Old 11-06-2012, 06:53 AM   #21
yurigaitho
LQ Newbie
 
Registered: Oct 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
Please some one help me with this last step..i have manged to successfully insatll warvox on my system and i got this congrats message




**********************************************************************
* *
* WarVOX Installation Verifier *
* *
**********************************************************************
[*] The KissFFT module appears to be available[*] The SOX binary appears to be available with RAW file support[*] The GNUPlot binary appears to be available[*] The LAME binary appears to be available[*] The IAXRECORD binary appears to be available
[*] Congratulations! You are now ready to run WarVOX[*] Start WarVOX with bin/warvox.rb


however as the instructions say i should start warvox web interface with "bin/warvox.rb" Once the web interface is started, it can be accessed from your browser at the URL http://127.0.0.1:7777/. Enter the username and password from the previous step to login. but when i type "bin/warvox.rb" in the same terminal i get this


yurigaitho@yurigaitho-HP-Compaq-dc7100-SFF-PC923A /usr/local/src/warvox-1.0.1 $ bin/warvox.rb
[*] Starting WarVOX on http://127.0.0.1:7777/

=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails 2.2.2 application starting on http://127.0.0.1:7777
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
/usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load_without_new_constant_marking': no such file to load -- mongrel_rails (MissingSourceFile)
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/railties/lib/commands/servers/mongrel.rb:64
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:153:in `require'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/activesupport/lib/active_support/dependencies.rb:153:in `require'
from /usr/local/src/warvox-1.0.1/web/vendor/rails/railties/lib/commands/server.rb:49
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from ./script/server:3
from bin/warvox.rb:72:in `load'
from bin/warvox.rb:72

kindly help me on the correct method,
Thanks in advance
 
Old 11-22-2012, 08:11 AM   #22
yurigaitho
LQ Newbie
 
Registered: Oct 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
Hi
on following warvox installation instructions here http://warvox.org/install.html
i was able to finally install warvox with some sucess..
i installed with ubuntu 10.04 with the following criteria


tar zxvf warvox-1.0.1.tar.gz

sudo apt-get install build-essential libiaxclient-dev sox lame ruby ruby-dev rake rubygems libopenssl-ruby libreadline-ruby libsqlite3-ruby gnuplot

gem install mongrel

cd warvox-1.0.1/ && make



However on issuing the command -

"gem install mongrel"

I'm getting some error warnings as below

yurigaitho@yurigaitho-desktop:~/Desktop$ gem install mongrel
WARNING: Installing to ~/.gem since /var/lib/gems/1.8 and
/var/lib/gems/1.8/bin aren't both writable.
WARNING: You don't have /home/yurigaitho/.gem/ruby/1.8/bin in your PATH,
gem executables will not run.
Building native extensions. This could take a while...
Successfully installed mongrel-1.1.5
1 gem installed
Installing ri documentation for mongrel-1.1.5...
Installing RDoc documentation for mongrel-1.1.5...
yurigaitho@yurigaitho-desktop:~/Desktop$


what can i do to issue make redeem this error and get warvox running successfully

Thanks in advance
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install .tar.bz and src.rpms and tar.gz files gadekishore Linux - Software 1 10-12-2005 08:09 PM
how do i install .tar files? squirlprotector Linux - Software 16 02-17-2005 06:04 PM
How do you install .tar.gz files? Lechium Slackware 7 09-20-2004 12:04 AM
How do you install tar/gz files, and rpm files? Fear58 Linux - Software 6 02-14-2004 04:35 PM
cant install .bin files, tar.gz files or anyother format!!! madskillz Linux - Newbie 4 10-05-2003 10:28 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration