Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 10-30-2009, 08:36 PM   #1
Registered: Mar 2006
Posts: 170

Rep: Reputation: 15
How can I force my system to boot to a plain terminal?

My ubuntu installation failed, and I think I might be able to fix it if I could get to a terminal. I just need to be able to make the system use the most basic video driver so that I can at least see a terminal. Is there something I can add to the grub menu that will boot it in stone-age mode?

I used a fresh alternate, amd64 disk ran it and the installer worked, for certain values of 'worked'. It installed and now on the grub menu i can see my old system and boot it just fine. That's what I'm on right now. But the new system that I actually just installed is broken. It boots, but when it is supposed to switch to the login screen, everything completely breaks and the monitor is like a color test pattern of noise, and my monitor says "out of range". Nothing is visible. Clearly, the graphics are broken. I can switch to a terminal with ctrl+alt+F2, but that is a monochrome test pattern of noise, and I can't see anything.

Although my keyboard is not labeled, luckily, I can touch type, and entering my username+enter, then password+enter, then "sudo reboot"+enter, then my password, will reboot the system. So it's running, I just can't see anything.

I have no idea what to do; re-reinstalling is going to do the same thing. When I installed, I did NOT have tubes because I only have a wireless card. I figure there is a chance that if I plug my box in with a network cable, boot to an invisible terminal, and run "sudo apt-get update && sudo apt-get upgrade && sudo reboot", without making a keystroke error, that it will be fixed. But if I could see a terminal, at least I could run

 dpkg --reconfigure xserver-xorg
or something? Is that the right command? and tell it to use the nv free driver or whatever.

Or any other suggestions? How can I make my system boot, but not run X and maybe just give me a terminal that I can see?
Old 10-30-2009, 08:42 PM   #2
Senior Member
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
You can boot up Ubuntu into single-user mode, which will ensure that you don't have any GUI working:
Old 10-30-2009, 08:46 PM   #3
Registered: Oct 2009
Location: England
Distribution: Kubuntu, Ubuntu, Debian, Proxmox.
Posts: 553

Rep: Reputation: 115Reputation: 115
Is there not a 'failsafe' option in the grub menu?

If not, in grub, get into the mode to edit commands. Find the long line that starts 'kernel'. At the end, delete 'quiet' and 'splash' if they're there, and add 'single'. That should do the trick.
Old 10-30-2009, 08:49 PM   #4
LQ Guru
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 132Reputation: 132
Have you tried the "fix broken system" entry from the livecd?

Last edited by jay73; 10-30-2009 at 08:50 PM.
Old 10-30-2009, 10:57 PM   #5
Registered: Mar 2006
Posts: 170

Original Poster
Rep: Reputation: 15
Yes I've tried the fix broken system.

I'll try the grub thing maybe.

This jaunty install is working just as well as it has for months, so it's a bit puzzling, but I'm confident if I could at least get the ability to enter commands I could fix it.
Old 10-30-2009, 11:02 PM   #6
Registered: Jan 2008
Location: Cleveland Ohio
Distribution: Current CentOS 5.6
Posts: 117

Rep: Reputation: 20
you want run level 3 or 4 can't remember. If network is not needed then run level 1 should work. check for an option in the boot menu if you get one.
Old 10-30-2009, 11:58 PM   #7
Registered: Mar 2006
Posts: 170

Original Poster
Rep: Reputation: 15
Thanks! I added the "single" to the end of my grub kernel entry and I was able to get a terminal that I could actually see. Running startx still resulted in broken graphics, and on the newer ubuntu releases, there is no xorg.conf to delete anymore, it's just not there. So what I did was apt-cache search nvidia, and I came up with a program called envyng, that builds and installs the latest nvidia driver. I ran that and rebooted and nephew as a kittens!
Old 10-31-2009, 12:59 AM   #8
Wim Sturkenboom
Senior Member
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Originally Posted by murankar View Post
you want run level 3 or 4 can't remember. If network is not needed then run level 1 should work. check for an option in the boot menu if you get one.
Ubuntu does not use runlevels for that purpose anymore (I think since 6.06 Dapper Drake).


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you force a terminal to remain open? (Or see what it said before) Chronothread Linux - Newbie 1 11-28-2008 07:56 PM
Way to force a specific value for system uptime? soliax Linux - Kernel 8 09-10-2008 01:18 AM
GRUB just plain won't boot by itself crrazychicken Linux - General 2 04-01-2008 10:48 AM
System Wide Passwd Reset or Force outspoken Linux - Security 10 12-12-2004 08:16 AM
need a dmesg.boot error translated into plain english mipia *BSD 3 09-11-2003 08:20 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:24 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration