LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   How can I force my system to boot to a plain terminal? (https://www.linuxquestions.org/questions/linux-newbie-8/how-can-i-force-my-system-to-boot-to-a-plain-terminal-765682/)

Daravon 10-30-2009 08:36 PM

How can I force my system to boot to a plain terminal?
 
My ubuntu installation failed, and I think I might be able to fix it if I could get to a terminal. I just need to be able to make the system use the most basic video driver so that I can at least see a terminal. Is there something I can add to the grub menu that will boot it in stone-age mode?

I used a fresh alternate, amd64 disk ran it and the installer worked, for certain values of 'worked'. It installed and now on the grub menu i can see my old system and boot it just fine. That's what I'm on right now. But the new system that I actually just installed is broken. It boots, but when it is supposed to switch to the login screen, everything completely breaks and the monitor is like a color test pattern of noise, and my monitor says "out of range". Nothing is visible. Clearly, the graphics are broken. I can switch to a terminal with ctrl+alt+F2, but that is a monochrome test pattern of noise, and I can't see anything.

Although my keyboard is not labeled, luckily, I can touch type, and entering my username+enter, then password+enter, then "sudo reboot"+enter, then my password, will reboot the system. So it's running, I just can't see anything.

I have no idea what to do; re-reinstalling is going to do the same thing. When I installed, I did NOT have tubes because I only have a wireless card. I figure there is a chance that if I plug my box in with a network cable, boot to an invisible terminal, and run "sudo apt-get update && sudo apt-get upgrade && sudo reboot", without making a keystroke error, that it will be fixed. But if I could see a terminal, at least I could run

Code:

dpkg --reconfigure xserver-xorg
or something? Is that the right command? and tell it to use the nv free driver or whatever.

Or any other suggestions? How can I make my system boot, but not run X and maybe just give me a terminal that I can see?

rjlee 10-30-2009 08:42 PM

You can boot up Ubuntu into single-user mode, which will ensure that you don't have any GUI working:

http://www.cyberciti.biz/faq/grub-bo...mode/#comments

cantab 10-30-2009 08:46 PM

Is there not a 'failsafe' option in the grub menu?

If not, in grub, get into the mode to edit commands. Find the long line that starts 'kernel'. At the end, delete 'quiet' and 'splash' if they're there, and add 'single'. That should do the trick.

jay73 10-30-2009 08:49 PM

Have you tried the "fix broken system" entry from the livecd?

Daravon 10-30-2009 10:57 PM

Yes I've tried the fix broken system.


I'll try the grub thing maybe.


This jaunty install is working just as well as it has for months, so it's a bit puzzling, but I'm confident if I could at least get the ability to enter commands I could fix it.

murankar 10-30-2009 11:02 PM

you want run level 3 or 4 can't remember. If network is not needed then run level 1 should work. check for an option in the boot menu if you get one.

Daravon 10-30-2009 11:58 PM

Thanks! I added the "single" to the end of my grub kernel entry and I was able to get a terminal that I could actually see. Running startx still resulted in broken graphics, and on the newer ubuntu releases, there is no xorg.conf to delete anymore, it's just not there. So what I did was apt-cache search nvidia, and I came up with a program called envyng, that builds and installs the latest nvidia driver. I ran that and rebooted and nephew as a kittens!

Wim Sturkenboom 10-31-2009 12:59 AM

Quote:

Originally Posted by murankar (Post 3738705)
you want run level 3 or 4 can't remember. If network is not needed then run level 1 should work. check for an option in the boot menu if you get one.

Ubuntu does not use runlevels for that purpose anymore (I think since 6.06 Dapper Drake).


All times are GMT -5. The time now is 11:06 PM.