LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-06-2014, 09:38 AM   #16
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.4 + 50+ other Linux OS, for test only.
Posts: 16,755

Rep: Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329

# 15 .

GPRS is already present in ns-2.2x - ns-2.3x .
Post #20 http://www.linuxquestions.org/questi...125/page2.html
( #20 ... #22 ).

-
 
Old 02-06-2014, 08:00 PM   #17
muthana
Member
 
Registered: Oct 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
sir knudfl
please con you sent to me the steps for (How to install ns-2.33 in ubuntu 12.04
thank you
 
Old 02-07-2014, 02:13 AM   #18
muthana
Member
 
Registered: Oct 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
hi can any one help me to solve this problem
iraq@iraq:~$ cd ns-allinone-2.33/
iraq@iraq:~/ns-allinone-2.33$ sudo apt-get install gcc-4.4 g++-4.4
[sudo] password for iraq:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package gcc-4.4 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'gcc-4.4' has no installation candidate
E: Unable to locate package g++-4.4
E: Couldn't find any package by regex 'g++-4.4'
iraq@iraq:~/ns-allinone-2.33$ sudo apt-get install libxt-dev libx11-dev libxmu-dev xorg-dev xgraph
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libxt-dev
E: Unable to locate package libx11-dev
E: Unable to locate package libxmu-dev
E: Unable to locate package xorg-dev
E: Unable to locate package xgraph
iraq@iraq:~/ns-allinone-2.33$
thanx
 
Old 02-07-2014, 08:33 AM   #19
muthana
Member
 
Registered: Oct 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
Hi every body
con any one help me to solve this problem please
configure: error: C compiler cannot create executables
See `config.log' for more details
tcl8.4.18 configuration failed! Exiting ...
Tcl is not part of the ns project. Please see www.Scriptics.com
to see if they have a fix for your platform.
iraq@iraq:~/ns-allinone-2.33/ns-allinone-2.33$ ^C

thanx for help
 
Old 02-07-2014, 01:48 PM   #20
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.4 + 50+ other Linux OS, for test only.
Posts: 16,755

Rep: Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329
# 19 .

The prerequisites for ns2 are :
$ sudo apt-get install libxmu-dev xgraph g++ autoconf automake libtool patch


Quote:
E: Unable to locate package libxmu-dev
? No internet connection ?
? Or you have a non valid file /etc/apt/sources.list ?

# 17 : How to install ns-2.33 in ubuntu 12.04 :
Install the gcc41/g++41 compilers for the 32bits (i686) Ubuntu 12.04 :
Post # 18 here ..
http://www.linuxquestions.org/questi...022/page2.html

The ns2 build: $ cd ns-allinone-2.33/ && export CC=gcc41 CXX=g++41 && ./install

-
 
Old 02-07-2014, 01:56 PM   #21
muthana
Member
 
Registered: Oct 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
Dear sir
please can you sent to example for GPSR and the steps for implementation this example in ns2.33

best wishes
 
Old 02-07-2014, 02:20 PM   #22
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.4 + 50+ other Linux OS, for test only.
Posts: 16,755

Rep: Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329
# 21 .

No. You cannot "implement" something that is already present in ns-2.33.
But you can run the suggested commands. See post #16, and follow the link.

EDIT : Sorry, now it seems to be GPSR, not GPRS !


-

Last edited by knudfl; 02-08-2014 at 03:29 PM.
 
Old 02-08-2014, 12:26 PM   #23
muthana
Member
 
Registered: Oct 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
Dear sir
I tried to install Ns-2.33 and it was successfully installed but I would like to install GPSR into it.

I tried to run the example hls.tcl and i got below problem:

invalid command name "Agent/GPSR"
while executing
"Agent/GPSR set bdesync_ 0.5 "
(file "gpsr.tcl" line 6)


Does that mean GPSR is not installed yet?
 
Old 02-08-2014, 03:41 PM   #24
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.4 + 50+ other Linux OS, for test only.
Posts: 16,755

Rep: Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329
# 23 .

OK, I was still answering your original question about GPRS.
"GPSR" is something else.
Please read 1) gpsr http://www.linuxquestions.org/questions/tags/gpsr/
2) gpsr-hls http://www.linuxquestions.org/questions/tags/gpsr-hls/
3) gpsr-KeLiu http://www.linuxquestions.org/questi...gs/gpsr-keliu/

Building GPSR-hls, example post #23 here
http://www.linuxquestions.org/questi...526/page2.html
... And post #69 for the gpsr-hls package.

.
 
Old 02-09-2014, 04:59 AM   #25
muthana
Member
 
Registered: Oct 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
Dear sir
I tried to install Ns-2.33 and it was successfully installed but I would like to install GPSR into it.

I tried to run the example hls.tcl and i got below problem:

invalid command name "Agent/GPSR"
while executing
"Agent/GPSR set bint_"
invoked from within
"expr 3*([Agent/GPSR set bint_]+[Agent/GPSR set bdesync_]*[Agent/GPSR set bint_])"
invoked from within
"Agent/GPSR set bexp_ [expr 3*([Agent/GPSR set bint_]+[Agent/GPSR set bdesync_]*[Agent/GPSR set bint_])] "
(file "hls.tcl" line 7)


Does that mean GPSR is not installed yet?
 
Old 02-09-2014, 05:09 AM   #26
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.4 + 50+ other Linux OS, for test only.
Posts: 16,755

Rep: Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329
# 25 .
Quote:
Does that mean GPSR is not installed yet ?
Either you did not build any GPSR-hls !

Or you are using the wrong executable 'ns'.
The safe thing to do when a new `ns' has been built : Rename it.
And take care that ns2 added *PATH text in .bashrc gets deleted.
Nothing is to be added to .bashrc !

! Make sure that you read all posts linked in post # 24 !

-
 
Old 02-09-2014, 11:31 PM   #27
muthana
Member
 
Registered: Oct 2013
Posts: 61

Original Poster
Rep: Reputation: Disabled
Unhappy GPSR

dear sir
I have this problem please need your help and your explan to solve it
thanks

muthana@muthana:~$ sudo dpkg -i gcc41-compat-4.1.2.ubu1204_i386.deb g++41-compat-4.1.2_i386.deb
[sudo] password for muthana:
(Reading database ... 148187 files and directories currently installed.)
Preparing to replace gcc41-compat 4.1.2.ubu1204 (using gcc41-compat-4.1.2.ubu1204_i386.deb) ...
Unpacking replacement gcc41-compat ...
Preparing to replace g++41-compat 4.1.2 (using g++41-compat-4.1.2_i386.deb) ...
Unpacking replacement g++41-compat ...
Setting up gcc41-compat (4.1.2.ubu1204) ...
Setting up g++41-compat (4.1.2) ...
muthana@muthana:~$ cd ns-allinone-2.33/
muthana@muthana:~/ns-allinone-2.33$ export CC=gcc41 CXX=g++41
muthana@muthana:~/ns-allinone-2.33$ ./install
bash: ./install: No such file or directory
 
Old 02-10-2014, 08:20 AM   #28
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.4 + 50+ other Linux OS, for test only.
Posts: 16,755

Rep: Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329Reputation: 3329
# 27 .
Quote:
bash: ./install: No such file or directory
Your location is wrong.
Or the file 'install' is missing.
( Or maybe you unpacked ns-allinone with sudo, and have no access to files.)

If any doubt, the first command is always $ pwd
... to decide your location.

-
 
  


Reply

Tags
gprs, gpsr, maodv, multicast, ns2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Patch CBRP -Cluster based Routing Protocol for Manet (NS-2.33) vuichoigiaitri Linux - Wireless Networking 4 10-08-2015 06:41 AM
[ASK] About MANET (adhoc routing protocol) kucrut69 Linux - Networking 13 06-06-2013 03:36 PM
Patch Hybrid Routing Protocol in Manet vuichoigiaitri Linux - Wireless Networking 0 12-10-2012 04:44 PM
Energy Efficient Routing Protocol implementation in NS2 engrasafkhan Linux - Newbie 1 07-20-2012 09:41 AM
ns-2 simulator implementing a manet routing protocol myrto Programming 1 07-09-2007 04:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration