LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-16-2003, 03:16 PM   #1
r0dr0ddy
LQ Newbie
 
Registered: Mar 2003
Posts: 12

Rep: Reputation: 0
how can I disable the auto screen blanking?


Hi everyone;

I am one of thousands who have installed the nVidia drivers for my graphics card. It's no surprise that the nVidia drivers have problems with the screen saver/auto monitor shutoff.
I've searched high and low all over the web (and this forum!) to find out how the heck I can turn off the screen blanking. In other words, I want my monitor to remain on permanently so it won't freeze up.

So far I've done the following:

I've unchecked the screen saver under the desktop properties along with the "blank after x minutes" box. This didn't stop the screen from turning off.

I've disabled the advanced power management under my system's BIOS. This didn't stop the screen from turning off.

I've disabled the APM under KDE's processes setup. This didn't stop the screen from turning off.

What else can cause the screen to turn off after a few minutes and how can I disable it?

Thanks!
Mark
 
Old 04-16-2003, 03:29 PM   #2
rockdw
Member
 
Registered: Nov 2002
Location: Chicago, IL
Distribution: Rasbian, Debian, Gentoo, RHEL
Posts: 63

Rep: Reputation: 15
comment out the dpms option in your /etc/X11/XF86Config file under the Monitor section. That may disable X's ability to interface with the power management.

e.g.

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Generic Monitor, 1280x1024 @ 60 Hz"
DisplaySize 308 230
HorizSync 31.5 - 64.3
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection
 
Old 04-16-2003, 05:00 PM   #3
lectraplayer
Member
 
Registered: Mar 2003
Location: a little west of Birmingham, AL, USA.
Distribution: Porteus 3.1
Posts: 932

Rep: Reputation: 32
I've had limited success (with Mandrake) to go KDE Control Center, Power Management (way at the bottom somewhere) and turn everything under there to "DISABLED". That works only for KDE, though. I would like to know how to disable screen blanking under Konsole. Any Ideas?
 
Old 04-16-2003, 06:42 PM   #4
andy18
Member
 
Registered: Oct 2002
Location: Malaysia
Posts: 106

Rep: Reputation: 15
Quote:
comment out the dpms option in your /etc/X11/XF86Config file under the Monitor section. That may disable X's ability to interface with the power management.
Hi,

Tried that..but the monitor just went blank screen after 10 minutes.Any workaround on this?



Andy
 
Old 04-16-2003, 08:01 PM   #5
r0dr0ddy
LQ Newbie
 
Registered: Mar 2003
Posts: 12

Original Poster
Rep: Reputation: 0
I tried rockdw's idea with changing the XF86config line. This didn't stop the screen from turning off either.
Who knows how many things could be causing it...
 
Old 01-27-2004, 03:57 PM   #6
utv99
LQ Newbie
 
Registered: Jan 2004
Posts: 3

Rep: Reputation: 0
Stopping KDE from blacking out

KDE is in a way like 'windows' it has screen savers built in to it as does other os systems

what is going on is this by default it is set to blank out in 5mins time ...

to check this just do like you would in windows 'right click' over desktop

you will see 'configure desktop' select it a panel will come up much like windows on the left is icon 'screensaver' click it then 'uncheck' 'enable screensaver and the desktop should stay on all the time from then on

if not you can use 'set term' command


hope this helps
 
Old 01-27-2004, 04:03 PM   #7
lectraplayer
Member
 
Registered: Mar 2003
Location: a little west of Birmingham, AL, USA.
Distribution: Porteus 3.1
Posts: 932

Rep: Reputation: 32
There's also a Monitor Power Saving thing under Power Options (KDE Control Center). Either lenghen the time there to, say, 120 minutes (2 hours) or uncheck Enable Power Saving (above the sliders). That should fix it.

You know something? This is an old thread that I didn't have any luck with. From the konsole, you can also execute this:

setterm -blank 0

That will take care of the konsole. I found that out in another thread.
To make it permanent, go in as root and put that command at the end of your /etc/profile as I showed it here.

Last edited by lectraplayer; 01-27-2004 at 04:08 PM.
 
Old 01-30-2004, 05:04 PM   #8
utv99
LQ Newbie
 
Registered: Jan 2004
Posts: 3

Rep: Reputation: 0
kde blanking

yes it is old ... i noticed it when looking for answer to the very same problem ... took me maybe 3 mins to find it

the set term works under gnome ... or has before on older vers of linux
last one i tired it on was linux 6 or 7 if i recall

i wondered why no one answered this from early posts myself ... not like it was magic
 
Old 01-30-2004, 09:59 PM   #9
lectraplayer
Member
 
Registered: Mar 2003
Location: a little west of Birmingham, AL, USA.
Distribution: Porteus 3.1
Posts: 932

Rep: Reputation: 32
I asked the same thing (similar), but they answered it in another thread. I then forgot about this one until I did a search and dug it up. Think nobody knew what r0dr0ddy was wanting?
 
Old 02-03-2004, 02:33 PM   #10
utv99
LQ Newbie
 
Registered: Jan 2004
Posts: 3

Rep: Reputation: 0
blanking

my guess that is correct .. they must not have seen this one
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 01:50 PM
how to disable screen blanking in fedora core 1? ujjwal_mh Linux - Software 3 07-26-2004 12:58 PM
How to disable screen blanking in X? make Linux - General 14 07-15-2004 06:15 PM
rh 9.0 screen blanking corrupter Linux - General 1 06-04-2003 05:16 PM
RH 9.0 screen blanking corrupter Linux - Distributions 0 06-04-2003 10:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration