LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   how can I boot to a fakeRAID -Raid0 set drive from a non-raid hdd (https://www.linuxquestions.org/questions/linux-newbie-8/how-can-i-boot-to-a-fakeraid-raid0-set-drive-from-a-non-raid-hdd-913041/)

todingman 11-11-2011 12:19 PM

[SOLVED]how can I boot to a fakeRAID -Raid0 set drive from a non-raid hdd
 
Hi all,

First of all, my English is bad and I hope I can explain it what my problem is. Secondly, I need your expert help with my problem right now.

I'll just layout some hardware information and some history before I start. Currently, my motherboard has 3 hdd controllers which are:

1) Intel - 6 ports --> contains 2 sets of RAID drives = 2 x 60gb SSD (boot drive) and 2 x 500gb HDD (data drive) both in RAID 0

2) Jmicron - 2 ports --> 1 port is used by the DVDROM

3) Marvell - 2 ports --> I don't use these ports as they are slow and are so bad - currently disabled in BIOS

HISTORY: Before, my 2 x 60gb SSDs (RAID 0) contained Arch 64 + Windows 7 64 with Grub as the main bootloader. I remembered having a hard time setting up intel fakeraid with Arch linux + Win7 dual boot before, but fortunately, with your help, I found the solution and I've been using it ever since until today.

NOW is kind of a different issue. I bought a new 60gb SSD (just one). I totally reformatted everything with my 2 x 60gb SSD Raid 0 and I decided to just use that exclusively for windows, still in RAID 0. My brand new SSD will ONLY have Arch64 on it. So I installed Windows 7 first on my Raid SSD set. I plugged my new SSD to the Jmicron port so I can take advantage of AHCI. I don't want to mix my new SSD to the Intel Controllers since its not RAID anyway. Anyway, I installed Arch 64 on the new SSD in the JMicron Port fine.

Now here comes the problem, I set the Jmicron port where the Arch is installed to be the primary boot in the BIOS (since GRUB is there) and I can't boot to Windows! It gives me an error that It can't find the target drive (Win7 in the Raid 0 - intel ports). I've tried modifying the menu.lst and trying so many combinations and It still fails. Of course, I can boot to Arch fine since the drive is independent. It looks like grub legacy can't boot to fakeRaid drives if its not installed on that same drive.

Can you give me advice on how to fix this issue?

Also, I was just thinking, is there a 3rd party Windows Bootloader, that can be installed in Raid 0, that can pick up Linux and boot from it. I was thinking of just making the Windows 7 as primary boot in BIOS, with a 3rd party bootloader, then just boot to Arch.

Thank you!

syg00 11-11-2011 05:56 PM

From the grub boot menu drop into command mode and enter (no quotes) "root (hd" and hit the <Tab> key.
You will get a list of available drives that the BIOS presents as boot drives to grub. May be enumerated differently than you think.

The standard Win7 loader can chainload grub.Install grub to the partition boot record (as well as the MBR - doesn't matter), and go get EasyBCD (free) to manage the boot menu in Win7.
Easy.

todingman 11-23-2011 10:58 AM

Awesome, it worked!

Thanks


All times are GMT -5. The time now is 07:38 PM.