LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-03-2015, 03:06 AM   #1
Steve175
LQ Newbie
 
Registered: Oct 2014
Posts: 2

Rep: Reputation: Disabled
How best to remount external drive with permissions to access it?


I am user/group 999 (Mint Cinnamon, but that shouldn't matter). I plug in my USB drive (ext4) which is assigned to user 1000, and of course get "You do not have the permissions necessary to view the contents of ..." What is the proper procedure for (temporarily) owning this drive?

Open a terminal and "sudo mount -o remount gid=999,uid=999 /dev/sdg1" or something like that??? I want to be able to write files to the drive and have them be user 1000, like all other files on the drive. (So that when it's mounted by user 1000, there isn't an access problem.)

Or do I have to create a user 1000 and login under it?

[Of course what I REALLY want under Linux is: when I plug in a USB (etc.) drive, a dialog pops up and asks me if I want to mount it, and if so, RW or RO, and whether to run file manager. It would mount it to my user #, but write files under the drives user #. I can dream...]

Thank you for your advice.
 
Old 01-03-2015, 03:31 AM   #2
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Better you create user: 1000 and group: 1000

add your user to 1000 group id.

Or you can remount them as root. For more info see man page of mount command.

Code:
man mount
 
Old 01-03-2015, 01:39 PM   #3
jefro
Moderator
 
Registered: Mar 2008
Posts: 17,101

Rep: Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551
Might be a few things going on. User 1000 ought to be the first normal user created on system. Are you that person? As to why you are 999 I can't say.

When you unplug the usb and then plug it back in, does it automount like it should to your user ?
 
Old 01-03-2015, 05:05 PM   #4
Habitual
LQ 5k Club
 
Registered: Jan 2011
Location: Nowhere near you, thank God.
Distribution: OSX Sierra
Posts: 8,573
Blog Entries: 14

Rep: Reputation: Disabled
http://forum.linuxmint.com/viewtopic.php?f=49&t=183506
 
Old 01-04-2015, 11:58 AM   #5
Steve175
LQ Newbie
 
Registered: Oct 2014
Posts: 2

Original Poster
Rep: Reputation: Disabled
None of these really worked. I did make a list of about 20 steps which sort-of work (run terminal, sudo su, adduser, add user to sudoers, exit, logoff, login new user, back to terminal, change mount point from /media/mint/ to current group, etc...)

I believe the fundamental problem is that the ext filesystem keeps track of owners/users. This is a very bad idea for filesystems. If I just used FAT, I believe this would avoid all problems. FAT is too limited, however.

The short answer solution is: Run terminal, then "gksudo nemo". Fix the file user/group numbers when you come to that problem.
 
Old 01-04-2015, 12:11 PM   #6
Habitual
LQ 5k Club
 
Registered: Jan 2011
Location: Nowhere near you, thank God.
Distribution: OSX Sierra
Posts: 8,573
Blog Entries: 14

Rep: Reputation: Disabled
Quote:
Originally Posted by Steve175 View Post
I am user/group 999
How did you come to this conclusion?
 
Old 01-04-2015, 12:32 PM   #7
JeremyBoden
Senior Member
 
Registered: Nov 2011
Distribution: Debian
Posts: 1,181

Rep: Reputation: 243Reputation: 243Reputation: 243
Do you have a user with an id of 1000?

You could try using that - if you don't have one, you could consider creating one.
It is fairly quick to change ownership of all 999:999 files to 1000:1000
 
Old 01-04-2015, 01:14 PM   #8
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,218

Rep: Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517
if you use a fat file system for things like a /home partition
the os should stop it from booting
( for security reasons)


and WHY a 999 uuid
debian systems START!!!! at 1000 and GO UP!!!!
1001
1002
1003
1004
1005

Redhat uses 500 ( ROOT!!! )
and 501 for the first NON root user
then 502 ,503

they do NOT GO DOWN
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] permissions on external hard drive. poly_s Linux - Newbie 2 11-09-2011 05:02 PM
Will an external usb hard drive remount on wake from sleep? mturob Linux - Newbie 14 07-05-2011 10:10 PM
Permissions for external drive kameshkar Linux - Software 1 03-31-2010 09:47 AM
Having to remount an external drive every day Zeno McDohl Linux - Hardware 10 09-01-2009 02:00 PM
External USB hard drive unmounts, can't remount or figure out what's causing it adanedhel728 Ubuntu 7 04-21-2008 02:26 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration