Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-05-2013, 12:15 PM   #1
LQ Newbie
Registered: Mar 2013
Posts: 2

Rep: Reputation: Disabled
how and where to add Xvfb display

i have centos 6.3 with asterisk 1.8 with freepbx
and siptosis runing with single channel
and now i am following this link
i have downloaded ststrunkbuilder and followed the included readme.txt
where it says

Before you begin, make a working SipToSis configuration that will be used as a base.
Thorougly test it. If you are planning on using snd-dummy - test it on this test channel.

To generate skype trunk configurations do the following:

New Install:
chmod +x trunkConfig_linux
Accept license
Sample configuration files are copied.
Not recommended. Put in a new folder.

Edit stsTrunkPbxSipBase.cfg for your custom PBX settings
Edit stsTrunkPbxExtBase.cfg for your custom PBX settings

Scripts should work as is on Centos 5.2/5.3 and Ubuntu9.04
You probably will need to add Display lines for each channel to /etc/dbus-1/system.d/xorg-server.conf
Channel 1 starts at display 101

You can edit the scripts for any additional things you need

Edit stsTrunkDef.cfg and set your parameters for the generation

Sound Device:
With Sound hardware:
Look at the supplied sndShare_ALSA file for instructions.
No Sound hardware:
On a system without a sound card, you are forced to use the Alsa snd-dummy module.
There have been many issues with this solution. You may or may not be successful.
Hopefully you already tested snd-dummy with your test channel.

XServer Setup:
Xvfb: (preferred)
This is the default setup.
rpm (or apt-get) install Xvfb if you don't have it already
The default setup sets the X Authorization to locahost

where it says > You probably will need to add Display lines for each channel to /etc/dbus-1/system.d/xorg-server.conf
Channel 1 starts at display 101
< i am unable to add this lines and dontknow how and where to add these lines . please helpme
Old 03-14-2013, 11:32 AM   #2
LQ Newbie
Registered: Mar 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
problem has been solved
i have edited script ./ststTrunk_Control

where the origenal line is
Xvfb ${DISPLAY} -render -auth XauthXvfb 1> log/xvfb_${channum}.log 2>&1 &

and replaced with this
Xvfb ${DISPLAY} 1> log/xvfb_${channum}.log 2>&1 &

and now it is working without the need of add display lines in /etc/dbus-1/system.d/xorg-server.conf
and [B T W ] i can not find this file


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
XVFB brownie_cookie Linux - Newbie 3 04-15-2011 09:38 AM
Pidgin how to add display picture. knockout_artist Linux - Newbie 9 03-19-2009 01:04 PM
Xvfb question ndo Linux - General 1 05-18-2007 11:49 AM
Xvfb and gnome dogalmity Linux - General 0 07-26-2006 11:23 AM
xvfb issues asyoung Linux - General 0 07-14-2003 12:49 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:35 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration