LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-18-2010, 10:42 PM   #1
ababil151
LQ Newbie
 
Registered: May 2010
Posts: 18

Rep: Reputation: 0
Smile Honeyd installation problem


Hay guys,,
i have a proble when installing honeyd-1.5c software on open suse.I have installed libdnet,libpcap,libevent and libedit but i getting this error when try to execute "make" command.

make all-recursive
make[1]: Entering directory `/root/honeyd-1.5c'
Making all in .
make[2]: Entering directory `/root/honeyd-1.5c'
gcc -DHAVE_CONFIG_H -I. -I. -I. -I./ -I./compat -I/usr/include/python2.6 -I/usr/
local/libevent/include -I/usr/include/pcap -I/usr/local/libdnet/include -O2
-Wall -g -DPATH_HONEYDINCLUDE="\"/usr/local/honeyd/include/honeyd\"" -DPATH_HONE
YDDATA="\"/usr/local/honeyd/share/honeyd\"" -DPATH_HONEYDLIB="\"/usr/local/honey
d/lib/honeyd\"" -DHONEYD_PLUGINS_DECLARE="" -DHONEYD_PLUGINS="" -DPATH_RRDTOOL="
\"\"" -c honeyd.c
In file included from stats.h:36,
from honeyd.c:98:
./compat/sha1.h:23: warning: ‘__bounded__’ attribute directive ignored
./compat/sha1.h:23: warning: ‘__bounded__’ attribute directive ignored
./compat/sha1.h:26: warning: ‘__bounded__’ attribute directive ignored
./compat/sha1.h:28: warning: ‘__bounded__’ attribute directive ignored
./compat/sha1.h:30: warning: ‘__bounded__’ attribute directive ignored
./compat/sha1.h:32: warning: ‘__bounded__’ attribute directive ignored
./compat/sha1.h:35: warning: ‘__bounded__’ attribute directive ignored
./compat/sha1.h:35: warning: ‘__bounded__’ attribute directive ignored
honeyd.c:106:20: error: Python.h: No such file or directory
In file included from honeyd.c:108:
pydataprocessing.h:39: error: expected specifier-qualifier-list before ‘PyObject ’
pydataprocessing.h:82: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ b efore ‘*’ token
pydataprocessing.h:89: error: expected declaration specifiers or ‘...’ before ‘P yObject’
pydataprocessing.h:91: error: expected ‘)’ before ‘*’ token
make[2]: *** [honeyd.o] Error 1
make[2]: Leaving directory `/root/honeyd-1.5c'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/honeyd-1.5c'
make: *** [all] Error 2

oh ya i execute this command as a root as well.
Really need your help since this for my final year project


thanks a lot
 
Old 05-18-2010, 10:54 PM   #2
LVsFINEST
Member
 
Registered: Aug 2006
Posts: 99

Rep: Reputation: 21
Is Python installed? Does Python.h exist anywhere on your system?
 
Old 05-18-2010, 10:55 PM   #3
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 613Reputation: 613Reputation: 613Reputation: 613Reputation: 613Reputation: 613
Quote:
honeyd.c:106:20: error: Python.h: No such file or directory
Install the Python development packages.
 
Old 05-18-2010, 11:22 PM   #4
ababil151
LQ Newbie
 
Registered: May 2010
Posts: 18

Original Poster
Rep: Reputation: 0
phyton development package is already installed.
Last time iam using Yast software to install..,
is there another way to install phyton package?
 
Old 05-19-2010, 09:49 AM   #5
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 613Reputation: 613Reputation: 613Reputation: 613Reputation: 613Reputation: 613
Quote:
phyton development package is already installed.
You sure? What does this return: rpm -qa | grep -i python
 
Old 05-20-2010, 11:09 PM   #6
ababil151
LQ Newbie
 
Registered: May 2010
Posts: 18

Original Poster
Rep: Reputation: 0
This is the output
python-urlgrabber-3.1.0-178.8
python-2.4-2.4.4-64.1
dbus-1-python-0.83.0-21.31
python-ReportLab-2.1-1.20
python-satsolver-0.13.9-0.1.1
python-tk-2.6.0-6.1
libxml2-python-2.7.1-9.1
python-gtk-2.12.1-63.3
python-sip-4.7.7-1.40
gimp-plugins-python-2.6.2-2.18
zope-python-2.4-2.10.3-18.1
libpython2_6-1_0-2.6.0-2.12
python-2.6.0-2.16
python-xml-2.6.0-2.12
python-cairo-1.6.4-1.35
rpm-python-4.4.2.3-20.1
python-qt4-4.4.3-1.44
python-base-2.6.0-2.12
python-qt-3.17.4-1.138
python-numeric-24.2-195.8
python-gobject2-2.15.4-2.28
libboost_python1_36_0-1.36.0-9.5
python-2.4-xml-2.4.4-64.1

I have installed few rpm files but too many dependencies between the installation file it self,,

Really thanks for u r answers
 
Old 05-20-2010, 11:41 PM   #7
ababil151
LQ Newbie
 
Registered: May 2010
Posts: 18

Original Poster
Rep: Reputation: 0
Smile

Now its working.,,,,,,,,,,,

i can install my honeyd application

Thanks a lot AlocardZero
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
honeyd installation problem samratnikhil Linux - Software 8 02-01-2011 12:58 AM
honeyd problems syrushcw *BSD 3 12-02-2009 10:58 AM
Having Problems with honeyd lucky_dev36 Linux - General 1 07-22-2006 06:03 AM
Installation of HoneyD on Fc3 navinxavier Linux - Software 1 12-01-2004 07:20 PM
Anyone good at honeyd james_cwy Linux - Security 4 11-12-2003 08:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration