-   Linux - Newbie (
-   -   home network (

Baracuda 03-19-2007 09:46 AM

home network
I have two computers at home. I have FC6 on a desktop and FC4 on a laptop. They both connect to a router through whick they connect to a cable modem. I would like to be able to have the two computers communicate for saving files on the desktop and in order to print from the desktop. I used the Linuxquestions tutorial "Easy NFS" but when I attempt to mount I get the message that the server is down.
Do I need to configure something on the laptop as well as the desktop?

These are the files I edited on the desktop:



portmap: ALL
lockd: ALL
mountd: ALL
rquotad: ALL
statd: ALL

I verified that the stated daemons were running.

All I did on the laptop was attempt to mount:
mount /home/me /home/me

I have everything set to use a DHCP but verified the current ip address to be correct for the desktop.

What am I leaving out or doing wrong?


camorri 03-19-2007 10:33 AM

I have NFS running well on my home network. I believe you have to edit your hosts.allow file and allow other services besides mountd. For each host I allow, here is the setup...


portmap: , , , ,

lockd: , , , ,
rquotad: , , , ,
mountd: , , , ,
statd: , , , ,
sshd sshd1 sshd2 : , , , ,
You don't need to allow sshd, unless you want to use ssh as well.

I think on your mount command you need to specify the file system type as nfs. I put entries in my clients /etc/fstab file so if the server is up, and I connect a client, they connect when the client is booted. Here is a sample of fstab...


sluggy:/home/cliff/download /mnt/data/download nfs rsize=8192,wsize=8192,timeo=14,intr
I also set up a /etc/hosts file and set the IP addresses in the hosts file, so I can use the names in place of IP addresses.

DHCP is O.K. as long as the network is small. Some routers allow you to control which IP address is issued to which MAC address. This way you always get the same IP address from a DHCP request.

To print, you need to set up cups on both systems. Set up the local machine and get local printing working. Then set up cups on the remote machine. You add the printer on the remote and specify the print driver. Once cupsd is running, connect to it with your web browser with :


To add a printer, you log as root, and do "admin tasks" "add printer".

Hope this helps.

Baracuda 03-25-2007 03:06 PM

I followed all of the instructions and am still getting the same message:

mount to NFS server 'x.x.x.x' failed: server is down

Before I ran the mount command on the laptop I verified that the server was up. I ran:

ps aux | grep nfsd,lockd,statd,mountd,rquotad
root 3821 0.0 0.1 60236 704 pts/1 R+ 16:00 0:00 grep nfsd,lockd,statd,mountd,rquotad

I also ran:

ps aux | grep nfs
root 2616 0.0 0.0 0 0 ? S< 11:34 0:00 [nfsd4]
root 2619 0.0 0.0 0 0 ? S 11:34 0:00 [nfsd]
root 2620 0.0 0.0 0 0 ? S 11:34 0:00 [nfsd]
root 2621 0.0 0.0 0 0 ? S 11:34 0:00 [nfsd]
root 2622 0.0 0.0 0 0 ? S 11:34 0:00 [nfsd]
root 2623 0.0 0.0 0 0 ? S 11:34 0:00 [nfsd]
root 2624 0.0 0.0 0 0 ? S 11:34 0:00 [nfsd]
root 2625 0.0 0.0 0 0 ? S 11:34 0:00 [nfsd]
root 2626 0.0 0.0 0 0 ? S 11:34 0:00 [nfsd]
root 3830 0.0 0.1 60236 692 pts/1 R+ 16:02 0:00 grep nfs


service nfs status
rpc.mountd (pid 3274 2629) is running...
nfsd (pid 2626 2625 2624 2623 2622 2621 2620 2619) is running...
rpc.rquotad (pid 3269 2596) is running...

Why would I be getting the message that the server is down?

Should I do something else on the desktop or laptop in order to make the connection?

btmiller 03-25-2007 04:24 PM

Are you running iptables on the desktop? If so is it blocking access to the portmapper and/or the ports nfsd is running on? While you're at it, make sure that portmap is actually running, as the NFS client will need to use it.

camorri 03-26-2007 08:31 AM

I cut this from the 'Easy NFS Setup' on the networking tutorials... for the client...


Start the portmapper, lockd, and statd services on the client machine, and
begin enjoying your NFS setup.


$ mount /blahasdf/files

$ umount /files

Verify you have thoes running on your client systems.

All times are GMT -5. The time now is 01:38 PM.