LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-11-2013, 08:59 AM   #1
PingGUI
LQ Newbie
 
Registered: Jan 2011
Posts: 5

Rep: Reputation: 0
Home LAN problem


I hope this is the right place for this and would love to be pointed to the correct place if not.

I have inherited an old Belkin and three old desktop PC's two running Mint the second Ubuntu. I can ssh into the desktops when they are plugged into my laptop(Ubuntu) via an Ethernet cable.

I want to be able to connect the desktop's to the router so I dont have to keep switching the Ethernet cables around.

Is this possible and how do I start ? (I have also not been able to access the routers admin page )

Thank you for reading all of that.
 
Old 03-11-2013, 09:02 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
A belkin what? They make a hell of a lot of different things!

A router will usually be running a DHCP server etc, so just plugging them all in will usually work by default.
 
Old 03-12-2013, 05:06 AM   #3
PingGUI
LQ Newbie
 
Registered: Jan 2011
Posts: 5

Original Poster
Rep: Reputation: 0
Thank you for the speedy reply.

I can get it to work so long as I plug the ethernet cable into my laptop then ssh into the desktop then plug the router in the middle. I cant directly ssh into the desktop via the router without first doing it directly.

Is this to with DHCP ?

The belkin router is a FD1401 v1 (Not a router supported by dd-wrt)

I have tried to access the admin page by connecting the router to my laptop and going to 192.168.2.1 which is the adress the manual suggests.
 
Old 03-12-2013, 05:31 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
what are you doing to make the systems work directly? Where is the IP addressing coming from? you're applying it manually? Are you not doing anythign at all? I'm not sure how much stuff might happen by magic these days via NetworkManager, are you put on a 169.254 IP address? (ifconfig -a when connected will show you) If all clients are configured to use DHCP, which would be default, and the router IS prodividing a DHCP service, which would be a default again, then eveything should just work. Make sure you can ping the router IP from each device first though before trying to go between two machines. That'll highlight which connection has the issue, if it's only one.
 
Old 03-12-2013, 06:23 AM   #5
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677
Why are you plugging and unplugging the laptop's nic device? Are you really saying that you can't share files with a desktop computer, from the laptop when using the wireless device? The router may have wireless isolation enabled by default. If so, you simply need to disable it in the web interface. You may need to look up the default user and password for the router. If this was changed by the previous owner, you may need to factory reset the router.

What is the IP address of the desktop, with the wired connection? The first 3 octets of the router's web interface will probably be the same. So if the desktop has an IP address of 192.168.1.100, the router is probably at 192.168.1.1.

Last edited by jschiwal; 03-12-2013 at 06:34 AM.
 
Old 03-12-2013, 01:29 PM   #6
rtmistler
Moderator
 
Registered: Mar 2011
Location: Sutton, MA. USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu
Posts: 5,960
Blog Entries: 12

Rep: Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034
A first choice would be to see if you can get documentation on that particular Belkin device. You're saying that you have tried to access the admin page for the Belkin, so that encourages me in seeing that you have some understanding of network awareness and network configuration.

I'd try and default that Belkin to it's factory defaults. You say you inherited it, but who knows how it's configured, I didn't even look it up, but some things that are striking my mind are MAC address security, or other forms of security, or even the fact that DHCP have been disabled. Perhaps the former user of that equipment used it in a static address configuration and hence they disabled assignment of network address assignment.

OK, I didn't want to be dismissive/unkind and so I googled for FD1401, it looks like a wireless router. I'd definitely default it so that it will be unsecured for now and then later configure it once you get it working properly. If they have firmware updates, I'd recommend that too.

The other short of it is:
- ifconfig on Linux will show you the IP address information for your system. eth0 is likely the port you'd be looking at. "lo" will be the local loopback and is not what you will be interested in. Here's an example of my ifconfig, where I happen to have two network adapters and I recommend that you try this with only one adapter in the machine until you figure out these problems.

Code:
desktop:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:26:18:06:b7:09  
          inet addr:192.168.1.128  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: 2002:183e:221a:0:226:18ff:fe06:b709/64 Scope:Global
          inet6 addr: fe80::226:18ff:fe06:b709/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:35198549 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12321954 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1256998922 (1.2 GB)  TX bytes:149167381 (149.1 MB)
          Interrupt:28 Base address:0x6000 

eth1      Link encap:Ethernet  HWaddr 00:1b:21:48:c3:95  
          inet addr:192.168.2.6  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::21b:21ff:fe48:c395/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:808524 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1108453 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:302842604 (302.8 MB)  TX bytes:671971757 (671.9 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:88394 errors:0 dropped:0 overruns:0 frame:0
          TX packets:88394 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:7511611 (7.5 MB)  TX bytes:7511611 (7.5 MB)
If you're seeing the self assigned address or something, then there's a fundamental problem getting an address assigned for your machine and you need to look at the router to figure out what it's doing.
 
Old 03-16-2013, 06:49 AM   #7
PingGUI
LQ Newbie
 
Registered: Jan 2011
Posts: 5

Original Poster
Rep: Reputation: 0
Cheers for all the support. Iv needed some time to work on your suggestions and come up with a reply.

I still have no idea how to get the router web interface. Iv tried putting the router ip 196.168.1.0 which the manual suggests, into my browser.

ifconfig was a useful command. Iv connected the desktop into the router and then into my laptop and ifconfig gave the eth0 as 192.168.... Which I was not expecting and cant seem to ssh into. I the connected the desktop to the laptop and ifconfig gave 10.42.... Which I can ssh into and survives restarts of both laptop and the desktop.

If I conect the router after ifconfig shows the desktop eth0 as 10.42.. it stays a 10.42... and works fine.

I want to know what causes this and how to prevent it in the future.
 
Old 03-16-2013, 11:44 AM   #8
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 1,879

Rep: Reputation: 263Reputation: 263Reputation: 263
http://www.linuxhomenetworking.com/w..._to_Networking

http://www.linuxhomenetworking.com/w...etwork_Devices

http://en.wikipedia.org/wiki/Cidr

Find out how to access the router, maybe a reset somewhere on it will bring it back to default settings. Then look at how each puter is set up. Everything needs to be using DHCP or assign everything a fixed IP. Read the links above.

If you can't find the routers address, You should be able to find what's on the subnet with example (Use your own IP range)
Code:
nmap -sP 192.168.0.0/24
Also route or ip route might give you some info.
Code:
ip route
default via 192.168.0.1 dev eth0
http://linux.die.net/man/1/nmap
http://linux.die.net/man/8/route
http://linux.die.net/man/8/ip
http://linux.die.net/man/8/ifconfig

Dive in and find out what you have and how it works.
 
1 members found this post helpful.
Old 03-16-2013, 01:28 PM   #9
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,907

Rep: Reputation: 1994Reputation: 1994Reputation: 1994Reputation: 1994Reputation: 1994Reputation: 1994Reputation: 1994Reputation: 1994Reputation: 1994Reputation: 1994Reputation: 1994
There should be a hole somewhere where you can poke a paperclip or similar to reset the router to factory defaults:
http://www.dslreports.com/faq/13631
There's not much point messing around with the IP configuration on your laptop and PC until you've got your router in a known-good state where you can access the configuration page on it.
 
1 members found this post helpful.
Old 03-17-2013, 08:39 AM   #10
rabirk
Member
 
Registered: Dec 2012
Location: Maryland, US
Distribution: Debian
Posts: 87
Blog Entries: 8

Rep: Reputation: Disabled
Also, if you haven't tried 192.168.1.1 to access the router, I'd give that a try. It's oftentimes the default.
 
Old 03-18-2013, 09:14 AM   #11
rtmistler
Moderator
 
Registered: Mar 2011
Location: Sutton, MA. USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu
Posts: 5,960
Blog Entries: 12

Rep: Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034
I agree with the recommendations to default the router, having also suggested that earlier.

In addition it's worth ensuring that your system accepts a default network situation too. Examine your /etc/networks/interfaces file and if it has more than something simple like:

Quote:
-desktop:/etc/network$ cat interfaces
auto lo
iface lo inet loopback
Then I'd suggest renaming it (via sudo) to a backup, reboot, and let the system create a default one for you.

Quote:
sudo mv /etc/networks/interfaces /etc/networks/interfaces.bak
 
1 members found this post helpful.
Old 03-20-2013, 07:20 AM   #12
PingGUI
LQ Newbie
 
Registered: Jan 2011
Posts: 5

Original Poster
Rep: Reputation: 0
Thank you everybody for being so helpful. You have given me an awful lot of information so I doubt I will be coming back soon with any meaniful questions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how do YOU name your in-home LAN? SaintDanBert Linux - Networking 13 10-21-2010 05:25 PM
LAN at Home akvino Linux - Networking 12 07-04-2007 07:17 PM
Home LAN Setup bLaDe Linux - Networking 3 04-28-2006 08:03 AM
Home Wireless LAN - Problem kicker Linux - Wireless Networking 2 03-24-2006 09:31 AM
sharing internet over home lan! 94gsr Linux - Networking 13 05-04-2004 04:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration