LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-04-2017, 03:27 AM   #1
nadawy
LQ Newbie
 
Registered: May 2017
Posts: 21

Rep: Reputation: Disabled
hii every one ..


iam trying to improve AODV routing protocol by adding speed and direction of each node in RREQ new fields in aodv.cc file and check which of neighbors node in the same direction and appropriate speed i will chose these nodes to receive RREQ message and i dont know this language to programing on it ..using NS2-35 and ubuntu12.04 .. can anyone solve my problem

Last edited by nadawy; 05-04-2017 at 03:30 AM.
 
Old 05-04-2017, 05:29 AM   #2
Keruskerfuerst
Senior Member
 
Registered: Oct 2005
Location: Horgau, Germany
Distribution: Manjaro KDE, Win 10
Posts: 2,197

Rep: Reputation: 164Reputation: 164
You should use a more recent version of Ubuntu, like 16.04 LTS.
 
1 members found this post helpful.
Old 05-04-2017, 05:50 AM   #3
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Welcome to LQ!

12.04 is End Of Life.

in a terminal >
Code:
sudo do-release-upgrade -c
to "check" for upgrade candidacy.
If good, run
Code:
sudo do-release-upgrade
and follow the prompts.

file.conf "conflicts"? I usually keep what I have (is default too I believe)

and the only package I had trouble with was some perl library or something being rolled into the main perl package, so I had to
Code:
sudo apt-get install libperl5.18
after the Upgrade.

Last edited by Habitual; 05-04-2017 at 05:51 AM. Reason: s/mail/main
 
1 members found this post helpful.
Old 05-04-2017, 06:16 AM   #4
nadawy
LQ Newbie
 
Registered: May 2017
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Keruskerfuerst View Post
You should use a more recent version of Ubuntu, like 16.04 LTS.

thats right but the supervisor put condition to be ubuntu12.04 to work with sumo and move simulators
 
Old 05-04-2017, 06:19 AM   #5
nadawy
LQ Newbie
 
Registered: May 2017
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Keruskerfuerst View Post
You should use a more recent version of Ubuntu, like 16.04 LTS.
Quote:
Originally Posted by Habitual View Post
Welcome to LQ!

12.04 is End Of Life.

in a terminal >
Code:
sudo do-release-upgrade -c
to "check" for upgrade candidacy.
If good, run
Code:
sudo do-release-upgrade
and follow the prompts.

file.conf "conflicts"? I usually keep what I have (is default too I believe)

and the only package I had trouble with was some perl library or something being rolled into the main perl package, so I had to
Code:
sudo apt-get install libperl5.18
after the Upgrade.


thanks very much .. can i do improvement on AODV in 12.04 or not???
 
Old 05-04-2017, 07:49 AM   #6
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by nadawy View Post
thanks very much
You're welcome.
and I don't know.

Have a great day!
 
1 members found this post helpful.
Old 05-04-2017, 09:21 AM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,425

Rep: Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622
@nadawy :

Ubuntu 12.04 is OK with the most ns2 changes / modifications / additional protocols.

Please use Google to look for solutions :
https://www.google.com/webhp?hl=all&...e+in+RREQ+aodv


-
 
1 members found this post helpful.
Old 05-04-2017, 11:31 AM   #8
nadawy
LQ Newbie
 
Registered: May 2017
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by knudfl View Post
@nadawy :

Ubuntu 12.04 is OK with the most ns2 changes / modifications / additional protocols.

Please use Google to look for solutions :
https://www.google.com/webhp?hl=all&...e+in+RREQ+aodv


-
beautiful idea browse title .. thanks very much
 
  


Reply

Tags
aodv, ns2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hii akmere LinuxQuestions.org Member Intro 4 07-30-2016 04:54 AM
Hii!! Pinux Linux - Newbie 2 05-06-2016 06:55 PM
Hii everyone... Elizabeth_Keen LinuxQuestions.org Member Intro 1 08-20-2014 08:28 PM
hii chaudhary9 LinuxQuestions.org Member Intro 1 07-04-2011 09:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration