LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-19-2016, 02:46 PM   #1
AdultFoundry
Member
 
Registered: Jun 2015
Posts: 282

Rep: Reputation: Disabled
High server load after moving /var/lib/mysql


mysqld is showing as using 770% of the cpu in top. I have a script that displays the load average of the hosting and in a normal situation it is at around 3 or 4 it gets to up to 100 or more at this point.

Would you have an idea how to figure out what is going on and how to fix the problem. I add that I've been already researching this topic in google.com for about two hours so far.

This is top:
http://prntscr.com/dlgsh9

Very high mysqld / mysql load on the CPU.

Last edited by AdultFoundry; 12-19-2016 at 02:48 PM.
 
Old 12-20-2016, 08:21 AM   #2
JeremyBoden
Senior Member
 
Registered: Nov 2011
Location: London, UK
Distribution: Debian
Posts: 1,948

Rep: Reputation: 511Reputation: 511Reputation: 511Reputation: 511Reputation: 511Reputation: 511
Note that mysql is using 4.8% of memory - but 776% of CPU.

Two possibilities - a program loop!
or even swap thrashing!!!

You've missed the top few lines from top.
I'm presently running an intensive media conversion program (4 cores, 8GB).
Attached Thumbnails
Click image for larger version

Name:	Screenshot from 2016-12-20 14:08:48.png
Views:	13
Size:	190.8 KB
ID:	23806  
 
Old 12-20-2016, 10:16 AM   #3
AdultFoundry
Member
 
Registered: Jun 2015
Posts: 282

Original Poster
Rep: Reputation: Disabled
This is how it was looking yesterday:
http://prnt.sc/dlheuq

I had to go to sleep so I left it at this, and I turned my pc off. I have a program that is showing the load average and it was reaching 100 or more.

When I turned on the computer in the morning everything was ok. The load average in the program that I mentioned was like 0.5 instead of the 70-100+ yesterday. I guess there was something wrong there, but it cleared itself up, by itself. When I entered SHOW ALL PROCESSES; (or something like that) in mysql it was showing transactions related to a pinterest clone script that I have. It is not the best program, and I need to replace it for something else. The main page with pins was working on at the beginning and it now it takes like 25 seconds to load. I was told by the support that the hosting is not good enough, but it is not a bad plan for anything else that I have (pic site script, wordpress, good tube script).

It would be good to know what may have been going on for edu purposes, and better understanding of things.

This is the top command now:
http://prntscr.com/dlsopy

Like I said, there was something wrong with something, but it cleared itself up by itself, possibly, I am not sure. It would be good what this was and if everything is good now. It may not be good.

Last edited by AdultFoundry; 12-20-2016 at 10:19 AM.
 
Old 12-20-2016, 11:30 AM   #4
JeremyBoden
Senior Member
 
Registered: Nov 2011
Location: London, UK
Distribution: Debian
Posts: 1,948

Rep: Reputation: 511Reputation: 511Reputation: 511Reputation: 511Reputation: 511Reputation: 511
Look at your log files?
 
Old 12-20-2016, 11:52 AM   #5
Sefyir
Member
 
Registered: Mar 2015
Distribution: Linux Mint
Posts: 634

Rep: Reputation: 316Reputation: 316Reputation: 316Reputation: 316
Isn't this basically the same issue from http://www.linuxquestions.org/questi...-a-4175595701/ ?
 
1 members found this post helpful.
Old 12-20-2016, 01:15 PM   #6
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
So, it just started acting up all by itself?
When did it last work as expected?
What changed since it worked last?

At least 4 posts all for the same thing. No worries.
Zero actionable details.

Why do we have to hunt down your recent misadventures?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql. NoviceW Linux - Networking 17 09-17-2014 02:13 PM
HTTPD: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' markseger Fedora - Installation 2 02-09-2011 11:53 PM
mysql error Can't connect to local MySQL server through socket '/var/lib/mysql/mysql. SpellChainz Linux - Newbie 1 06-23-2007 03:35 PM
mysql error Can't connect to local MySQL server through socket '/var/lib/mysql/mysql. Dannux Linux - Software 3 03-24-2006 08:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration