LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-04-2011, 07:19 PM   #1
ibrahim52
LQ Newbie
 
Registered: Aug 2011
Posts: 13

Rep: Reputation: Disabled
Hibernate/Suspend doesn't work


Hello,
First of all let me introduce myself. My name is Rasheed and i am from UAE, after not having any reply from a week in Fedora's official forum i came across the linuxquestions through google and hoping to help others and resolve my issues as well with the help of experts here. So here is my problem what i am currently having.

I am going through a serious issue right now. My laptop crashes when SUSPEND/HIBERNATE or unplugging the laptop's charger. Any idea, how can i check the logs and fix it ?
 
Old 08-04-2011, 07:34 PM   #2
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Hello,

What kind of computer do you have, and what version of Fedora are you using?

Cheers,

Josh
 
Old 08-04-2011, 07:39 PM   #3
ibrahim52
LQ Newbie
 
Registered: Aug 2011
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by corp769 View Post
Hello,

What kind of computer do you have, and what version of Fedora are you using?

Cheers,

Josh


Currently i am having LENOVO G550 and FEDORA 15. I had F15 before but recently i reinstalled it by creating the partitions again as i had very less space for SWAP but atleast i was able to suspend it if not hibernate but this time, whenever i do hibernate or suspend. The CAPS LOCK LED starts blinking and screen goes blank. That's it.
 
Old 08-04-2011, 07:41 PM   #4
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Smells like a kernel panic Try booting into a different/previous version of the kernel and see of your problem persists, before we start troubleshooting further.
 
Old 08-04-2011, 07:59 PM   #5
ibrahim52
LQ Newbie
 
Registered: Aug 2011
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by corp769 View Post
Smells like a kernel panic Try booting into a different/previous version of the kernel and see of your problem persists, before we start troubleshooting further.
Not an expert but if you can help me on rollback to previous version, please.
 
Old 08-04-2011, 08:28 PM   #6
ibrahim52
LQ Newbie
 
Registered: Aug 2011
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by corp769 View Post
Smells like a kernel panic Try booting into a different/previous version of the kernel and see of your problem persists, before we start troubleshooting further.

Oh yeah, one more thing as i mentioned the problem persists since i reinstalled the OS on formatted partition.
 
Old 08-09-2011, 03:19 PM   #7
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Hello,

Just received your email.... Your thread moved down my list and I didn't see it; Any luck lately? As far as trying a previous kernel, at your grub screen, press any key, and select a previous version and see if that helps.

Cheers,

Josh
 
1 members found this post helpful.
Old 08-09-2011, 03:27 PM   #8
ibrahim52
LQ Newbie
 
Registered: Aug 2011
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by corp769 View Post
Hello,

Just received your email.... Your thread moved down my list and I didn't see it; Any luck lately? As far as trying a previous kernel, at your grub screen, press any key, and select a previous version and see if that helps.

Cheers,

Josh
Thanks Josh, i figured that out but still even after booting from previous versions. There is no change as i told you after i formatted and reinstalled Fedora since than i am not able to make through hibernate/suspend.
 
Old 08-09-2011, 03:30 PM   #9
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
To me, it is starting to seem like a hardware problem, especially since you said that when you unplug your charger, it crashes.... How is your laptop's battery life? I know it seems dumb, but that may be playing a part here - a power issue.
 
Old 08-09-2011, 07:54 PM   #10
ibrahim52
LQ Newbie
 
Registered: Aug 2011
Posts: 13

Original Poster
Rep: Reputation: Disabled
Unhappy

Quote:
Originally Posted by corp769 View Post
To me, it is starting to seem like a hardware problem, especially since you said that when you unplug your charger, it crashes.... How is your laptop's battery life? I know it seems dumb, but that may be playing a part here - a power issue.


But if i hibernate/suspend WINDOWS 7 (installed) it works perfectly without any issues and sleep mode last for 5 minutes at least and automatically goes to hibernate and as i mentioned earlier that it was working fine earlier when i installed F15 but i did not had much space in that partition so i decided to install the F15 again with bigger partition and discovered this issue
 
Old 08-09-2011, 08:12 PM   #11
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
That's definitely weird. Have you tried using any other distributions, like ubuntu or slackware?
 
Old 08-10-2011, 05:40 AM   #12
ibrahim52
LQ Newbie
 
Registered: Aug 2011
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by corp769 View Post
That's definitely weird. Have you tried using any other distributions, like ubuntu or slackware?
and guess what UBUNTU works flawlessly , is there anyway i can trace through any logs or something ?
 
Old 08-10-2011, 06:31 AM   #13
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Awesome..... Disable ACPI for Fedora by editing /boot/grub/grub.conf and adding the following to the end of your kernel options:
Code:
acpi=off
Cheers,

Josh
 
Old 08-10-2011, 06:32 PM   #14
ibrahim52
LQ Newbie
 
Registered: Aug 2011
Posts: 13

Original Poster
Rep: Reputation: Disabled
Unhappy

Quote:
Originally Posted by corp769 View Post
Awesome..... Disable ACPI for Fedora by editing /boot/grub/grub.conf and adding the following to the end of your kernel options:
Code:
acpi=off
Cheers,

Josh
Code:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,4)
#          kernel /boot/vmlinuz-version ro root=/dev/sda5
#          initrd /boot/initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.40-4.fc15.i686)
	root (hd0,4)
	kernel /boot/vmlinuz-2.6.40-4.fc15.i686 ro root=UUID=30a6f48-3d6- rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
acpi=off
	initrd /boot/initramfs-2.6.40-4.fc15.i686.img
title Fedora (2.6.38.8-35.fc15.i686)
	root (hd0,4)
	kernel /boot/vmlinuz-2.6.38.8-35.fc15.i686 ro root=UUID=30a6f48-3d6- rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
	initrd /boot/initramfs-2.6.38.8-35.fc15.i686.img
title Fedora (2.6.38.6-26.rc1.fc15.i686)
	root (hd0,4)
	kernel /boot/vmlinuz-2.6.38.6-26.rc1.fc15.i686 ro root=UUID=30a6f48-3d6- rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
	initrd /boot/initramfs-2.6.38.6-26.rc1.fc15.i686.img
title Other
	rootnoverify (hd0,0)
	chainloader +1
Am i doing it right ? as i always chose the latest kernel version i am using. I tried the above but still it crash in the same way.
 
Old 08-10-2011, 09:39 PM   #15
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
It needs to be on the same line:
Code:
kernel /boot/vmlinuz-2.6.40-4.fc15.i686 ro root=UUID=30a6f48-3d6- rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet acpi=off
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xfce 4.6 Suspend and Hibernate Function does not work properly with my notebook. phys Slackware 2 03-09-2009 06:46 PM
bluetooth logitech mouse doesn't work after standby or hibernate mexx20 Slackware 3 01-18-2009 09:27 PM
wirless iwl3945 doesn't work after suspend zux Slackware 11 12-06-2008 09:33 AM
Boot from USB key, does suspend or hibernate work? paulsiu Linux - Hardware 1 05-02-2008 03:34 PM
Sound doesn't work after sleep or hibernate, how to restart? lumix Linux - Hardware 1 12-16-2007 05:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration