LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-14-2015, 11:10 AM   #1
aditya.mukundan
Member
 
Registered: Jul 2015
Location: India
Distribution: slackware
Posts: 42

Rep: Reputation: Disabled
help with xfce compilation


when trying to compile libxfce4ui i am getting a following error
when trying to configure ..
checking for libxfce4util-1.0 >= 4.12.0... found, but 4.10.1
*** The required package libxfce4util-1.0 was found on your system,
*** but the installed version (4.10.1) is too old.
*** Please upgrade libxfce4util-1.0 to atleast version 4.12.0, or adjust
*** the PKG_CONFIG_PATH environment variable if you installed
*** the new version of the package in a nonstandard prefix so
*** pkg-config is able to find it.

i can't find a solution ,however i need help with it.i wish to learn and tackle the same if it occurs in future .pls help

Last edited by aditya.mukundan; 07-14-2015 at 11:12 AM.
 
Old 07-14-2015, 01:09 PM   #2
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: Redhat/Centos, Ubuntu, Raspbian, Fedora, Alpine, Cirros, OpenSuse/SLES
Posts: 3,461

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
Just follow the instructions:
Code:
upgrade libxfce4util-1.0 to atleast version 4.12.0
Now, precisely how you upgrade it depends on the distro you are using, I guess.

There is also the possibility that the newer version exists already on your system, but it's in a non-standard location. This might be so because other programs need the older version.
Should this be the case, use the PKG_CONFIG_PATH to tell the config program where to find it.

Disclaimer: I don't know anything about your distro, nor about compiling XFCE.
 
Old 07-14-2015, 09:07 PM   #3
aditya.mukundan
Member
 
Registered: Jul 2015
Location: India
Distribution: slackware
Posts: 42

Original Poster
Rep: Reputation: Disabled
i am using salckware would you please tell me weather i've to use pkgtool or installpkg?i'm not quite sure of the command
 
Old 07-14-2015, 09:26 PM   #4
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: Redhat/Centos, Ubuntu, Raspbian, Fedora, Alpine, Cirros, OpenSuse/SLES
Posts: 3,461

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
I am sorry to say that I don't know the slackware softwre management tools.
 
Old 07-14-2015, 09:30 PM   #5
aditya.mukundan
Member
 
Registered: Jul 2015
Location: India
Distribution: slackware
Posts: 42

Original Poster
Rep: Reputation: Disabled
okay but i've installed that ./configure and make for libxfce4util-4.12.1 ....still it says installed version is 4.10....how to redirect or adjust the variable, i tried ./configure --prefix=/usr/lib.
still it's not working..
 
Old 07-14-2015, 09:35 PM   #6
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: Redhat/Centos, Ubuntu, Raspbian, Fedora, Alpine, Cirros, OpenSuse/SLES
Posts: 3,461

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
Quote:
Originally Posted by aditya.mukundan View Post
okay but i've installed that ./configure and make for libxfce4util-4.12.1 ....still it says installed version is 4.10....how to redirect or adjust the variable, i tried ./configure --prefix=/usr/lib.
still it's not working..
make just compiles the software. After that, make install puts it in place.

Regarding package management, let me recommend you read the documentation: http://www.slackbook.org/html/packag...utilities.html. You use whichever of the two tools you prefer.
 
Old 07-14-2015, 10:18 PM   #7
aditya.mukundan
Member
 
Registered: Jul 2015
Location: India
Distribution: slackware
Posts: 42

Original Poster
Rep: Reputation: Disabled
oh right make install.....right i'll revert after trying that out...
libxfce4util

update...
tried for the dependencies as well....no luck.....after trying libxfce4util-4.12.1 and xfconf which is required for libxfce4ui-4.12.0 tried ./configure still no luck

Last edited by aditya.mukundan; 07-14-2015 at 10:24 PM.
 
Old 07-15-2015, 04:34 AM   #8
aditya.mukundan
Member
 
Registered: Jul 2015
Location: India
Distribution: slackware
Posts: 42

Original Poster
Rep: Reputation: Disabled
i setp up PKF_CONFIG_PATH before installing.Solved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Fedora 22 Linux Xfce Edition with Xfce 4.12 Screenshot Tour LXer Syndicated Linux News 0 06-12-2015 01:51 PM
LXer: Manjaro Linux Xfce 0.9.0 Promises to Bring the Best Xfce 4.12 Experience Possible LXer Syndicated Linux News 0 03-16-2015 11:30 AM
XFCE or Xfce desktop file manager question(s) and ntfs BW-userx Slackware 4 10-05-2013 08:28 AM
[SOLVED] Need help in installing XFCE in Linux Mint XFCE 13 (Don't be putoff by the title) psathiya1987 Linux - Software 5 10-07-2012 06:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration