LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   help with fstab can't write to second hdd (https://www.linuxquestions.org/questions/linux-newbie-8/help-with-fstab-cant-write-to-second-hdd-465505/)

albertBeach 07-19-2006 06:45 AM

help with fstab can't write to second hdd
 
The 'H" word :(
Using Fedora Core 5
I have tried and read the fstab to bits!!
I have understood and read a lot I have had no trouble doing it
I have added a second hard ide drive augementing a scsi and a cdrom
in FC3 FC4 previous.. and also mounting a vfat partition....but
I still can't get user write access to this mounted drive.
The whole drive is formatted with a ext3fs
here's my line

/dev/hdc1 /home/name/namexx/ ext3 user,noauto,dev,exec,rw 0 0
no errors on bootup
and as I look in the dir I still see the no write acces to the mounted
folder and the permission is owned by root.
what sort of silliness am I doing ..THANKYOU in advance :)

albert the dunce

b0uncer 07-19-2006 06:55 AM

Umm well an option umask=022 that I usually use with usb flash disk/mp3 players makes the mounted filesystem be available for all users read&write..but is it what you want?

Zmyrgel 07-19-2006 07:53 AM

Quote:

Originally Posted by albertBeach
/dev/hdc1 /home/name/namexx/ ext3 user,noauto,dev,exec,rw 0 0

Change the above to:
Code:

/dev/hdc1  /home/name/namexx/  ext3  user,noauto,defaults 0 0
I had weird results when my root partition was mounted with the exec option. Try the above and see if it helps.

albertBeach 07-20-2006 01:17 AM

Thanks a million for your help guys! :)
b0uncer and Zmyrgel
It works! I tried the 'defaults' option one first
and it worked first time.. I hadn't tried the umask one yet but will do! :)
cheers again

albertbeach :)

albertBeach 07-20-2006 02:16 AM

fstab problems
 
:( Need some more help ?
My return posting of success with this problem was premature.
My exitement re using the different fstab lines for
having user write permissions on extra mounted hard drive were short lived.
It seems when I rebooted again still don't have access to write
to mounted drive.
Still no closer to solution.

albertloosingItbeach .

b0uncer 07-20-2006 06:27 AM

What do you have in the drive, if nothing? If your fstab file is ok, then have you set the permissions correctly on the filesystem (i.e. if it's ext3, then do you have write access to the root of the filesystem)?

Code:

/dev/hdc1  /home/name/namexx/  ext3  user,noauto,rw,umask=022 0 0
The above fstab line should work as far as I understand. Well I'm not sure about the umask=022 option since I've only used that for flash disks which use fat filesystem..but even without it it should work.

albertBeach 07-20-2006 07:03 AM

Hi :)
Thanks b0uncer..
I have pasted what I have and still the same
rayeng@Boolean ~]$ cat /etc/fstab
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/hdc1 /home/name/namexx ext3 user,noauto,rw,umask=022 0 0


[rayeng@Boolean namexx]$ mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda1 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
automount(pid2242) on /net type autofs (rw,fd=4,pgrp=2242,minproto=2,maxproto=4)
/dev/hdc1 on /home/name/namexx type ext3 (rw)

[rayeng@Boolean namexx]$ ls -l
total 16
drwx------ 2 root root 16384 Jul 18 21:26 lost+found
still no write :( .. I'll keep searching

albertbeach

Zmyrgel 07-20-2006 08:34 AM

Check the mount point which permissions it has.


All times are GMT -5. The time now is 09:24 PM.