LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   help with first time running linux (https://www.linuxquestions.org/questions/linux-newbie-8/help-with-first-time-running-linux-410232/)

thecheat 01-29-2006 02:41 PM

first time install! help!
 
Well I was bored with doing the same old thing over and over and I had an extra hard drive so I decided to try linux (Red Hat 9). I downloaded and installed everything successfully (to my surprise) but I'm having difficulties with the loading. It looks like everything loads alright with all the green OK's but it then gets to a prompt that asks for a login and password. During the installation I didn't see anything that asked for a login name, it only asked for a supervisor password. Where can I set a login name and pass? Any help with getting through this would be greatly appreciated! Thanks!

vls 01-29-2006 02:53 PM

The 'supervisor' password is the root account password.
When you get the login prompt:

Code:

login: root
password: password you set up (hopefully)

If that gets you in, you are now God of the Machine.

Try adduser to set-up a normal user to do your daily futzing about.

thecheat 01-29-2006 03:10 PM

that got me in..but I am still confused (noob) is there a command to get me out of the prompt part and into the desktop environment?

vls 01-29-2006 03:19 PM

Not a RedHat guy, but try startx.

Hopefully some RH gurus will pop in.

Brian1 01-29-2006 03:31 PM

Been a long time since installing Redhat 9. If you are not to deep into it and wish to stay with Redhat type then install Fedora Core 4. It is the latest since the Fedora team took over redhat workstation.

But startx should bring up either KDE or gnome if you choose that during the install.

Once there in the start menu there will be a gui tool to add users. Create a new user and logout and back into as that user. That way you can't really mess much. If running root and type the wrong command it can wipe your data quickly. It is best to use root only when needed.

Brian1

thecheat 01-31-2006 09:44 PM

help with first time running linux
 
I posted a couple days ago regarding help with installing red hat 9 for the first time, and in response some people told me how to long in as 'root' and use startx to start everything up (I'm a huge noob). Anyways, when I do type startx, it looks like I get a variety of errors: I wrote some of them down in hope of getting some help here :)

(EE) Unable to locate/open config file
(EE) Error from xf86HandleConfigFile()

Fatal server error:
no screens found

XI0: fatal IO error 104 (connection reset by peer) on X server

I think those were the only ones. Any help with any of this would be greatly appreciated. Thanks!

Penguin of Wonder 01-31-2006 10:10 PM

Did you configure XFree86 before you tried to start it? Your error is telling you there is no config(uration) file or you've locked X out of it. The second possiability is extremely unlikely, so odds are you need to configure your X server first. The "no screens error" should come as no surprise since you haven't configured X yet, it dosen't have any "screens" use.

A "screen" is a set of pararmeters X uses when starting up. It tells it which video card, monitor, and such to use after you type 'startx.' This screen thing will make more since after you configure X, trust me.

pljvaldez 01-31-2006 10:22 PM

Also, depending on how new your hardware is, it may not even be supported by RedHat 9 (which is probably on the same order as windows 98 age wise).

If you like red hat, try the newer Fedora Core or CentOS. If you'd like to try something new, try out these quizzes:

thecheat 01-31-2006 11:06 PM

No, I did not configure XFree86 as I do not know how unfortunately...Any help with this as well will be appreciated!

Penguin of Wonder 02-01-2006 12:11 AM

Try running this command at the prompt.
Code:

XFree86 -configure
If you need more help, here is a page about XFree and setting it up.

pixellany 02-01-2006 08:18 AM

When you installed, did it not default to GUI mode? Or did you explicity tell it not to install/configure X and a desktop such as Gnome.

In your situation, it might be easier to reinstall......

primussucks 02-01-2006 08:47 AM

I got that same fatal IO error line, while trying to install Feather to my HD(it worked off the live CD but not of the HD)about 4 days ago. The fix was to make sure i knew what settings my moniter would tolerate, with feather i needed to use a cheat code at the boot promt(vga=789) to get it to work. now with anything else(using debian now) i just need to configure X to the right settings and it works fine.

Timesmuggler 02-01-2006 12:32 PM

Just like to echo what some people said here earlier - probably much easier to start over. And if you want to stay within the redhat world, use Fedora, latest version. Otherwise you might want to check Ubuntu out (my favorite).

Red Hat 9 is really like installing windows 98 ... you'll run into so many problems down the road when trying to install newer software. More modern distributions are more user friendly and easier to maintain. Really.

RH9 is also not faster, or less demanding of resources, than Fedora or Ubuntu. So there's only positives in going to either one of those.

Tinkster 02-01-2006 02:52 PM

Merged the two threads ...

stewlsalws 02-01-2006 03:11 PM

Try Mandriva2006
 
Try Mandriva2006 I have had no trouble installing and it uses a "windows" GUI environment and makes Linux easier to use for ex-Windows people. I can send you a copy is you like. Send me your address

cheers

Stewstewlsalws@yahoo.co.uk


All times are GMT -5. The time now is 08:13 PM.