LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Help with dual-booting vista and ubuntu! (https://www.linuxquestions.org/questions/linux-newbie-8/help-with-dual-booting-vista-and-ubuntu-608649/)

Mortal Light 12-22-2007 10:01 PM

Help with dual-booting vista and ubuntu!
 
I am currently using a vaio vgn-fz140e which came with vista preloaded. I have a 60 gig external hard drive from my previous computer which I had wiped and installed Ubuntu linux on it. For some reason, the computer automatically tries to boot ubuntu but can't load it from the external drive. It doesn't even try to load vista. The words "Booting from local disk; GRUB Loading stage1.15.; GRUB Loading, please wait; Error 21" appears shortly after the computer is turned on. When running ubuntu from the live cd, I can see that both vista and ubuntu are installed on their respective drives, but they won't boot at all. I tried to get into the BIOS, but for some reason, I can't. Can anyone help me?

AceofSpades19 12-22-2007 10:42 PM

having ubuntu installed would not effect the BIOS at all. It should say press Esc to enter menu when its booting up, or something like that. Can't you just unplug the external harddrive to load vista?

Mortal Light 12-22-2007 10:45 PM

Unplugging the external hard drive yields the same results. The only way I can boot anything is by using the ubuntu live cd.

rufusss 12-24-2007 01:51 PM

Which o/s did you install first,i am presuming it was windows vista since you said it was already preloaded.When you installed ubuntu where did you install grub?

Thanks....

dward526 12-24-2007 03:44 PM

You will probably need to reinstall grub

check out the wiki at

https://help.ubuntu.com/community/Re...tallingWindows

Hope this helps

syg00 12-24-2007 04:45 PM

Sounds like you don't have the capability to boot from USB. In which case you'll need to restore the Vista boot-loader - boot the install CD and fix that (you *did* get one, right ???).
Then re-install grub to the (root) partition of the external, then use EasyBCD (as per the above link) to add it to the Vista boot list.

Mortal Light 12-25-2007 04:24 PM

Problem solved
 
Thanks for your help but I finally got both ubuntu and vista to boot. I finally managed to get into the BIOS and it seems like the booting order was changed; the usb drive was set to boot before the internal drive. After switching the order back to default, grub started working like a charm. It seems like the problem was much simpler than I first thought. Thanks again for your help.


All times are GMT -5. The time now is 07:48 AM.