LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Help with Boot Options (https://www.linuxquestions.org/questions/linux-newbie-8/help-with-boot-options-75602/)

DamianY2J 07-24-2003 04:44 PM

Help with Boot Options
 
I have recently set up Mandrake Linux 9.1 as a dual boot with Windows XP Home, and all is well, except I cant seem to set Windows as the default, so when I boot my PC up, it loads into Linux by default. I dont want this.

For some reason, I couldnt find Linux mentioned in the Windows boot.ini file, so I had a look in Linux and found the Control Center --> System --> Boot Manager section.

I saw Linux was default, so I set windows to default, and clicked Apply. I got an error message saying the Configuration was NOT ok. I thought this was Linux trying to make itself the default, so I ignored it, but Linux remained the default when I booted up. Also, I see to have linux, linux-enterpris, failsafe, windows and floppy listed in the Operating Systems windows, which is a bit weird and confusing.

Anyway, how do I make window the default?

Here is my current configuration file (which is shown in the Expert tab):

Quote:

boot="/dev/hda"
map=/boot/map
keytable=/boot/uk.klt
prompt
nowarn
timeout="100"
message=/boot/message
menu-scheme=wb:bw:wb:bw
default=windows

image="/boot/vmlinuz"
label="linux"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"
read-only

image="/boot/vmlinuz-enterprise"
label="linux-enterpris"
root="/dev/hda5"
initrd="/boot/initrd-enterprise.img"
append="devfs=mount hdc=ide-scsi acpi=off"
read-only

image="/boot/vmlinuz"
label="failsafe"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=nomount hdc=ide-scsi acpi=off failsafe"
read-only

other=/dev/hda1
label="windows"
table=/dev/hda

image="/dev/hda1"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"

image="/dev/hda1"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"
And here is the Configuration file error:

Quote:

Configuration NOT ok. LILO said:
LILO version 22.4.1 (test mode), Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2002 John Coffman
Released 27-Jan-2003 and compiled at 11:11:26 on Feb 5 2003.
Reading boot sector from /dev/hda
Using GRAPHIC secondary loader
Calling map_insert_data
Mapping message file /boot/message -> message-graphic
Calling map_insert_file
Boot image: /boot/vmlinuz -> vmlinuz-2.4.21-0.13mdk
Mapping RAM disk /boot/initrd.img -> initrd-2.4.21-0.13mdk.img
Added linux
Boot image: /boot/vmlinuz-enterprise -> vmlinuz-2.4.21-0.13mdkenterprise
Mapping RAM disk /boot/initrd-enterprise.img -> initrd-2.4.21-0.13mdkenterprise.img
Added linux-enterpris
Boot image: /boot/vmlinuz -> vmlinuz-2.4.21-0.13mdk
Mapping RAM disk /boot/initrd.img -> initrd-2.4.21-0.13mdk.img
Added failsafe
Boot other: /dev/hda1, on /dev/hda, loader CHAIN
Added windows *
Boot image: /dev/hda1 -> ide/host0/bus0/target0/lun0/part1
Fatal: Kernel doesn't support initial RAM disks
Has anyone got any ideas?


Also, since I'm here, another weird thing I've noticed is that I can access my Windows files from a Linux menu (from the mnt --> windows menu), and open images, etc, but I cant access Linux files from Windows. In fact, Windows has no mention of Linux anywhere.
They are on 2 separate partitions, so it is a bit weird, but its not a major problem like my default booting thing.

Any ideas please?

Skyline 07-24-2003 04:55 PM

One possible problem in saving your Lilo.conf file is the 2 duplicate entries at the bottom.

Delete these 2 entries at the botom and save lilo.conf again

image="/dev/hda1"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"

image="/dev/hda1"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"



Youve already got :

default=windows

So once your able to save lilo.conf correctly - Windows will be your default boot up OS

remember to become root user at a console after youve saved lilo.conf and type

/sbin/lilo

In general you wont be able to see Linux partitions from Windows but you can see Windows partitions from Linux

Proud 07-24-2003 04:59 PM

Major advice for Mandrake: Use the Mandrake Control Centre and it's bootloader configurator instead of the KDE one in the KDE Control Centre. :)

Also remember you can boot off the 1st Mdk install disk and the rescue mode has an option to fix Lilo if you manage to break it. ;)

Only some newer server releases of Windows have linux filesystem support iirc. :rolleyes:

DamianY2J 07-24-2003 05:11 PM

I removed the duplicate entry, but still got both the error messages that I quoted in my first post. I didnt do that console thing, because I didnt think there was much point since I got errors, and when I rebooted, linux was still the default.

What else should I try?

Proud 07-24-2003 05:17 PM

Lilo wont be updated until you run lilo, or better lilo -v -v. Just change the default line in /etc/lilo.conf, save the file, and run that command.
Or use the nice Mandrake editor. :)

DamianY2J 07-24-2003 05:22 PM

So, you want me to open the Console and type /sbin/lilo -v -v

Is that right (excuse me for being a very slow Linux learner!)?

Btw, whats this Mandrake editor?

Skyline 07-24-2003 05:27 PM

Hi Damian

I wouldnt run /sbin/lilo yet as you haven't been able to save lilo.conf correctly yet.

Do you hasve the powerpack edition of Mandrake - which edition have you got.

DamianY2J 07-24-2003 05:30 PM

Yeah, I've got the PowerPack edition. I keep getting the Configuration is NOT ok error whenever I try to click Apply to any changes I make.

It doesnt seem to make much difference, as Linux and Windows both load correctly, but I would like to make Windows the default.

I am also a little confused as to what failsafe and Linux Enterpris are? I had something called Floppy on the list as well, but deleted it, which I'm guessing was the wrong thing to do now!

Proud 07-24-2003 05:31 PM

Well, try posting the contents of /etc/lilo.conf here first, as that's what KDE's editor is trying to alter.

The Mandrake Boot option editor is explained in my post above. :)

DamianY2J 07-24-2003 05:36 PM

I am going to Start Applications --> Configuration --> Control Center --> System --> Boot Manager (LILO), and changing the things in there.

Do you want me to post the contents of the Expert tab on that, or the contents of another file?

Proud 07-24-2003 05:42 PM

I'd rather the raw file, instead of KDE's possibly munged output. Simply start kwrite or your fav text editor and open /etc/lilo.conf. You may need to use the KDE launcher/Run... entry to start the app as root to access that file, depending on your security settings.

Failsafe is like windows safe mode, only this is actually useful and doesnt break other settings. Floppy was to boot off a floppy drive containing a boot disk. Enterprise is probably a hardened server variation of the kernel to deal with higher load and attacks in the business environment. :)

Skyline 07-24-2003 05:46 PM

Hi Damian

The Expert tab is your LILO.CONF file - and you've already posted it.

As I said in my first post the default = directive already correctly points to Windows.

The problem youve got is trying to save it correctly first before you run the map installer /sbin/lilo

The last line of the error mesage talks about the kernel not supporting inital ram disks? - strange

Proud 07-24-2003 05:49 PM

I think this may be KDE's editor's fault, so running /sbin/lilo -v -v will report specifics about any problems when trying to update lilo. It may be the quickest way to solve the problem.
Editing lilo.conf by hand isnt hard, so we can skip kde's editor and just use a text editor. :)

Edit: scratch that, I think the symlinks for vmlinuz and initrd.img are squiffy, maybe because of multiple kernel source installs or repeated kernel install-uninstall?

DamianY2J 07-24-2003 05:55 PM

I found the etc/lilo.conf file but couldnt open it in anything - KWord wouldnt let me, neither would KJots, and attempting to save it to floppy disk to open in Notepad in Windows didnt work as it said "Cannot read from /etc/lilo.conf".

That RAM error is strange - maybe its because I have 1024Mb of RAM - I know Windows has initial problems working with so much.

Anyway, I am having to post this in Windows, close down, go into Linux, etc, etc, so sorry for a long time between posts. Shall I run that console command and see what happens, or has anyone got any other ideas?

Could someone do it on their own PC and copy and paste me the contents of lilo.conf, or wouldnt that work?

DamianY2J 07-24-2003 05:58 PM

Well, I did install and then reinstalled over it (well, I thought I did), because the first time I did it, it didnt work at all.

The first time I installed it, i deleted everything in the list except windows and linux, and renamed linux to mandrakelinux, and window to windowsxp.

Then, on bootup, when I selected mandrakelinux, it said "Loading mandrakelinux....." but then didnt do anything, ever. I had to keep restarting the PC. Windows loaded fine though.

Maybe I reinstalled wrong - I do know I got confused at the partition questions it asked me, and just kept clicking Next and accepting their default values - maybe I agreed to a wrong value.

What can I do?

Skyline 07-24-2003 06:03 PM

Hi Damian

Go to Console

type

SU
Then type your Root password

then type

KEDIT /etc/lilo.conf

then scan down to the botom

Definately make sure those 2 duplicate entries are not there - they shouldn't be - they dont refer to anything - the image = lines dont even specify a Boot image so get rid of them.


image="/dev/hda1"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"

image="/dev/hda1"
root="/dev/hda5"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"

Make sure they're not there and save your KEDIT file

then as root user again try running

/sbin/lilo

DamianY2J 07-24-2003 06:17 PM

Thanks for that. It's late now, so I'll try that tomorrow morning, and post the results then.

DamianY2J 07-25-2003 05:16 AM

I did as you said, and deleted one of the duplicate entries, and saved it, and typed /sbin/lilo.conf, and I got the following message:

ADDED linux
ADDED linux-enterpris
ADDED failsafe
ADDED windows*
FATAL: Kernal doesn't support initial RAM disks

Anyway, I closed Console down and rebooted, and linux was still the default. What went wrong?

Skyline 07-25-2003 07:34 AM

Hi Damian

I'd delete both those duplicate entries - taken at face value they dont do anything and shouldn't be there - so delete both of them

Also when you run the map installer you type

/sbin/lilo not /sbin/lilo.conf

try this properly -

Can you post your lilo.conf file or your Expert tab again - I'd like to see exactly what youve deleted at this point and whats left in there.

DamianY2J 07-25-2003 11:45 AM

It now works :-)

I deleted both duplicate entries, and then typed /sbin/lilo and now everything works fine, with Windows as the default :-)

Since you have been so good at helping me solve this problem, I don't want to push my luck, but I do have 2 other Linux queries at this stage - hope you don't mind me posting them in here:

1. What are failsafe and linux-enterpris, and can they safely be deleted from the list?

2. Sometimes, when I click Logout Damian, it brings up a box with Reboot or Halt options, and sometimes it brings up a box with the dragon in, and 3 options (log out, shut down or reboot, I think). How can I make it so that the dragon box always comes up, and not just sometimes?

Skyline 07-25-2003 12:21 PM

Hi Damian

Personaly - I would just leave the entries for Failsafe and Enterprise alone.

Failsafe mode just enables you to go into Graphical,text,maintennance modes, check bootlogs etc - I would suggest you just leave it - Enterprise presumably is a more enhanced kernel/version offered on the Powerpack edition.
Again - just leave it now youve got your computer sorted.

If you really do want to delete these entries just go into your expert tab and delete the whole entry for Failsafe and the whole entry for Enterprise - then just click on apply.

Then go to a Console and

SU
root password

/sbin/lilo

I would just leave them alone for now though.

DamianY2J 07-25-2003 12:35 PM

OK, thanks :-)


All times are GMT -5. The time now is 04:04 PM.