LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   HELP!! Tried to install linux (YOPER) with winxp and now winxp is unmountable! (https://www.linuxquestions.org/questions/linux-newbie-8/help-tried-to-install-linux-yoper-with-winxp-and-now-winxp-is-unmountable-277450/)

buffpandabear 01-13-2005 04:42 PM

HELP!! Tried to install linux (YOPER) with winxp and now winxp is unmountable!
 
Hi everyone. this is my first type ever using linux, and I need some serious help. this is what i did.
i used partition magic to resize my 20g hard drive in my notebook (which had winxp on it) so that i would have a 50mb partition at the beginning of the disk (which i thought would be the boot), a 12gb containing all of my current data and winxp, a 5gb for root and a 200mb swap. i also discovered incidentally that there is a hidden partition on my thinkpad which is 1.2gb.
so it ended up being
boot - 50mb
winxp partition (ntfs) - 12gb
linux partition - 5gb
swap - 200mb
hidden partition (fat32) - 1.5gb

the resizing went without hitch and i rebooted into windows xp fine.

then i put in the yopers cd, booted off of it, and went into qtparted. well, i hadn't formatted the newly made partitions yet, so i went ahead and made my boot and linux and swap into ext3 (i didn't yet know that swap was supposed to linux-swap). needless to say i ran into problems. so i emptied those partitions and tried to re-boot into windows. it didn't work, and i started to panic.
so i made all the partitions into reiserfs and this time made the swap into linux-swap. when the installer asked for what to boot with, i chose lilo. when it rebooted, it didn't work, so i used the yoper cd to reboot again, but when i got into qtparted, it showed the hda1 filesystem as "UNKNOWN". now i really started to panic.
this time when i installed, i chose grub, and when it restarted, yoper installed fine.

i tried to mount my windows partition through
"mount -t ntfs /dev/hda1 /mnt/c"
but it says "wrong fs type, bad option, bad superblock on /dev/hda1, or too many mounted filesystems". I want to save my data, but I can't seem to even access or mount my windows partition! help!!
ideally, i would like to still be able to boot off of windows, but if i can just access the files, that would be good enough for me.
thanks for all your help,
buffpandabear

buffpandabear 01-13-2005 04:43 PM

oh yeah, but when i use cfdsk instead of qtparted, it says that the hda1 partition is ntfs, not "unknown" like qtparted says. i don't know what this means.
help this frazzled newbie.

mjolnir 01-13-2005 07:18 PM

Don't panic, your data is probably still there. This link has a bunch of info with folks in the same position. A number of the "fixes" involve booting with an XP or WIN98 cd and running fix /mbr. Hope you find an answer.

http://www.linuxquestions.org/questi...der=descending


All times are GMT -5. The time now is 09:36 AM.