LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Help the dumb girl install her drivers (https://www.linuxquestions.org/questions/linux-newbie-8/help-the-dumb-girl-install-her-drivers-95546/)

hindenbergbaby 09-22-2003 01:01 PM

SOLVED! (embarrassed) Help the dumb girl install her drivers
 
Okay, I'm proud of how far I got... I FOUND my Linux sound card drivers on my mobo CD (there's a novel place to look). I managed to unzip, configure and install them. My verbose start up even recognizes and configures my sound card, which it didn't before.

But... I am using SuSE 8.2. It has all the old ALSA snd files. Somehow, I am supposed to get rid of them to install the new ones. They said use utils/module-tools or some such file names to "quickly and easily" get rid of them. I opened that file, and saw a script. Okay. This is where I get lost. What do I do with the script? Do I type it in bash? Can I copy it from the disk and link to it? And the first line, the command line, is # (some weird little stick symbol) /bin/bash. What IS that little stick symbol anyway?

Second problem: I need to edit /etc/modules.conf. I have the text I need to edit it with. Does it matter where I put the text? I figured I'd put it in the section where the sound stuff is, but does it matter if it's at the beginning or end? Then, how do I save it? I searched through all the help I could find, and couldn't find ANYTHING on how you just save and exit the silly VIM editor. I feel so stupid.

My knowledge of Linux commands is sorely lacking, even with the help of the Cookbook and O'Reilly. Go easy on me, soldiers.

shoe

DrOzz 09-22-2003 01:09 PM

well that stick symbol is the exclamation mark :D shift of the 1 key ... and typically you run a script by typing ./nameoffile ..
it won't matter for your case where to insert the module line in the file, you can just append it to the end of the file if you wish, but i would assume if you are adding stuff for your sound, then i would just assume that the stuff in there already has to go, but your the one with the documentation in front of you, so i'll leave that one with you :D
as of vi, use your arrow keys to get to the spot where you want to edit and hit :
Code:

i
to start inserting whatever it is
then when your done press :
Code:

ESC
and then to save you'll hit ::
Code:

shift ZZ
hope this gives ya a head start :cool:

/bin/bash 09-22-2003 03:07 PM

Why would you get rid of sound modules that work? If they work then leave them there. If you have a module you want to try then install it, edit /etc/modules.conf and comment the lines for the "old alsa drivers", comment means to put a # at the beginning of the line. Then insert the line for the new module.

This way if it doesn't work all you have to do to get back to where you started is to un-comment the old alsa lines and remove the new lines.

hindenbergbaby 09-22-2003 06:58 PM

Thanks... I'll give that a go!

shoe

hindenbergbaby 09-23-2003 09:07 AM

Okay, I tried that, and still no luck... I also ran the script, but for some reason I keep getting the same error message that there are old snd files. I think, though, that they aren't really the things gumming up the works. I *did* notice, however, in my travels in /etc/modules.conf that there was this section that said this:

alias char-major-14 off
alias sound off
alias midi off

It also said that YaST2 should change them automatically. Well, I have my doubts about YaST sometimes... Think this could be causing the problem? Should I give it a try? My alsa mixer is unmuted and turned all the way up, my cd's poised in the drive, and I'm DYING to hear what SuSE's test sound is! (I hope it's Torvalds saying "Linux!")

thanks again
shoe

EDIT: This proves what a hopeless newb I am... Whereas my speaker settings worked FINE in Windows, for some reason, Linux wanted them in the OTHER plug. I don't know what made me think of it, but at least now I'm getting system sounds (still working on the CD ROM).

Oh yeah, SuSE's test sound wasn't nearly as exciting as I thought it would be...

I am SO embarrassed. Thanks to all you who helped. Now I have the latest drivers, anyway.


All times are GMT -5. The time now is 02:41 PM.