-   Linux - Newbie (
-   -   Help on installing a HP LaserJet 1018 in Linux Mint9 Long term release (

stegmann 03-28-2012 04:17 AM

Help on installing a HP LaserJet 1018 in Linux Mint9 Long term release
When I plug my printer in I get a small window in the top right hand corner of the screen stating: "HP Laser Jet 1018 requires a proprietary plug in, downloading and installing ..." but nothing happens afterwards.
I have run hp-setup but get an error message: HP Linux Imaging and Printing System (ver. 3.10.2)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: Qt/PyQt 4 initialization failed.
error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode

After which I ran hp-check which then did a whole lot of downloads and updates but the printer still doesn't work.

Please advise ...

tronayne 03-28-2012 06:45 AM

You may want to upgrade HPLIP to 3.12.2 (the current version) at

You need to execute hp-setup in a terminal window with X running (and, of course, you need to have Qt and Python libraries installed on your system, check and make sure that they are).

Hope this helps some.

stegmann 03-28-2012 06:57 AM

Thanks ...
Thanks Tronayne, will try ...can I not perhaps do it via the terminal directly like I upgraded Thunderbird?
I used the sudo apt add; get and install commands.

stegmann 03-28-2012 06:59 AM

I have also downloaded the ollowing file: but do not know how to run the shell script file?
Sorry man, still learning but rather this than being a Microsoft slave for the rest of my life!

tronayne 03-28-2012 08:10 AM

I'm not an Ubuntu user, so I don't really know how you would upgrade your software on that platform -- this is where "upgrade" replaces your existing out-of-date software installation.

The software you did download, a "dot-run" file, can be executed with

su -  or  sudo
<enter root password if prompted>
sh ./

which may -- may! -- upgrade (actually, I suspect that it will, but I don't know diddly about the strange and wondrous workings of Ubuntu).

... and, I know even less about Mint (looking at the Ubuntu logo on your posts, eh?). Suspect, though, that you can do the above.

Generally, HP provides full support for every product they make in Linux so doing the above ought to (but may not!) get you where you want to go. You might want to check with folks that are familiar with Ubuntu before you do, but, on the other hand, what the heck. Up to you. I would also think that the current version would be available at Ubuntu's upgrade site (Yum or something like that? Dunno).

When you do get 3.12.2 installed (or upgraded), you can run hp-setup as "you" (you will be prompted to enter the root password as you go) and hp-setup will make all the connections you need in CUPS for you.

Hope this helps some.

jhunt29 03-30-2012 08:23 AM

Ubuntu is v. close to Debian, so I am guessing that the same problems currently apply. The distro includes hplip, and hplip-gui ( install from synaptic or apt-get) BUT: depending on how new your printer is, they may be out of date. (This is an inevitably common problem, since printer models change every 6 months) In which case, you may need to download hplip directly from and install it.
Do not download and install unless you truly need to. As a possible alternative, try to install your printer through CUPS using the PPD file from an older, related printer model. [If you do not understand CUPS, spend your time there. It will have better yield in the long term, and actually you want both working in tandem for a happy networked printing environment]
Building hplip from source unleashes a world of pain. The install has a number of dependencies, most of which can be satisfied from the repositories, but are not necessarily intuitive (The hplip install prompts for dependency installs, but the repository packages have slightly different names. I ended up installing a lot of development packages, some of which I did not need)

At the end of this:It still did not work! This is the well known ( but poorly documented) "foomatic-rip-hplip" gotcha. "Foomatic-rip-hplip not installed". For reasons that escape me, foomatic-rip-hplip does not seem to exist. But "foomatic-rip" does. and works. There are two ways to bypass this. Ubunutu engineers built hplip for the ubuntu ( and debian) distros, with the foomatic-rip-hplip dependency changed to foomatic-rip. This is why their distro works. But now you have escaped that cage, and you are on you own.

Alternately (and less elegantly):
cd /usr/lib/cups/filter
ln -s foomatic-rip foomatic-rip-hplip

Also note that in mixing the repository ( pre built ) and source versions, the system got confused. If your are going to take the plunge and build, first fully uninstall the repository packages (uninstall hplip and hplip-gui via synaptic or apt-get) then build ("sh ./ " and wait for complaints) They can be easily reinstalled if needed.

This works in the current debian distro (squeeze: 6.04) anyway.

All times are GMT -5. The time now is 12:43 PM.