-   Linux - Newbie (
-   -   help! my brain is melting! (

briancof 11-20-2001 01:35 PM

help! my brain is melting!
I'm still trying to get my modem working with linux (still have to boot windoze to post here). I've d/led the LTmodem driver and printed off the installation howto for it.
The howto talks about kernel headers and says they should be found at /usr/src/linux2.x.x which in my case is a redhat directory. Are the headers named as such or are there particular files/types I should be looking for?
And is there an easier way of doing this? Is there a driver directory I can just copy my d/led driver into? All this talk of compiling and building modules makes me want to run back to windoze and its one click and its installed user friendliness!

isajera 11-20-2001 03:55 PM

ok... in your /usr/src directory... there should be a few things:

/usr/src/linux-2.4.? - this is the real directory with all the kernel sources in it. if you don't have this directory, you need to install it from the install discs.
/usr/src/linux - this is a symbolic link that points to the current kernel installation. it's there in case you want to use different kernel versions, which i'm guessing you won't. so, suffice to say that it points to the other directory.

if you have these directories, then you can download the ltmodem file, and untar it using

tar -xzvf ltmodem-???.tar.gz

the tar.gz file isn't the driver itself... you need to go into the directory it creates, and follow the README directions.

taz.devil 11-20-2001 03:56 PM

Not sure what the howto says, but here is a page, unless you already have it, that has some detailed Lucent LT installation help. Most winmodems don't have a chance in Linux altogether, but it's possible. Check here and see if it helps any. It depends on what kernel you are using also. You can tell by after booting, the console will say something like Running Kernel 2.x.x. Hope this gave you some help. I'm not familiar with red hat so this is all i found.

briancof 11-26-2001 12:01 AM

Okay, so I found an easier way around the modem problem (still on windoze here though). I d/led a binary driver for my kernel, mounted it, clicked on the icon and it seems to have installed itself. I went through the dialup configuration process again and when I tried to debug the connection it initialised the modem and it seemed to be trying to log into my isp. It tried a few times without success so I stopped it to investigate.
My modem is connected to com2 under windows which should be ttys1 under linux (right?) except running the win/linmodem driver it should now be ttylt1 which is how I've configured the modem in the dialup configuration. Now when I try to connect it tells me the device is unavailable or in use.
I had a look in the /dev directory and there is an entry for ttylt0 but none for ttylt1 which I should be using. With my extremely limited knowledge I have tried to rename ttylt0 to ttylt1 (with the mv command) but it wouldn't let me. I tried to create a symlink from 0 to 1 but that wouldn't work either.
Is there an easy solution to this or do I go ahead and reinstall redhat and start again from scratch?

Dayewalker 11-26-2001 12:43 AM

Just out of curiosity, have you tried using ttyl0 just for the sake of trying it? It probably won't work but it's worth a shot. :)

briancof 11-26-2001 04:35 PM

Yeah! Tried that...
...when I try to connect then it tells me that the device is unavailable or in use.

All times are GMT -5. The time now is 06:12 PM.