LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Help Me Please!!!!!! VLC Related Issue (https://www.linuxquestions.org/questions/linux-newbie-8/help-me-please-vlc-related-issue-599226/)

Newbie6 11-13-2007 01:46 AM

Help Me Please!!!!!! VLC Related Issue
 
Hi there Folks

Please if u can help me out this would be very much appreciated, im on the verge of pulling out my hair and running to the hills!!!
i recently updated certain packages in Yast (Im running 10.2 suse) and got Amarok running, but now my VLC does not want to work (VLC is most valuable to me) i get the following error: error while loading shared libraries: libdts.so.0: cannot open shared object file: No such file or directory. Now i have tried to see what i can do and there has been similar experiences to mine, stating that i should downgrade to some Packman version... where, how???


Now folks, im a newbie :D i need some help as to where, what and how to do what i must do to correct this PLEEEAAASE. I cannot go another day without my precious vlc running.

Thanks for all your trouble.
Have a lovely day further
Newbie6

jschiwal 11-13-2007 03:12 AM

You can add the repositories in YaST2 -> Installation Sources

Here is the Videolan repository that I am using (although I edited 10.3 -> 10.2)

Protocol
HTTP

Server Name
download.videolan.org

Directory on Server
/pub/videolan/vlc/SuSE/10.2/

For the Packman repository:
Protocol
HTTP

Server Name
ftp.skynet.be

Directory on Server
/pub/packman/suse/10.2

These sites were recommended by a Community Repository Module in openSUSE 10.3's YaST2 -> Software Management. A nice feature they added. When I tried to install vlc and others using the repo's I had used before (but changed to 10.3) I got conflicts as well. I removed them and added these two and then didn't have as man problems, including being able to install "transcode" which tends to be the most difficult.

I just checked for libdts on my system. I have a static library /usr/lib64/libdts.a and libdts plugins in /usr/lib64/vlc/.

Here is my vlc version:
vlc --version
VLC media player 0.8.6c Janus
VLC version 0.8.6c Janus
Compiled by abuild@messiah.

My libdts.a file is supplied by the libdca-devel package.

If you go to http://rpm.pbone.net, you can see if you can find a SuSE10.2 vlc rpm package. The page where you can download it will list the prerequisites of the package. You can click on the libdts.so.0 link to go to the package you need.


Good Luck!


All times are GMT -5. The time now is 09:35 PM.