LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Help Me! (https://www.linuxquestions.org/questions/linux-newbie-8/help-me-509907/)

pm010537 12-12-2006 11:43 PM

Help Me!
 
I have installed CentOS 4.4 on dell 2850. I have been logged in as root; the prompt was "[root@localhost/]#" . I rebooted the server and the prompt got changed to "[root@kilimanjaro/] #". All I was trying to do was install drivers for one of the serial port and I did access ftp sites for that. so the change of prompt has something to do with that? Is something malicious going on with my dell server?

I am a newbie to LINUX and hence was worried at this unusual change.

All your help is greatly appreciated

Thanks

matthewg42 12-12-2006 11:47 PM

Please help us help you - use better thread subjects.

Without more detail about what you did it's hard to say why this changed. Did you follow some instructions to install these "drivers"? Please describe exactly what you did.

btmiller 12-12-2006 11:52 PM

Generally on CentOS the word after the "@" sign in the prompt is the host name of the machine. Is the host name supposed to be kilimanjaro? Did you change any network settings or anything like that? Like matthewg42 said, more info on what exactly you did is necessary.

pm010537 12-13-2006 02:09 AM

Sorry about the confusing subject!
 
I have been using the machine for last couple of days and it was working fine meaning had the prompt [root@localhost/]. No; I have not changed the name of the machine. I did not do anything else other then trying to install the drivers today; here is a brief description of what I did:

1)drivers are for RocketPort card (RocketPort uPCI) from Comtrol.
2)copied the pkgname.tar.gz to /usr/src from the installation CD
3)untar the file using "tar xzvf pkgname.tar.gz"
4)it created a folder by the name comtrol under /usr/src
5)cd comtrol
6)make clean
7)make
8)after executing make I got errors specific to drivers nothing else.
9)still went ahead and tried installing the drivers by using "make install"
10)was not successful.
11)removed everything using the "rm -r comtrol" and repeated steps 1-10 for for different versions of the driver.

The process that I followed was as per the manual from comtrol.

At one point I noticed that I was not able to get outside of my subnet; I tried to reconfigure the ethernet cards but was not successful so decided to reboot the server; when I issued the command reboot every thing was OK except "irq balance" failed.

It booted up and when I opened the terminal the prompt was changed to [root@kilimanjaro/]. Nothing else seemed to be changed; and this time even the network was up after reconfiguring the card. I again rebooted the server after 15 minutes or so and the prompt was changed back to [root@localhost/]. That is when I felt like something is wrong.

I hope I was able to give more details this time.

Thanks

timmeke 12-13-2006 06:23 AM

Quote:

I tried to reconfigure the ethernet cards
This seems a likely suspect to me...
Quote:

... the network was up after reconfiguring the card ...
... after 15 minutes or so and the prompt was changed back ...
Most likely, the reconfiguration caused the prompt to revert back.

Please also post the outputs of:
Code:

hostname
ifconfig

and give the details of your network card configuration/reconfiguration steps.

chrism01 12-13-2006 07:14 PM

also,
cat /etc/hosts

wmakowski 12-13-2006 08:53 PM

Good advice from both timmeke and chrism01. That will help us to see what is causing the change to your hostname. Another file that could have been written to is in /etc/sysconfig/networking/devices. Chances are you're using ethernet and posting the contents of ifcfg-eth0 will give us some additional information to help.

Here is my guess on what happened. Normally when installing a package from source you need to use the ./configure before performing make. This should have been done between steps 5 and 6. Review the README or INSTALL instructions in the comtrol directory. My guess is that there was an old configuration file present. When you ran the make and make install you picked up the old settings and it rewrote a file with what the configuration file from the package. Chances are we will need to make changes to your system before you can run configure otherwise you will get the same name again.

Bill

pm010537 12-14-2006 12:26 PM

Thanks for the responses!
 
I did try to do some troubleshoot and with the help of all your repsonses what I observed was it gets the different host name for a DNS server. That is what I am assuming. I have configured DNS entries and it then automatical goes to a DNS search path and gets a different host name from there.

When I cleared that DNS search path it gave me the default localhost. Here are the ifcfg-eth0 details:

DEVICE=eth0
BOOTPROTO=none
BROADCAST=X.X.X.X
HWADDR=00:11:43:30:BE:0E
IPADDR=X.X.X.X
NETMASK=255.255.255.128
NETWORK=X.X.X.X
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes
GATEWAY=X.X.X.X

Thanks
pm010537


All times are GMT -5. The time now is 05:11 AM.