LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-29-2004, 07:12 PM   #1
slimgarfield
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Rep: Reputation: 0
help installing gaim


I am a linux (i wonder if that actually worked) and my friend reccomended this site. I have suse 9.0 professional and it came with came with gaim version 0.67. But that version dosent support file transfers so i want the new version. I just learned how to use source (ive never gotten it to work but i at least know how) so i would like to use that to install it. so i downloaded gaim-1.0.0.tar.bz2 and did ./configure and it checked alot of stuff but then it came up with an error:
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.5.0)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at gtk.org/
so i tried to delete glib through yast.... not a very good idea cause nothing worked and i couldnt even try to install glib again. at least yast worked, so then i reinstalled it but i still get the same error. i have no idea what PKG_CONFIG_PATH means or where it is or where to change it or anything. it also said something about headers but i couldn't find it on the site.

o btw i have 2 other things
1) should i install the new kernel? i mean i cant even install gaim....
2) friend said that yast sucks and that i should get kpackage is he rite? cause yast dosn't always install the rpm... and if i should get kpackage where can i get it and is it this hard to install?

this linux needs help!
 
Old 09-29-2004, 07:23 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,578

Rep: Reputation: 191Reputation: 191
The orginal error was probably because of lack of glib-devel package. *devel packages are needed when you compile a program using a library (glib is a library). Now you need to install glib again (it's an important package). The most low-level (using rpms) way to install and RPM is to use 'rpm' command. Example
rpm -i packagename
Find glib package on your installation cd or download it etc and use the command above to install it. Then you should be able to use yast to install glib-devel.

You don't need to install a new kernel, definitely.
Is kpackage better than yast? Not sure... Don't use SuSE
 
Old 09-29-2004, 07:41 PM   #3
slimgarfield
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
ok so i did what you said and downoladed glib-devel-1.2.6-2.armv4l.rpm and installed it with yast. it worked great but then i went back it install gaim and i got the porblem:



checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.5.0)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.
 
Old 09-29-2004, 08:15 PM   #4
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,098

Rep: Reputation: 54
you might want to check out apt-get...

http://linux01.gwdg.de/apt4rpm/

it's like Yast...only better, i think.
 
Old 09-29-2004, 08:39 PM   #5
slimgarfield
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
ok i went to that site but where do i actually download it?
also what do you mean be suse sucks i think its pretty good ut i havnt tried any others but i have a laptop that im thinking of installing mandrake or slackware... but what is the difference between buying it and downloading it for free?
 
Old 09-29-2004, 10:55 PM   #6
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,098

Rep: Reputation: 54
who said suse sucks? i love suse...it's great, stable..easy to use...my distro of choice, actually, although slack 10 is pretty sweet too.

anyways...if you read on
http://linux01.gwdg.de/apt4rpm/
under software installation, it gives you the instructions and the links for installing and configuring it...
 
Old 09-30-2004, 11:13 AM   #7
Celettu
Member
 
Registered: Jan 2004
Distribution: VectorLinux 5.0 SOHO
Posts: 90

Rep: Reputation: 15
http://linux01.gwdg.de/~pbleser/rpm-...etwork%2Fgaim/

You don't need apt, these packages are compiled for Suse 9.1

Just be careful. You need 5 of them before you can work with gaim.
 
Old 10-02-2004, 01:10 PM   #8
slimgarfield
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
ok so i think i installed apt. But whenever i try to do the apt-get it gives the error:

john@linux:~> apt-get update
apt-get: relocation error: apt-get: undefined symbol: _ZN3Lua15SetCacheControlEP15LuaCacheControl


i have no idea what the means and im pretty sure i installed it correctly...

also i went to that one page that Celettu mentined but some of the rpms died halfway through... like i would click it then input password then push accept and then it died... is that my fault or the rpm's?
 
Old 10-02-2004, 03:10 PM   #9
slimgarfield
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
actually i did it again... and i did install it wrong... so i did the update thing but what does that even do? cause i still cant install gaim
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing GAIM vital_101 Mandriva 3 10-22-2005 07:27 AM
Installing GAIM vwal_13 Slackware 3 04-19-2004 08:53 AM
Problem Installing/Upgrading Gaim 0.60 or Gaim 0.71 AskMe Linux - Newbie 1 10-25-2003 09:00 PM
Installing Gaim Niellus Linux - Newbie 8 08-05-2003 05:42 PM
Installing Gaim rgarg Linux - Software 3 07-02-2003 05:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration