LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   help installing gaim (https://www.linuxquestions.org/questions/linux-newbie-8/help-installing-gaim-236839/)

slimgarfield 09-29-2004 06:12 PM

help installing gaim
 
I am a linux :newbie: (i wonder if that actually worked) and my friend reccomended this site. I have suse 9.0 professional and it came with came with gaim version 0.67. But that version dosent support file transfers so i want the new version. I just learned how to use source (ive never gotten it to work but i at least know how) so i would like to use that to install it. so i downloaded gaim-1.0.0.tar.bz2 and did ./configure and it checked alot of stuff but then it came up with an error:
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.5.0)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at gtk.org/
so i tried to delete glib through yast.... not a very good idea cause nothing worked and i couldnt even try to install glib again. at least yast worked, so then i reinstalled it but i still get the same error. i have no idea what PKG_CONFIG_PATH means or where it is or where to change it or anything. it also said something about headers but i couldn't find it on the site.

o btw i have 2 other things
1) should i install the new kernel? i mean i cant even install gaim....
2) friend said that yast sucks and that i should get kpackage is he rite? cause yast dosn't always install the rpm... and if i should get kpackage where can i get it and is it this hard to install?

this linux :newbie: needs help!

Mara 09-29-2004 06:23 PM

The orginal error was probably because of lack of glib-devel package. *devel packages are needed when you compile a program using a library (glib is a library). Now you need to install glib again (it's an important package). The most low-level (using rpms) way to install and RPM is to use 'rpm' command. Example
rpm -i packagename
Find glib package on your installation cd or download it etc and use the command above to install it. Then you should be able to use yast to install glib-devel.

You don't need to install a new kernel, definitely.
Is kpackage better than yast? Not sure... Don't use SuSE :)

slimgarfield 09-29-2004 06:41 PM

ok so i did what you said and downoladed glib-devel-1.2.6-2.armv4l.rpm and installed it with yast. it worked great but then i went back it install gaim and i got the porblem:



checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.5.0)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.

detpenguin 09-29-2004 07:15 PM

you might want to check out apt-get...

http://linux01.gwdg.de/apt4rpm/

it's like Yast...only better, i think.

slimgarfield 09-29-2004 07:39 PM

ok i went to that site but where do i actually download it?
also what do you mean be suse sucks i think its pretty good ut i havnt tried any others but i have a laptop that im thinking of installing mandrake or slackware... but what is the difference between buying it and downloading it for free?

detpenguin 09-29-2004 09:55 PM

who said suse sucks? i love suse...it's great, stable..easy to use...my distro of choice, actually, although slack 10 is pretty sweet too.

anyways...if you read on
http://linux01.gwdg.de/apt4rpm/
under software installation, it gives you the instructions and the links for installing and configuring it...

Celettu 09-30-2004 10:13 AM

http://linux01.gwdg.de/~pbleser/rpm-...etwork%2Fgaim/

You don't need apt, these packages are compiled for Suse 9.1

Just be careful. You need 5 of them before you can work with gaim.

slimgarfield 10-02-2004 12:10 PM

ok so i think i installed apt. But whenever i try to do the apt-get it gives the error:

john@linux:~> apt-get update
apt-get: relocation error: apt-get: undefined symbol: _ZN3Lua15SetCacheControlEP15LuaCacheControl


i have no idea what the means and im pretty sure i installed it correctly...

also i went to that one page that Celettu mentined but some of the rpms died halfway through... like i would click it then input password then push accept and then it died... is that my fault or the rpm's?

slimgarfield 10-02-2004 02:10 PM

actually i did it again... and i did install it wrong... so i did the update thing but what does that even do? cause i still cant install gaim


All times are GMT -5. The time now is 12:20 PM.