Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 02-27-2016, 11:31 AM   #1
LQ Newbie
Registered: Nov 2015
Posts: 7

Rep: Reputation: Disabled
Help! how to access Insatlled Linux Mint filesystem after restoring computer defaults


I have Linux Mint 17.2 installed on a Dell Latitude 3340.
In a moment of sheer stupidity I restored the computer factory defaults via the BIOS.
When I try to boot I first get in Invalid Partition Table! error message.
When I try to boot using my boot usb I get, among other, the option
Start Linux Mint 17.2 64-Bit. When I try to that I get the following error message:
"Could not find the ISO ${iso_path}
This could also happen if the file system is not clean because of an operating system crash, an interrupted boot process, an improper shutdown, or unplugging of a removable device without first unmounting or ejecting it. To fix this, simply reboot into Windows, let it fully start, log in, run 'chkdsk /r', then gracefully shut down and reboot back into Windows. After this you should be able to reboot again and resume the installation."

The boot menu also gives me the option: "Start Linux Mint" When I do this I can get into the Mint GUI and have an option to install Linux Mint.
When I try to I get to install I get to the install type screen when I'm told That the computer currently has Linux Mint Rafela (17.2) on it.
So I infer that previously installed Mint is still on the computer somewhere.
I can also see via the USB boot that the filesystem that I usually boot into if still there.
How can I access it?

If it is of any relevance, the output of parted is below.

Any help will be most appreciated
mint@mint ~ $ sudo parted -l
Model: ATA KINGSTON SV300S3 (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End    Size    File system     Name  Flags
 1      1049kB  538MB  537MB   fat32                 boot
 2      538MB   112GB  111GB   ext4
 3      112GB   120GB  8507MB  linux-swap(v1)

Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sdb: 8003MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      16.4kB  8003MB  8003MB  primary  fat32        boot
Old 02-27-2016, 01:27 PM   #2
Registered: Dec 2010
Location: /home
Distribution: Ubuntu LTS, Slackware stable
Posts: 57

Rep: Reputation: 33
Try to repair grub of linux mint using chroot. the following link worked for me, so give it a shot .
Old 03-04-2016, 09:11 AM   #3
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 730

Rep: Reputation: 219Reputation: 219Reputation: 219
I have used a cool utility called Boot Repair Disk (a live, bootable USB or CD tool) to address similar issues. It is able restore MBRs, detect and repair boot config files (I've used it with both GRUB and Syslinux). I usually pick up this tool through Pendrivelinux, using their YUMI solution, but you can probably easily find it online.


1 members found this post helpful.
Old 03-04-2016, 09:36 AM   #4
Senior Member
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,665

Rep: Reputation: 486Reputation: 486Reputation: 486Reputation: 486Reputation: 486
When you installed Linux Mint was your BIOS set to "Legacy" or "UEFI"? Whichever is On upon restoring defaults try to select the other. Configure it from the BIOS. Reboot. The Grub loader should be able to locate the drive pointed to.
1 members found this post helpful.
Old 03-04-2016, 10:29 AM   #5
LQ Newbie
Registered: Nov 2015
Posts: 7

Original Poster
Rep: Reputation: Disabled
@Rickkkk: Thanks, I used boot-repair, and it worked great.
In the interest of completeness: In my first attempt to use boot-repair I got an error message becuase I was booting in legacy mode.
To resolve that I temporarily switched to EFI mode via BIOS, ran boot-repair, then re-booted and switched back to legacy mode. Worked like magic.
Attached Thumbnails
Click image for larger version

Name:	Screenshot.png
Views:	19
Size:	30.0 KB
ID:	21044  
1 members found this post helpful.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to transfer from old computer of Windows 7 & Linux Mint files to new computer Socrates2 Linux Mint 12 07-02-2014 01:20 PM
restoring defaults in seamonkey tigertim71 Puppy 10 08-16-2009 06:34 PM
Restoring everything to their original defaults. LinuxPadawan Fedora 1 03-15-2005 03:39 AM
Restoring to defaults Superganja23 Red Hat 7 11-14-2004 02:23 PM
Restoring ALSA mixer defaults in Gentoo? Seph64 Linux - Distributions 2 01-22-2004 12:01 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:22 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration