LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Help...How do i go about installing stuff (https://www.linuxquestions.org/questions/linux-newbie-8/help-how-do-i-go-about-installing-stuff-74870/)

phatish 07-22-2003 11:36 AM

Help...How do i go about installing stuff
 
i'm using slackware 9. i downloaded a file divx4linux-std-20030428.tar.gz off the net. i have been using linux for 3 days only.. just could not seem to get the stuff to install.. maybe i just don't know how... i know the file have been 'tarballed' the most i know is how to untarball it...

Thanks for all your kind help

aaa 07-22-2003 11:42 AM

Did you try Pkgtool or installpkg?

phatish 07-22-2003 11:57 AM

where are those programes located? can't seem to find them... i only can find kpackage... thats all

aaa 07-22-2003 11:59 AM

Type them in Konsole.

aaa 07-22-2003 12:01 PM

Pkgtool is pretty easy.
Installpkg works by also adding the name of the file your installing when you type it.

phatish 07-22-2003 12:02 PM

shaun@Shaun:~$ pkgtool
-bash: pkgtool: command not found

phatish 07-22-2003 12:04 PM

haha.. a total newbie...
could u give me the command to ran instead? like what to type and all
Thanks

aaa 07-22-2003 12:09 PM

Try this:
First cd to the directory where the divx4linux-std-20030428.tar.gz is. Then type:
installpkg divx4linux-std-20030428.tar.gz

phatish 07-22-2003 12:19 PM

shaun@Shaun:~$ installpkg divx4linux-std-20030428.tar.gz
-bash: installpkg: command not found


still cannot

aaa 07-22-2003 12:21 PM

Did you install everything on the slack cd?

phatish 07-22-2003 12:21 PM

tried the pkgtool also

shaun@Shaun:~$ pkgtool divx4linux-std-20030428.tar.gz
-bash: pkgtool: command not found

same error

phatish 07-22-2003 12:22 PM

yes... install everything... the full...every single stuff

aaa 07-22-2003 12:25 PM

Weird. Try searching for them.

phatish 07-22-2003 12:26 PM

found the problem... i did not do the stupid #SU stuff

new error

root@Shaun:/home/shaun# installpkg divx4linux-std-20030428.tar.gz
Cannot install divx4linux-std-20030428.tar.gz: package does not end in .tgz

MasterC 07-22-2003 12:26 PM

That's because he's a user (he/she no sex intended).

In order to use installpkg or pkgtool you have to be root, it's in /sbin

Also, I wouldn't use pkgtool or installpkg on it because it's not a slackpack but rather a standard tarball (likely anway).

Use:
file filename.tar.gz
Where filename.tar.gz is the name of the file.

Then you will see if it is indeed a slackpack. If not, you should follow these instructions:
http://www.linuxquestions.org/questi...ticle&artid=15
And/or these instructions:
http://www.linuxquestions.org/questi...threadid=45094

To install and use it.

:)

Welcome to LQ :)

Cool


All times are GMT -5. The time now is 04:12 AM.