LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   HELP--firewall! (https://www.linuxquestions.org/questions/linux-newbie-8/help-firewall-98586/)

clownstar25 09-30-2003 09:41 AM

HELP--firewall!
 
Hi guys,

I'm a real newbie at this, so go easy on me. I am trying to completely turn off the firewall in RH 8.0. Everytime I go into Security Level Configuration I choose No firewall, but when I go back to check to see if it took it it's back up to High! I've even tried lokkit from the command line. Same thing happens. I'm logged in as root, so there has to be something somewhere that is not letting me turn it off. I'm trying to do this because I'm setting up a MySQL server, but I can't even get the firewall to let me to port 3306. If anybody has any ideas, please let me know. I am about to pull my hair out here!!!

Thanks

thosm 09-30-2003 10:27 AM

Hey ClownStar,

I can't help you with directly with your problem, but once you get your firewall disabled, go check out this great utility:

Guarddog firewall utility

I was having a lot of problems with my firewall until I found this utility. It allows you to check off the ports that you want to allow the different parts of your network access to, i.e. Internet, Local (the machine the firewall is installed on) and LAN, and then writes a corresponding set of rules. It gives you a lot of preconfigured port selections, (I believe MySQL is included) and the ability to define your own. This is a well designed program, laid out in a very instructive way.

If you need IP masquerading, you will need to install a companion utility called Guidedog, also available at the same site.

Good luck,
Tom Murray

/bin/bash 09-30-2003 10:37 PM

Try this:
/sbin/chkconfig --list|grep fire
If you have a firewall or firewalld listed then disable it like this:
/sbin/chkconfig --level 12345 firewall off
service firewall stop

If that doesn't work then you need to find out the name of the service that launches the RedHat firewall. This may work:
grep iptables /etc/rc.d/init.d/*

Then use the above chkconfig command to disable the service and
service <iptables> stop
To shut it down.

AshleyK 10-03-2003 02:52 AM

From Gnome or KDS menu, select Server Settings - Services. Find iptables and uncheck. Also hit the STop Service button. Save, and then change runlevel to either 3 or 5 (you will be in the other) and uncheck iptables again. When you restart machine, iptables service will not start.

HIH
Ashley


All times are GMT -5. The time now is 02:47 PM.