-   Linux - Newbie (
-   -   Help connecting to WiFi using Broadcom BCM4313 (

kiki strumm3r 03-20-2012 01:17 AM

Help connecting to WiFi using Broadcom BCM4313
I downloaded the drivers from Broadcom's website ( I have a 64-bit processor and dowloaded the 64-bit tar. I think I installed it incorrectly because whenever I connect to the internet via wifi my computer freezes and has to be powered down. Should I untar it from the terminal? I mean I really have no idea. It could be something completely different. The only other thing I can think of is that I'm using Fedora 16 and there is some incompatibility in the driver, but I don't see why that would be an issue.

EricTRA 03-20-2012 03:01 AM


Can you provide some more information? What exactly did you do, I mean how did you install the driver? Where there any errors when executing those commands? If so, what were the errors? What's the output of:


Kind regards,


kiki strumm3r 03-20-2012 08:45 PM

1 Attachment(s)
How did I install the driver? Well I'm not really sure. I downloaded the tar and extracted the files to the desktop. The website says "NOTE: You must read the LICENSE.TXT file in the lib directory [the tar contains lib & src directories, and a makefile] before using this software." So I opened the file, but my computer said it was an executable. I executed it anyways, and when I went to look at my 'Network Connections', I could use the wireless tab. So I tried connecting to my home network, and it froze twice.

I attached a screenshot of the results. (Yes, I know I shouldn't always be working in the root)

dsplayer14 03-20-2012 09:09 PM

Did you follow the README.TXT file on the Broadcom website? I feel like you might have installed your driver a different way. Ive followed it that way and it works everytime.

kiki strumm3r 04-25-2012 01:06 AM

2 Attachment(s)
yeah so initially what I did was to just doubleclick on the makefile. I guess it *technically* installed b/c it got the network manager to recognize the BCM4313. So I just went back, read the readme, and tried following directions. I attached two screenshots to show what codes I have run on the command line. After the first screenshot, I installed kernel-devel. My problem currently is when I try to make the makefile, it tells me a directory doesn't exist.

EricTRA 04-25-2012 01:52 AM


Do you have the header files for the your kernel installed? If I'm not mistaking it's called kernel-headers in Fedora. Looks like it's looking for the header files and cannot find them.

Kind regards,


kiki strumm3r 05-06-2012 12:05 AM

I just ran the command:

yum install kernel*

and tried to make the makefile. The same error happened.

glennT 06-08-2012 01:21 PM

I got to the same place--it wouldn't compile. Not necessarily the same reason, but the same effect. (By the way, this is on an HP g6 and fedora 17).
So after I tried using the hybrid driver from broadcom, I tried using the built in driver (brcmsmac). Both failed. (Actually brcmsmac worked, but poorly and not with all routers.)

I ended up getting these rpms online (since I couldn't use yum), and going oldschool with 'rpm -ivh <all-three-files>'. Of course you need the fc16 versions, and maybe 32 bit....
> broadcom-wl-
> kmod-wl-3.3.4-5.fc17.x86_64-
> kmod-wl-
I also had to add these lines to /etc/modprobe.d/blacklist.conf
blacklist b43
blacklist brcmsmac

Once I got that straight, I get a strong signal and fast connection.

Hope this is helpful to you.

All times are GMT -5. The time now is 01:55 AM.